Skip to main content
AT&T Community Forums
mkenny28

Teacher

 • 

19 Messages

Sat, Sep 7, 2019 10:57 PM

Have to turn off WiFi to receive MMS

As the title says: At least once or twice per day I have to turn WiFi off on my Note 10+ in order to receive MMS (sometimes up this dozen times per day). I have WiFi calling on so not sure if that is the problem or not. Using Android Messages instead of stock Samsung Messages but it seems to be the same behavior regardless of what I use.

Responses

mkenny28

Teacher

 • 

19 Messages

a year ago

Anyone????? 

mkenny28

Teacher

 • 

19 Messages

a year ago

Ok let's try this again: Can anyone please help me with my issue? It is driving me nuts.

QuarryRye

Master

 • 

3.2K Messages

a year ago

MMS goes through the cellular network, it will not go through Wi-Fi. If you're not getting MMS when Wi-Fi is on, then the Wi-Fi is somehow blocking the cell data. Why that's happening is a mystery without more details.


Is the Note 10 unlocked or did you buy it from AT&T?
If it's unlocked, did you update the APN settings?
When the Wi-Fi is off, do you get a 4G or 3G data symbol?
What city and state are you in?


Honestly, you'd probably get farther and get a faster response by calling AT&T. We're mostly volunteers on this forum.

**Disclaimer: I don't work for AT&T, have never worked for AT&T, and have never been compensated by them in any way, shape, or form**
mkenny28

Teacher

 • 

19 Messages

a year ago

I have attempted tech support multiple times but they seem more interested with getting me off the phone than anything. That probably isn't fair of me to say because they are actually trying to help, no one seems to know how to though. This is an AT&T branded Note 10+. After experimenting it appears WiFi Calling stops MMS from coming in if several come in around the same time.Turning Wifi Calling off appears to fix the MMS issue but every so often I still have to turn Wifi off to get them. It is like it just isn't switch to cellto receive them.  When Wifi is off I am on 4G LTE and I am in New Orleans, LA on the latest AT&T software. 

Tutor

 • 

3 Messages

a year ago

I am also experiencing the same problem as you are. I also have the Note 10 plus from AT&T and it started happening a couple of weeks ago. It was working fine before. I've also contacted At&t tech support a couple of times and they were not able to help me. I've tried everything. I've done factory reset and checked all the settings with no luck.  I will probably try Samsung support soon. 

Contributor

 • 

1 Message

a year ago

Same exact scenario, except I'm still on an S8+. AT&T device, DFW, 4G LTE when wifi is off, happens on any wifi I'm on, but isn't super consistent, using Google Msgs instead of Samsung msgs. 

 

Sometimes I get MMS, but it does seem it's limited to when you receive a couple at a time, like when someone sends a pic via group MMS, along with text copy in the same message. Additionally, when it's between people on iOS vs Android, I can't tell if that has anything to do with it. 

 

Regardless, it's frustrating as I do like the idea of wifi calling and messages being delivered via WiFi when cell is weak or whatever, but it's frustrating when on a family group message and something relatively important is sent through, but I don't receive it until I leave the building a few hours later and wifi disconnects and I get the message late. 

Tutor

 • 

3 Messages

a year ago

A member in another forum had a fix that worked for me. Enable developer option and under networking, enable mobile data always active. So far I've been receiving my mms like before under wifi. To enable developer option, just go to settings, about phone, software information, then keep clicking on build number until developer option is enabled. Then go back to settings and you should see developer option on the bottom. Hope this helps for now until Samsung or AT&T fixes the problem. 

behenchod

New Member

 • 

18 Messages

Mobile data always active, that actually prevents wifi calling from turning on. So your "solution" is the same is disabling wifi calling. Thanks

Coach

 • 

2 Messages

a year ago

I am having the same issue for a while now not being able to receive MMS messages on WiFi. It started with my Samsung Galaxy S7 Edge late last year. Blaming my phone thinking because it's old and started to get slow. I finally got the Note 10+ only to be stuck with the same issue. Tried Google Messages app, that didn't work. Thanks @Airic21, I'll try this out tomorrow.

 

BUT Seriously AT&T, fix it already!!! I doubt this is a  Samsung firmware issue. My old Galaxy S7 Edge used to get MMS over Wifi and then it stopped. This definitely started happening after an update that got pushed through. I can't believe not more people are complaining or is it only certain AT&T customers that are being targeted? 

Contributor

 • 

1 Message

a year ago

Here are more details. Problem exists with Wifi calling enabled. Turning of wifi calling allows mms to work with wifi enabled. Other vendors have a "prefer celluar" option for wifi calling to solve this. Att has no options. I have Samsung 8, wish att would fix this.

Tutor

 • 

2 Messages

a year ago

I have had the same problem. Was suggested i do a factory reset. Didnt work. Turns out this is a known issue and I went through all that and redoing my settings for nothing... Other folks out there reporting same issue. They say enabling developer options and choosing to enable option to keep wireless data active works, but i have tried that and it only works sometimes... this is a pain and going on several months. AT&T really needs to get a fix out for get the manufacturer to fix this. It is getting absurd.

behenchod

New Member

 • 

18 Messages

Because setting data to stay active prevents wifi calling from enabling. Getting to a place with no service switches to wifi calling and the problem with no MMS arises once again.

Contributor

 • 

1 Message

a year ago

Thank you Thank you thank you!!  This has been an issue for as long as the September updates I think  I'm on a note 9 and wasn't getting any pics via mms in my house.  The solution you give above works for me. Hopefully ATT will fix this, I've already reached out to support several times 

 

Thank you again!!! 

 

behenchod

New Member

 • 

18 Messages

No the solution doesn't work. It actually prevents wifi calling from actually enabling. Turn off wifi calling, you have the same "solution"

Contributor

 • 

2 Messages

a year ago

  • All of a sudden Im having issues with messaging on ATT again. I called a few weeks back because I cannot send or recieve messages or files/pics while on wifi. I have ALWAYS been able to send MMs and receive MMS while on wifi.  Im already in Developer mode and have been for years with the option for leaving mobile data always on in background and that does not make a differenc .  She suggested that we "reset my line connection" and that still didnt work. I have rebooted, cleared all my cache, uninstalled any recent apps i may have downloaded, run anti virus and still, nothing fixes it. Now today, the advanced messaging feature has stopped working. Im not the only one having these issues. My sisters, mom and boyfriend are ALL experiencing the same issue on a wide variety of phones. This is obviously an ATT issue and not a phone software issue and i see many other forums ho unanswered with these same issues recently. When is ATT gonna fix these issues???? I will not continue to pay for this crappy service with ATT and will go somewhere else with money if ita not addressed and fixed promptly.  I have been a devoted customer clear back to the Houston Cellular, Cingular, and now ATT days....please fix these issues and stop running us all around!!!

New Member

 • 

1 Message

10 months ago

Found a super simple solution. Turn off advanced messaging in the settings and bam I can send mms over wifi now.
behenchod

New Member

 • 

18 Messages

YOUR SUPER SIMPLE SOLUTION SIMPLY WORKS. Thanks a bunch. This needs to be marked as the solution. Now it's up to Samsung to have a solution to use advanced messaging over WiFi Calling... although honestly I have found zero benefits to using advanced messaging, as my videos still resize to dial up internet quality, so not using advanced messaging is really no problem. Again, thanks

New Member

 • 

1 Message

Thank you so much, this totally worked!!!

New Member

 • 

1 Message

8 months ago

I testing out the theory with my iphone 11. The group text is super buggy. ATT and Apple is playing dumb and the blame game. This one is something we have to figure out on our own. My best guess is, its the wifi. Because iMessage pull messages from any data source. Then when MMS comes in, phone gets confused between wifi and cellular. Just my guess, anyone else found a solution?

If you do a general internet search, this problem is pretty dated. ATT and Apple still haven't care to find an answer.

New Member

 • 

2 Messages

7 months ago

Just spent a loooong time with this again and what ultimately worked, this time, was clearing the cache on the Messages app.

Settings-Apps-Messages-Storage-Clear Cache. I have both Wifi and Wifi Calling enabled.

And good thing it worked because my mobile data doesn't seem to work at all (can't get to any web site with wifi disabled), even though I show 4-5 bars of 5G-E.

Get started...

Ask a new question