Get the new iPhone 15, iPhone 15 Plus, iPhone 15 Pro & iPhone 15 Pro Max from AT&T Now!
Protect yourself online

New Member


2 Messages

Friday, July 16th, 2021 5:32 PM


Can't Reload ATT McAfee Security Suite

I had to reload Win10 to fix a technical glitch.  Fixed the glitch, but it wiped out my ATT McAfee Security Suite.  When I got to ATT to reload it, I get to "Load English Version" key, and when I click it, I am immediately redirected to McAfee Security for purchase.   No matter what I try, I get the same result.  

This conversation has been merged. Please refer the main conversation:

Unable to Install AT T Internet Security Suite

ACE - Expert


33.1K Messages

2 years ago

Yeah.  Join the dozens of similarly situated customers who have reported the same thing during the past month or so.  AT&T and McAfee still haven't fixed it, and I don't think everyone in the support organization has caught on yet, either.

It's broke.  They're "working on it."  No ETA.

Not finding what you're looking for?