AT&T Holiday Deals & Gifts - Don't miss these holiday deals on the latest devices!
Protect yourself online
boredombulker's profile

Tutor

 • 

22 Messages

Sat, May 22, 2021 2:49 PM

Closed

cannot download mcafee security suite

I can login to my att account, select the option to download the security suite. It takes me to the page where I agree to the terms, once I select that I agree, it redirects me to an error page and says I need to login again, which I do, then it gives me another error page, stating it hit a snag, login again, then redirects me back to the main account overview page. 

Tried calling tech support. The automated system told me that my internet is working fine and refused to let me speak to someone :-/

Any ideas how to resolve this?

This conversation has been merged. Please refer the main conversation:

Unable to Install AT T Internet Security Suite

ATTHelp

Community Support

 • 

204.2K Messages

2 years ago

Let's get your downlead working, @boredombulker!

 

Let us know!

 

CalebP, AT&T Community Specialist 

Tutor

 • 

22 Messages

2 years ago

@ATTHelp yes I just tried clearing cache and using a different browser. I've tried chrome and edge. same thing on both. I've attached the screenshots. 

ATTHelp

Community Support

 • 

204.2K Messages

2 years ago

@boredombulker

 

Using an incognito window worked for one our users in the past.

 

Give it a try and let us know if it worked or not.

 

Aminah, AT&T Community Specialist

teetertotter

ACE - Teacher

 • 

943 Messages

2 years ago

Revised/Updated

If you have Windows 10, you are fully protected.   Run my "Update and Security" every couple days.  

"Virus & Threat Protection"  

Stay protected with Windows Security (microsoft.com)

Windows 10 in S mode FAQ (microsoft.com)

(edited)

Tutor

 • 

22 Messages

2 years ago

@ATTHelp incognito tab doesn't work. Once I select the "get it" button it logs me out and directs me to the same pages I attached above. What is going on? Is this your best answer? This is quite ridiculous....

Tutor

 • 

22 Messages

2 years ago

@teetertotter what does this have to do with my post?

ATTHelp

Community Support

 • 

204.2K Messages

2 years ago

@boredombulker

 

Are you logged into the account with the primary user ID and not letting the password be auto-generated from your browser's saved passwords?

 

Aminah, AT&T Community Specialist

Tutor

 • 

22 Messages

2 years ago

@ATTHelp yes I am logged in with the primary user is. It's the only one I have. Yes, I manually typed the login credentials. 

One thing I did notice is that I can login into uverse internet login but cannot login the att internet login. When I log into uverse internet, then go to download mcafee, it logs me out.

ATTHelp

Community Support

 • 

204.2K Messages

2 years ago

We're here to help, @boredombulker.

 

 

Here is more information on the AT&T internet security suite. Scroll down to the requirement section for mac or windows depending on your device to make sure your device meets the requirements. 

 

 

Let us know if this helps. 

 

 

Elmi, AT&T Community Specialist. 

Tutor

 • 

22 Messages

2 years ago

@ATTHelp I'm not sure what you are getting at. Yes, I meet all of the requirements. I am an ATT internet customer and my Windows PC meets the required specifications.

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.