Get the new iPhone 15, iPhone 15 Plus, iPhone 15 Pro & iPhone 15 Pro Max from AT&T Now!
Protect yourself online
LaureBelle's profile



2 Messages

Thursday, July 11th, 2019 12:58 AM

Cannot access my eMail through

I have always accessed my AT&T ( email account through Yahoo. For the past month, after I put in my email address, I get redirected to, where I have to re-enter my email address, and enter the password. I am then re-directed back to Yahoo where I can access my Mail.


Except today... On redirect to, after I enter my email address and password, I get the error message "Please make sure that your User ID and Password are both correct, and try again." The email address and password I entered are correct, after the first two failures I typed them onto a notepad, then copied and pasted them in, but still I'm getting that error message. I've closed out my browser, clearing the cache, tried again, same message.


I was worried that someone had hacked my email and changed the password, so I tried to signin to my account, which is the same email and password, and I logged in successfully. Obviously, that is how I found this forum. I do not need instruction on how to reset my password, thanks...


1. Why is my signin now redirecting to to signin?

2. Why does my email/password combination work to sign into my account, but no longer work to sign into my yahoo/email account?


Please help, I really need to access my Primary email. I am writing this from my Secondary AT&T/Yahoo email account, which I am able to access today, so I will get a notice if you reply.

Accepted Solution

Official Solution



2 Messages

4 years ago


I followed the instruction to Access your email on the web on the following page, and was able to successfully log in to my email that way.


I will continue to access my email via > Mail from now on, hopefully it will be more reliable than starting at This is not the first time I've had problems with that redirect to not accepting my correct email address or password.


Yahoo + ATT email signin behavior has changed, and it's quite buggy now.


Not finding what you're looking for?