Protect yourself online
J

New Member

 • 

1 Message

Thursday, February 11th, 2021 9:01 PM

550 5.2.1 ... blank mailhost - invalid address, relay=[209.85.166.172]

I got this and can't get email. I can send but I can't recieve. Whats up? I pay for DSL service which is frustrating enough now I can't use the email?

ATTHelp

Community Support

 • 

207.3K Messages

2 years ago

We're here to help @JKlajones, with sending emails.

 

  • Have you check to make sure that your server settings are correct?
  • How are you accessing your emails?
  • Have you trying signing in at http://sm.att.com/e05b5109 to see if you can send emails there?
  • We would also suggest that you try changing the password to sync your account.
  • Resolve email issues

Please let us know so we can better assist you.

 

Charles, AT&T Community Specialist

New Member

 • 

1 Message

2 years ago

I have the same issue.  I have tried everything and still can't receive emails.  I can send but can't receive. 

Contributor

 • 

2 Messages

2 years ago

Same thing, not receiving any email at my bellsouth.net account.  However I can send out email.  I tested this by sending an email from my bellsouth account to a non bellsouth account. It was delivered ok.  I then clicked reply to send the email back to my bellsouth account and got it returned as undeliverable with this message "blank mailhost - invalid address, relay=[66.163.185.148]"

(edited)

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.