Need help connecting your router?
prbroste's profile

Tutor

 • 

4 Messages

Monday, January 30th, 2012 5:35 PM

iMac fails to connect to AT&T U-verse via ethernet

I'm not a noob when it comes to my mac, but I don't know much about networking.  This problem has me really stumped:

 

For months, my iMac was connected to my U-verse router via ethernet, by way of my time capsule as a router.  Connecting to the internet via time capsule airport works fine.  No problems there.

 

Now, starting about a month ago, my iMac won't connect to the network.  When I run network diagnostics, "Ethernet" is green "Network Settings" is Yellow "ISP" is green  everything else is red.

 

In my Network control panel, under ethernet, my status is connected.  It says: 

"Ethernet has a self-assigned IP address and will not be able to connect to the Internet."

 

Configure IPv4 is set to "Using DHCP."

 

Things I've tried are:

 

-Restarting my computer and both routers.

-Creating a new network location under prefs and starting from scratch.

-Setting my time capsule to "bridge mode."

 

My setup again is:

2011 iMac

Mac OSX 10.6.8

ethernet to a time capsule

timecapsule ethernet to U-verse router

ethernet connection is down

airport works fine

 

Thanks for any help you can provide!

 

 

 

Accepted Solution

Official Solution

Tutor

 • 

4 Messages

12 years ago

Thanks for your help, but I found it! There was a faulty coupling in my Ethernet line that was letting just enough info through to give the impression that I was connected. I replaced the coupling and now it works!

Master

 • 

4.2K Messages

12 years ago

Will it connect at all wi-fi or ethernet from your post not sure which one is currently not working and Apple released new Airport firmware today so you might want to load it 6.0.

Tutor

 • 

4 Messages

12 years ago

Other devices have no problem connecting via wifi, but my iMac is out of wif fi range, and will not connect via Ethernet. Thanks for the heads up about the firmware update. I'll check it out!

Tutor

 • 

4 Messages

12 years ago

My timcapsule firmware appears to be up to date. Oh well.

Master

 • 

4.2K Messages

12 years ago

Are you turning your wi-fi off when you connect using ethernet as a default Mac's will try and connect via wi-fi (5GHz priority) newer ones anyway?

Also edit your preferences in internet connections and start over

I have not run into one that would not connect via ethernet unless the cable or nic card was bad.

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.