We Still Have Great Cyber Week Deals: Check out our $5 and under smartphone deals!
Need help with your equipment?
viento's profile

Tutor

 • 

4 Messages

Thu, Jan 29, 2015 8:11 PM

Roku won't connect to internet

For over two weeks I have been trying to get someone from at&t to help me figure this out.  One customer service rep tried to help but when I tried to use the roku later that day, it still wouldn't connect.  Roku says that the dns settings are the problem and that I need to change the dns address.  I can't find a way to do that though.  Any one know how to do this with an att router?

mitchflorida

Scholar

 • 

222 Messages

8 years ago

  If your Roku won't connect is it wireless?  do you have the right password? DNS has nothing to do with connecting Roku.  Most likely she means IP address.

Jeffster

ACE - Professor

 • 

2.6K Messages

8 years ago

I have a roku player for years and have no problem connecting to the Internet.

 

If you are trying to connect wireless you might want to try a wired connection.

 

Also try asking your question on the Roku forum.

aviewer

Expert

 • 

10.1K Messages

8 years ago

One suggestion is to try it without security.

 

Another is to use it wired - If your STB is connected to the RG via COAX you can connect it to the network jack on the STB.

 

There were some posts on similar problems with Samsung smart TV & one solution was to change the DNS server to reach the internet. This is done in the Samsung.

 

So, the two problem areas are a connection - physical or wireless & access to the internet (DNS) (set in the Roku)

Tutor

 • 

4 Messages

8 years ago

So I did find that others have had this problem and solved it buy changing the dns address but I am having no luck trying to change it on my att router.  It appears that you can not change the dns address for att uverse routers.  I'm hoping that is not true.  Has anyone had success doing such?



 

There were some posts on similar problems with Samsung smart TV & one solution was to change the DNS server to reach the internet. This is done in the Samsung.

 

 


 

aviewer

Expert

 • 

10.1K Messages

8 years ago

True, DNS is changed on devices, not the u-verse router.

Tutor

 • 

4 Messages

8 years ago


@mitchflorida wrote:

  If your Roku won't connect is it wireless?  do you have the right password? DNS has nothing to do with connecting Roku.  Most likely she means IP address.


I do have the right password.  I can connect to wireless and network but when it gets to internet connection in set up, it's a no go.  First Roku said it was security problem and now they say it is DNS address not being a public address.  I simply can't get either roku or att to effectively help me.

Tutor

 • 

4 Messages

8 years ago

My understanding is that you can do both.  I don't however see how I can change it on my roku device itself.  I do know how to get to the dns settings but it appears that att has a lock on that.

mibrnsurg

Expert

 • 

20.4K Messages

8 years ago


@viento wrote:

For over two weeks I have been trying to get someone from at&t to help me figure this out.  One customer service rep tried to help but when I tried to use the roku later that day, it still wouldn't connect.  Roku says that the dns settings are the problem and that I need to change the dns address.  I can't find a way to do that though.  Any one know how to do this with an att router?


Have you seen these instructions?

 

http://forums.att.com/t5/Third-Party-Devices/Roku-3-Wireless-Setup/td-p/4115146

Smiley Surprised

 

Chris
__________________________________________________________

Please NO SD stretch-o-vision or 480 SD HD Channels
Need Help? PM ATT Uverse Care (all service problems)
ATT Customer Care(all other problems)
Your Results May Vary, In My Humble Opinion
I Call It Like I See It, Simply a U-verse user, nothing more

Contributor

 • 

1 Message

6 years ago

I had the same problem. Had to switch from ATT to Uverse, which meant I had to set up a new wifi network and my Roku would not connect to the new network. I used the correct wifi network name and password over and over again and kept getting an error message that it could't connect. Finally, I reset the Roku (I think from the settings menu) and wa-la! It connected.

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.