Available Now: Buy the new iPhone 14, iPhone 14 Pro and iPhone 14 Pro Max from AT&T!
Need help with your equipment?
manrodman's profile

Tutor

 • 

4 Messages

Fri, Aug 28, 2015 12:39 AM

Macbook Pro will not connect to wireless router (NVG589) | please help

Please help!  $20 to whoever can find the solution!

 

I've wasted hours upon hours trying to figure out a solution to my problem.  My wife's Macbook pro will not connect to the U-Verse wireless router.  I have several devices (PC, Ipad, apple TV, Samsung TV) connected without issue, but for some reason the macbook pro will not connect.  I am able to see the network name, but once I click, I get either a "wrong password" or a "session timeout" message.  I've tried several different things to fix (i.e. reset system, changed channel on router, changed network name/password, etc.), and sometimes it will connect for a few minutes, but then will suddenly disconnect.  I've tried to connect with ATT but they are not very useful. Does anyone have a solution that I can try?  Thank you in advance.  

rdljr

Guru

 • 

921 Messages

7 y مضت

Did you try reinstalling the OSX operating system? What OS are you on? If you can, try hardwiring it into the modem and updating the software.

Tutor

 • 

4 Messages

7 y مضت

Just updated the most recent patch....but did not download Yosemite because of all the current bugs. Don't think that is the issue.

rdljr

Guru

 • 

921 Messages

7 y مضت

Try turning off the Bluetooth. You may want to get a separate Wifi router. Considering how you like Apple, you could try the AirPort Extreme or AirPort Time Capsule of you want backups. That made my wifi faster and more stable with all my devices.
aviewer

Expert

 • 

10.1K Messages

7 y مضت

When there ia a wi-fi problem, I am thinking that one of the testing steps is to connect without security - no password. If this works, it says the wi-fi is good, there is some problem with password.

 

If you still cannot connect you know it is the wi-fi.

 

I seem to remember, some version of mac was adding a character to the pasword. LIke #.Makes no sense, but that is what I remember.

rdljr

Guru

 • 

921 Messages

7 y مضت

I read with the 2wires, you had to use a $, but with OS X and NVG589, you don't. I don't think it will work, but it's worth a shot.

Tutor

 • 

4 Messages

7 y مضت

Thanks. Yes, it works without security, but didn't work with WPA2. I actually have had it working for the past hour, but am not optimistic that it will be a permanent fix. If you are curious, I went system preferences in Mac, selected the network tab, clicked advances tab then clicked the DNS tab. Clicked + and entered 208.67.222.222. Then clicked on + again and added 208.67.220.220. Then click ok, apply and restated Mac.

Thoughts?

Tutor

 • 

4 Messages

7 y مضت

Just as I thought....connection not working again. Every other device is fine except MacBook Pro. Can someone please help?

rdljr

Guru

 • 

921 Messages

7 y مضت

If you live near an Apple Store, you can take it there and have them look at it. My MBA had wifi problems and they did sonething to fix it. You could always update to Yosemite because I think they have ironed out the bugs.

Contributor

 • 

2 Messages

7 y مضت

Any luck? I just moved and signed up for AT&T UVerse. Same issue. Everything else works by my Macbook Pro will not connect.  It continues to say "Password Incorrect". Every other device; iMac, iPhone, PS4... all connect.

Contributor

 • 

2 Messages

7 y مضت

Option 1 (Best Option)

Apple Logo (Top Left Corner) -> System Preferences -> Firewall -> Turn Off Firewall...connect to the AT&T wireless network...then go ahead and turn the firewall back on after you've successfully connected at least once. 

 

From here on out you should be set.  Or you could just leave the firewall off if you want (not suggested).

 

Option 2 (Effective if for some reason option 1 doesn't work)

 

Unfortunately I can't remember the exact steps, because I can't get into my router right now, but it goes like this...

1. Start a web browser then Go to - http://192.168.1.254

1a. Since you are not getting Wifi you need to connect your laptop to the router with an ethernet cord to connect.  Newer Macbooks don't have the port, so you may need the Thunderbolt-to-Ethernet adapter ($29 at the Apple Store) 😕

2. Click the wireless option

3. Go to the area that enables you to create a guest (or second wireless network)

4. Create the network, but turn off all security for it (there should be no password)

5. There's an area where it asks you whether you want the SSID broadcasted.  Go ahead and turn it off (this step is optional)

6. On your computer the new guest network should show up as an option.  Connect to it.

6a. If you decided not to broadcast the SSID then you will need to click "Join Other Network".  In the box that shows up type in the name of the network you created that isn't being broadcast.  You will then connect.

 

 

Note: The reason for not broadcasting the SSID (Network name) is simple.  You don't want every one of your neighbors connecting to your network, so if it is not visible to WiFi enabled devices then essentially no one except for people you tell will know the wireless network exists.  Your security is in only you knowing the name of the network.  Hope that makes sense.

 

Those are the two workarounds I found in order to get my MacBook to connect to the wireless.

 

Good luck, AT&T should give me bill credit for me for how many fewer calls they are going to get for this issue!  The username is at the top if you want to find me or hire me 😉

 

- An Engineer Who Works at a Very Large Networking Company

Contributor

 • 

1 Message

6 y مضت

3 macbooks and same issue. Sometimes they connect automajically and other times I have to  manually enter the  Network name and password\ via following these steps.

 

1. Open Network Preferences

2. select Assist Me.

3. select Assistant

4. Hit Continue when you see a Location name.

5. Hit Continue when you see "How do you connect to the internet"

6. Next you will see a wi-fi Network list. Selecting your wireless network will not work. 

You need to scroll to the bottom of the list and select Other wi-fi network and then manually enter in your Network name and password. Strange thing. Sometimes I get a bad password when entering too fast so I wait about 5-10 seconds before I hit enter. 

7. Following the rest of the screens to connect.

 

ATT just sent me a replacement modem that does the exact same thing. They really are Clueless!!

mibrnsurg

Expert

 • 

20.4K Messages

6 y مضت

Actually just putting Google DNS in the Mac gets it connected many times.;)

 

https://developers.google.com/speed/public-dns/docs/using

 

Chris
__________________________________________________________

Please NO SD stretch-o-vision or 480 SD HD Channels
Need Help? PM ATT Uverse Care (all service problems)
ATT Customer Care(billing and all other problems)
Your Results May Vary, In My Humble Opinion
I Call It Like I See It, Simply a U-verse user, nothing more

Contributor

 • 

1 Message

6 y مضت

I have the very same issue with my my AT&T UVerse wireless and my Macbook Pro.  However, every other device, phone, 2 tablets, printer, several TV's,  connect instantaneously to UVerse, so I think this is a Mac problem.  After much trial and error I get my Macbook to connect by doing the following:

  1.  Open network preferences

  2.  Click on the "Assist me"  option at the bottom of the window that opens.

  3.  Then I get a smaller drop down window that says "Do you need assistance setting a ne

       network connection or solving a network problem?"    Click "Assistant"  in this window.

  4.  Next windown to open is a lock on modifying settings.  This box asks me to type in my user

       name and password to change settings.  Type in this information, then click "Modify  

       Settings."

  5.  Next The Network Setup Assistant window opens.  It has the word "Introduction" at the

       top.  It asks you to name your location.  I just let the system put in the name because this

      name does not seem to matter.  Click on "continue."

  6.  Now the Network Setup Assistant window opens.  If "I use AirPort to connect to the Internet wireless is not already selected, select that, then click continue.

  7.  Next I get a box that says "Connect to a Wi-Fi Network".  Scroll all the way to the bottom and choose "Other Wi-Fi Network."   You will probably see your network listed in this list but my experience is that it does not good to click on it.  You must select "Other Wi-Fi Network."

Type in the name of your network and the password. (sometimes it takes a few seconds for the network for the network name strip to appear)  Once name and password are typed in click continue.

  8.  Next window that opens says, "Ready to Connect?"   DO NOT CLICK CONTINUE.

My experience has been that if I click continue in this box I lose the internet connect that

is now established.  You should be able to see that your internet has connected in the bar at

the top of your desktop.   I just click the red circle and close this window, and I do the same for

the Network window that is probably open.

 

Now the bad news:  While this establishes a wireless connection every time I do it, I frequently have to re-do it!   Usually, if I put my computer on "Sleep" rather than turning it off, the network will be there when I wake it up.  However, this is not always the case.  What I can tell you is that this routine works for me.   I'm not a computer geek or a network specialist.  I called AT&T several times and they told me to talk to Apple.  I've found nothing on the Apple site that's helped.  So I developed this procedure by trial and error (lots of error before I got to something that worked!)    I hope you find something simpler, and please post it.  But if you are struggling, give this a try, even as a temporary way of connecting your Apple until we can all find something better.

 

Contributor

 • 

1 Message

6 y مضت

The last option #8 is the only thing that worked !!!!!!!!!!

Contributor

 • 

1 Message

6 y مضت

I have something similar but it is happening on my Mac BooK Air.  It started to happen when I upgraded to El Capitan.  I was hesitant to do so but my Google Chrome kept on saying it is no longer supported with my version of MacOS.

 

My main issue is that I have to do "troubleshooting gymnastics" to get my wi-fi to connect.  I called Apple and they told me to upgrade to Sierra, which I did.  The wi-fi did connect 100% for 2 days and then it went back to intermittenly connect.  I went to the Apple store to do an entire 'sys-wipe,' which did not fix the problem.  I am having AT &T send a new router to see if a new MAC Address will fix it.  My speculation is 10.11 and 10.12 doesn't work with the AT & T router.  If the new router doesn't work, I will likely roll the MacOS back to 10.7 or 10.8.

Need help?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.