Don’t miss your chance to add AT&T Protect Advantage. Peace of mind, starting at $15 per month. Open enrollment ends 3/31. See all protection plans.



1 Message

Thu, Mar 15, 2018 7:05 AM

MacBook Pro 2011 says that it’s connected to network but still has self assigned up address 169.xx

Hello, so I have a late 2011 MacBook Pro. Internet with att has always been a bit spotty, I.e where my sisters MacBook (2015) stays connected, mine would drop from time to time but it didn’t happen often enough to be a problem. Another problem it had was that whenever I opened it, the laptop would buffer for a while searching for the internet but it would eventually find it after like 2-3mins. Again, wasn’t long enough for it to impede my experience. 


Well, one day my MacBook just decided to stop connecting to the internet.


Now, when I open my laptop it would do the same buffering thing except rather than 2-3 mins it would be about 5-6 and then it would settle on “self assigned IP address” with exclamation point on the WiFi logo. If I wait long enough it eventually will find my network and the exclamation point disappears BUT the tcp/ip address is still the self assigned ip one 169.xx


Its annoying because it works sometimes. Never upon when I open it but if I leave it alone for a bit? Then it sometimes is able to connect but it’s unpredictable when it will.


catch is that, my computer is the only one that is having this problem. My phone, and roommates phones and computers (3 iPhones, 2 PCs, 1 2018 MacBook Air) all connect fine. Leading me to believe that my MacBook is the problem.


But, my MacBook connects fine to my personal hotspot or any other WiFi at school or coffee shops. Only my home att connection seems to cause this issue. So maybe it’s a compatibility thing with newer WiFi and old MacBooks ? Idk


ive tried renewing the dhcp  license, restarting my laptop, deleting the WiFi option from the left hand menu on my network  and re-adding, deleting my network name and reconnecting, deleting some files from this one network folder, manually putting in the router, ip addresses and nothing. Still Self-assigned ip  address but saying that it’s connected to the network. 


please help!    


Accepted Solution

Official Solution

Brand User



108.4K Messages

2 years ago

Salutations @MadAsis

Welcome to Community and Forums. It’s disheartening when you experience a spotty connection to a wireless network. I would like to help you get this resolved.

I would recommend doing  the following steps:

1.       Right click the wireless sign in the Task bar, then select Open network and Sharing Center.
2. Select Set up a new connection or network below Change your networking settings.
3. Chose a connection option, choose Manually connect to a wireless network, connect to a hidden network or create a new wireless profile and click Next.
4. Net work name: The same network name that you have.
Security type: Choose WPA2-personal
Encryption type: Choose AES
Security key: Enter the same password that you always use.
Tick the box : Start this connection automatically.
5. Click Next.
6. Go back to Connect wireless pane, select your network name and enter the same password.

If you have any other questions or concerns, please don’t hesitate to let us know.

Jason, Community Specialist

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.