Check out AT&T's Valentine's Day Gift Guide for ideas & deals on the new Samsung Galaxy S23!
Need help with your equipment?
JamesIII's profile

Contributor

 • 

1 Message

Thursday, August 14th, 2014 9:04 PM

Apache server appears to be rate limited / non initial connections refused.

I'm running an Apache server (personal use) which worked perfectly with my previous internet provider. No changes have been made to the server configuration since switching to AT&T.

 

I'm using the nvg589 router that came with my U-Verse internet. In the router settings, under Firewall->Nat/Gaming I have used the "Apache" service to forward port 80/443 traffic to my server. Initial hits to the server work. If I put in my domain name, it will load the page properly. However, a refresh or attempt to follow any links or download anything from the page results in a hanging connection. For example, clicking on a pdf to download may either do nothing or download the first 200kb of the document and then hang. Trying to download a pdf from the site from my phone gives a "Connection closed by peer" error.

 

I've tested on multiple different machines, browsers, and operating systems with the same effects from each. I have tried many different router configurations including setting NAT Default server and IP passthrough, and disabling all the advanced firewall features, but nothing seems to work.

 

How can I get the router to forward 80/443 traffic to my server?

 

EDIT: Upon further analysis, it appears to be some kind of rate limiting. Attempting to download a pdf gives the following behavior: 48KB downloaded immediately, wait exactly two minutes, 96KB downloaded (48KB more), wait exactly two minutes, 192KB downloaded (96KB more), wait exactly two minutes, 240KB downloaded (48KB more), wait exactly two minutes, 336KB downloaded (96KB more), wait exactly two minutes, 432KB downloaded (96KB more), wait exactly two minutes, 480KB downloaded (48 KB more), ...

 

More concisely: 48 96 192 240 240 336 432 480 KB downloaded with EXACTLY two minutes breaks inbetween.

Contributor

 • 

1 Message

7 years ago

I'm having an issue with specific URLs serving an apache server test error and /403 errors, it appears to be due to ATT's internet speed. 

 

Everything we did to circumvent the issue, from my IT guy:

flush dns, reset browers, turned off antivirus, still cant access it. Also when you ask them about your speed tell them that you got a speed of .5mb down and .23mb up when you ran speed test. Make sure you also make them know this happens on multiple devices not just your laptop.

 

Not sure if its exactly the same as the issue above, but it sounds like its similar! 

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.