Skip to main content
AT&T Community Forums
S

New Member

 • 

3 Messages

Sun, Oct 18, 2020 8:27 PM

WPA/WPA2 "not secure" warning

My iPhone displays the message: "WPA/WPA2 (TCKP) is not considered secure. If this is your Wi-Fi network, configure the router to use WPA2 (AES) OR WPA3 security type." 

When I look at the Security specs for my router, it shows "WPA-PSK (TKIP)/WPA2-PSK (AES)."

So I am confused. A search through this Forum shows other people have encountered same, but are either unanswered, or answers are left wanting.

First, that it appears my router is already configured to use WPA2 (AES); and
Secondly, I cannot find where I would UP^ the configuration to WPA3.

I have installed latest upgrades for everything on my Mac and iPhone, and have "forgotten" the prior network and rejoined on my phone. I need solid security due to the Working From Home thing; am using a VPN.

Am I good to go? Or, what to do?
please/thanks

Responses

Brand User
ATTHelp

Community Support

 • 

140.6K Messages

a month ago

We can help with this, @sSmithForum. Thanks for providing us some extra info about your setup.

 

If WPA2 is already enabled, this message may be triggered because the iPhone thinks the Wi-Fi password is not secure enough. Try updating your Wi-Fi password. Choose something more complex than your current setup: longer than eight characters, a mix of capital letters, lowercase letters, and numbers.

 

If that doesn’t fix your problem, can you provide us some more information about your equipment? Specifically:

  • What type of Gateway do you have?
  • What specific version of iOS is your phone running?
  • Does this happen when your iPhone connects to Wi-Fi networks outside of your home?
  • Did this problem first begin when you set up your VPN? And does it occur while the VPN is disabled?

Let us know, @sSmithForum, we’re here to help!

 

Genevieve, AT&T Community Specialist

Still need help? Ask a question! Our 1.4 million members typically respond within 1 hour.

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
bogar90706

Teacher

 • 

89 Messages

a month ago

The routers are by default have WPA/WPA2 enabled to make sure all of your WiFi devices are compatible. If I was you I would just set it to WPA2 only. WPA devices are really old devices so more than likely your WiFi devices are compatible with the WPA2 protocol 

New Member

 • 

3 Messages

a month ago

How do I actually change my router settings?
I'm getting a message on my work laptop that "my connection is not private" so I need to set to WPA2 only. 

New Member

 • 

3 Messages

a month ago

thanks ATTHelp > my password was already terrific

thanks bogar > I knew that my router needed to be set to WPA2 only, just could not see where or how to make that change. Have made it now. Thanks for the help:)

Get started...

Ask a new question