For the mom who gives us everything - Mother's Day gifts that connects us.
ATTHelpForums's profile
Community Support

Community Support


2.7K Messages

Friday, December 29th, 2017 3:28 PM

Troubleshooting your Nintendo Switch

Connecting your Nintendo Switch to Wi-Fi


Make sure you have your Wi-Fi information.



  1. Place the Nintendo Switch within 10 feet of the wireless router to ensure a strong wireless signal.
  2. On the Nintendo Switch console, select "Settings" from the HOME Menu.
    Home Menu.png
  3. Select “Internet”, and then “Internet Settings.”
    Internet Settings.png
    • The Nintendo Switch will automatically search for near-by Wi-Fi signals.
  4. Select the appropriate network name (SSID) from the list.
  5. If prompted, use the onscreen keyboard to enter the network's wireless password.
  6. The Nintendo Switch will test the Internet connection. Once the test is complete, select "OK" to complete the process.

Connection Issues

  • If you are not connected to the 5Ghz connection on your router, try connecting to it to see if there are better results. You may need to change the network name to achieve this.
  • Move your Nintendo Switch closer to the router.
  • Make sure there are no devices around your Nintendo Switch that could interfere with the signal. This includes all items that can cause interference, such as other electronic devices, or wireless interference, such as your cell phone.

David, AT&T Community Specialist

AT&T Help

Need help with an account specific question?  Post a new question here on the forums by clicking the "Ask a Question" button.
For additional support, please visit us at our AT&T services hub.

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.

Still need help? Ask a question! Our 1.4 million members typically respond within 1 hour.

4 Attachments

Accepted Solution

Official Solution

Community Support


2.7K Messages

6 years ago

Need help connecting other devices. Find out more information here.


David, AT&T Community Specialist



1 Message

5 years ago

How can I change my NAT type to make it less strict? I have tried multiple options such as Port Forwarding or a DMZ, but nothing works. I have called customer service multiple times and I cannot even get into the correct department. I am unable to play any Nintendo Switch games online because my NAT Type is too strict.

New Member


2 Messages

First you need to set your Nintendo Switch IP address to a static address. Then you need to set up multiple custom services in the NAT/Gaming section. Start with naming the custom service something like nintendo 1, then set your ports to be from 45000-65535. if you get an error saying port 51001 is reserved, go back and change the range to end at 51000. set up another named nintendo 2 and set the port range from 51002-65535. This excludes the 51001 port that is reserved. If you get another error with a range that conflicts, just reset the 2nd custom service range to end the port before the conflict and set up a third custom service to start the port after and end at 65535. Once this is done, exit back to NAT/Gaming and you will see the new nintendo services is the list. Select them one at a time and assign it to your switch IP address. This worked for me. I read online the Switch only connects through ports 45000-65535, I did not try starting at port 1.

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.