Let AT&T help you elebrate your dad with Father's Day Gifts that connect us.
Overload3979's profile

New Member

 • 

8 Messages

Monday, July 17th, 2023 9:20 PM

Troubleshooting Connection Issue with Modem to Play P2P Game

So I'm trying to play a p2p game called Mobile Suit Gundam: Battle Operation 2 on the pc, and I have this strange issue where I'm unable to play matches that involve a certain number of players. What I mean by that is that the game runs normally and smoothly if I play with 7 other people (8 in total including me) but, the moment I try to play with 10 or more people I disconnect and I lose internet connection. 

I've tried fixing and messing with settings on my end (using VPN, port forwarding, changing DNS etc.) and when that didn't fix anything I contacted the companies support team but nothing really came out of it. 


So now the modem is next on the checklist of what might be causing this issue. I'm asking here in hope of someone knowledgeable offering assistance. 

I have a BGW210-700 modem on software version 4.23.4. 

So in detail what happens is:

1) I join a room with 9 other players and the match starts normally (10 in total including me).

2) At some point in the match, I start lagging and/or desynching and eventually get hit with a message saying you have left/disconnected from the match followed by an in-game network error message.

3) Then after I get those messages my internet will drop. 

(splitting question into 2 parts because it was apparently too long)

New Member

 • 

8 Messages

11 months ago

(ok part 2 of 4 because it apparently comments have a much smaller allowed character limit)

I have taken multiple looks at the modem when that happens but there weren't any red lights and when accessing the modem's status page it said the broadband connection status was up.

New Member

 • 

8 Messages

11 months ago

(part 3 of 4)

I ran the modem's full diagnostics while my internet was down and the only part that failed was the IP check (DNS check was skipped), when looking at details it says:Check IP connection to Ethernet- Pass, Validate Broadband assigned IP address- Pass, Ping default gateway- Fail.

New Member

 • 

8 Messages

11 months ago

(part 4 of 4)

My computer did not give any message that I disconnected from the internet, nor did my devices connected to the modem via wifi lose wifi connection. But every device using that modem was unable to use the internet (browsers unable to load pages, videos not playing, etc.). 

How long it takes for the internet to come back is random, fastest is 5 seconds and slowest is 2-3 minutes.

The problem is very consistent and I can reliably cause the disconnect to happen.

Does this seem like an issue with the modem or would the source of the problem stem from somewhere else that I'm not thinking of?

(I'm really sorry for writing my question like this but it was the only way to write my long question without the site giving me an error message)

(edited)

Community Support

 • 

232.8K Messages

11 months ago

Glad to help with your gaming issue, Overload3979.

 

Your best option would be to factory reset your gateway. Locate the small red button and pinhole on the lower rear of the gateway and depress for ~15 seconds.

 

If you still need assistance, let us know if you're using any 3rd party equipment behind the AT&T gateway and if your service works fine when you're not playing the game.

 

Aminah, AT&T Community Specialist

New Member

 • 

8 Messages

11 months ago

@ATTHelp 

Hi, I just tried after factory resetting my modem and there doesn't seem to be any real improvements.

And I am not using any 3rd party equipment behind the modem, the modem is connected into the wall and I connect my pc to the modem with an ethernet cable.

There's never really any issues when using the internet normally and aside from this game I never really played any other p2p games that connected me to this many people at once. 

Community Support

 • 

232.8K Messages

11 months ago

From what we've found from looking into the game, there are quite a few complaints about connection problems, Overload3979.

 

That in addition to the fact that there are no other problems with your service leads us to believe that you should reach out to the game's support team again to see what they can do.

 

If you need help with any other aspect of your service, let us know.

 

Thank you for visiting the AT&T Community Forums.

 

Aminah, AT&T Community Specialist

New Member

 • 

8 Messages

11 months ago

Yes, there were many connection issues during the first week of launch; however, overall the issue has subsided to a point where many are able to play normally. Also, I have gone around asking various forums talking about my specific issue and have found no other case of this occurrence. The connection problems that most others are facing currently have more to do with having difficulty finding matches and people with weak connections being forced to host matches by the game, causing that match to lag and the room to disappear. 

I do not have those issues, the game plays fine when there are 8 or less people in total in a room. However, the moment I try playing a match with 10 or more people, I will disconnect and my internet will drop. 

According to the modem everything is running fine but is unable to ping the default gateway. I will contact them again but the development teams stance on the issue currently seems to be that connection issues stem from the players side. 

Does the modem save any logs? perhaps error logs to try and see what is causing the ping to default gateway to fail?

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.