Announcements

For the latest on our response to Coronavirus (COVID-19), click here.

New Member

 • 

6 Messages

Sat, Jan 18, 2020 5:29 PM

Sporadic failures of ssh into PC through 5268AC gateway

I have my gateway configured to open a pinhole for port 22137 and forward it to port 22 on a Linux PC on my network. Sometimes it works, sometimes the attempt times out. If I keep trying, eventually it works. It's as if the gateway had a rule something like "only allow one incoming connection per minute". If I ssh from another computer on my LAN, it always works, so it seems like the problem has to be with the gateway. This problem started after a much older model of gateway was replaced.

Responses

New Member

 • 

6 Messages

3 months ago

P.S. It occurs to me that someone might wonder why I need to make frequent ssh connections. It's because I'm running a Mercurial server. Each individual operation, like "are there any changes to pull from repository A", or "how about repository B", or "push my changes to repository C" is going to create a separate ssh connection.

New Member

 • 

6 Messages

After putting the Linux PC in DMZ mode, the ssh connection always starts. But if I try to transfer much data, it always stalls out right at 64 KB with a broken pipe.

New Member

 • 

134 Messages

3 months ago

I have the same problem SSHing and VNCing to systems on my network. I've had it timeout several times and boot me out even when I was at a shell.

The Pace 5268AC is really bad - especially its WIFI. i just said screw it and stuck another wireless router in bridge mode between my LAN and the gateway and have not had the problem since.

It's not something we should have to do but it's not like they are ever going to fix it. The only firmware upgrade they pushed out in a year I had the service was one to force you to use the AT&T proprietary speed test so we know their priorities.

(edited)

New Member

 • 

6 Messages

@malleable_malus when you said you have "not had the problem since", you mean the problem with WiFi, or the problem with SSH?

New Member

 • 

134 Messages

@jwwalkersd Both. I complete disabled both wi-fi radios on the gateway.

Reading your original post again, I might have misunderstood. Are you trying to remote SSH into the Linux PC on your LAN from outside the network/from the internet? I only SSH/VNC among systems on my LAN (via WiFI) so my suggestion probably doesn't apply, especially if your Linux PC is hardwired to an Ethernet port on the gateway. Sorry about that.

(edited)

New Member

 • 

6 Messages

Yes, I want to ssh in from outside my home. And yes, the Linux PC is hooked to the gateway by Ethernet, not wifi.

New Member

 • 

4 Messages

Something like disallow remote connections is not checked? A long time with another ISP i was setting up port forwarding/tunneling and couldn't get it to work.

Turns out the ISP had a gateway GUI that had some additional admin/remote config features like allowing outside connections. Or allowing single IP connections only.

Any chance something like that is the cause here?

New Member

 • 

6 Messages

I finally got things working. One change, which may or may not be relevant, is that I set the sshd configuration on the PC to use the nonstandard port, so that I didn't have to use port forwarding, just a plain pinhole. The other change is that I updated the gateway's firmware from version 11.4.1.532484 to 11.5.1.532678 using a link found at dslreports.com.

AT&T TV – All Your Entertainment In One Spot.  Learn more…