lisfolks's profile
lisfolks
Helpful 1
Supersonic 25!
#1 Star!

Mentor

 • 

40 Messages

Tuesday, October 4th, 2011 2:28 PM

NVG510 Bridge Mode???

Just switched from DSL (Motorola 2210) to UVerse (Motorola NVG510). I set the 2210 into bridge mode and ran my home network from an Apple Airport Extreme Base Station (AEBS). I have some complex configurations on my network and figured I'd be able to do the same thing with the NVG510. However, it seems the NVG510 uses different terminology than I am used to.

 

Under Firewall/IP Passthrough, I set:

Allocation Mode to 'Passthrough'

Passthrough Mode to 'DHCPS-Fixed'

Passthrough Fixed MAC Address to the AEBS' MAC address

And, I left the Lease at the default 10 minutes.

 

On the AEBS, under Internet/Internet Connection, I switched from 'PPPoE' to 'Ethernet'. I left the Ethernet WAN Port value at 'Automatic (Default)'. And Connection Sharing is set to 'Share a public IP address'.

 

This apparently is not enough, though. The AEBS reports that the "Wi-Fi base station does not have a valid IP address", and that there is a "Conflicting DHCP Range".

 

How do I turn off the DHCP on the NVG510? And, what are the correct settings to put the NVG510 into bridged mode?

lisfolks

Mentor

 • 

40 Messages

9 years ago

Some people, maybe; but the gateway definitely has a problem. It's been known now for a very long time, and Motorola says they made the Gateway the way AT&T told them to. (The Motorola tech noted also that they had never seen a setup like this one before on any modem/router they've made, and were shocked that AT&T designed it that way.)

 

One firmware update has come out in the life of this gateway. It fixed a couple of things related to port forwarding and VPN, but rare AT&T techs have even admitted that they're aware of a long list of issues with this gateway, including the DNS problems.

 

I'm sure AT&T has tons of people with only one or two computers on their network and no special setup - thus needing no second router or other special settings. The rest of us are probably just flies buzzing around their ears. We apparently don't make enough of a financial dent to make it worth the company's while to get this fixed ASAP.

 

fmalloy

Tutor

 • 

8 Messages

9 years ago

Very sorry to hear this. 

 

In my case, I connected the RG to my AEBS which sets DHCP/NAT to multiple devices. The AEBS warns me about "Double NAT", but everything was working...except for the baby cam. I have a Foscam IP baby cam on a reserved NAT address, and it no longer is accessible on the dedicated web page. I can only view the cam on the LAN. I am not a network expert but I assume the double NAT is not allowing the web site to find the IP address of the camera on the WAN. 

 

I assume I am going to have to try the pseudo bridge mode and hope that resolves the problem.

 

I was using AT&T DSL with dumb Speedstream modem and all was fine. Now, I "upgrade* to U-verse and expect everything to be better....instead, problems.

 

Very sad.

fmalloy

Tutor

 • 

8 Messages

9 years ago

Motorola recommends using Passthrough Mode of DHCPS-Dynamic, not Fixed:

 

http://broadband.custhelp.com/app/answers/detail/a_id/21979/kw/nvg510%20bridge%20mode

 

In this case, what IP address is actually passed through?

 

I need to set up a bridge mode so I can access my IP camera from a web page using my WEBS. Will this do it, or do I need to use Fixed?

Tutor

 • 

3 Messages

9 years ago

You need to change one of your devices (either the gateway or another router) to operate on different subnets.  Its the first step on many of these "fixes" to avoid problems like that from the get-go.

donluz

Teacher

 • 

3 Messages

9 years ago

It is indeed possible to do this; I am doing it right now using a Linksys E3000 as the router and the Motorola NVG510 as a pass-through.

 

I did the following:

 

- I set the IP of the router to 192.168.1.1 and then use a different subnet for my internal home network (e.g. 192.168.0.1-10).

 

- key setting on the NVG510 is under "Firewall | IP Passthrough".  Settings (default address of NVG is 192.168.1.254 in order to make these changes):

 

allocation mode:  default server

default server internal address:  192.168.1.1

 

- you'll need to reboot NVG once saving these settings.

 

- you'll also want to turn OFF the wireless signal for the modem just to reduce potential interferance from your router. 

 

Hope this helps!

Tutor

 • 

4 Messages

9 years ago

So your solution is to manually set the settings. As for the missing stuff you can just connect directly to the modem or get the settings from the modem b4 you set it to Passthrough. I'm not using an Airport device but rather a Dlink router and saw some of the same weird thing.

When surfing on WIFI using phones when opening the pages it always took long, quite annoying, and seeing this I tried it and boom its fine now. lol you know what is funny too. I had my router set to clone the same MAC as a PC on the network and while that PC was directly connected to the ATT modem/router it was getting the IP address too and surfed. getting no IP conflict at all. it was fine...weird right? After changing that though I still had the issue until using a manual config for the router's (a Dlink DIR-825) WAN settings.

Also weird is the ATT router is giving out that 1 address to a device that I cannot find. I disconnected all cables from it and it still showed up. I assumed it to be my DLINK but nope.... It says it is on Ethernet and using DHCP but while nothing at all is connected to it, it still shows up even after a reboot. Weird stuff.

Contributor

 • 

1 Message

8 years ago

For what its worth, I was able to get this to work just by changing the Firewall settings to passthrough with DHCPS-fixed and supplying the mac address of my router. After the reboot of the NVG510 I also rebooted my router.

 

-William

 

Contributor

 • 

1 Message

6 years ago

This worked for me with a 4th gen AEBS. Thanks so much!

fpuppy

Teacher

 • 

16 Messages

6 years ago

I had been using Jordan Earl's hack for years on these modems to achieve "true" bridge mode, but recent updates by AT&T have been causing problems with modems I've set up that way.  I finally changed one of my clients to the setup posted by lisfolks at the beginning of this thread and ran it successfully that way for the last couple of weeks.

 

After revisiting the problem and reading this entire thread today, I tested some more configurations and came up with the following setup (starting with NVG510 defaults):

 

1.  You don't need to change anything in Home Network -> Subnets & DHCP if you don't want to: the NVG510's DHCP server will hand the public IP off to the device specified below (which is presumed to be connected to one of the LAN ports of the NVG510).  Any other devices connected directly to the NVG510 (either wirelessly (if you don't disable it in step 2. below) or via the other LAN ports on the NVG510) will get IP addresses in the default subnet (192.168.1.nnn) and will be able to access the internet but NOT see any devices behind your "real" router (assuming you have it set up on a different subnet!!).

 

2.  Disable NVG510 Wireless in Home Network -> Wireless.

 

3.  In Firewall -> IP Passthrough, use the same settings originally suggested by lisfolks:

  • Allocation Mode: Passthrough
  • Passthrough Mode: DHCPS-fixed
  • Passthrough Fixed MAC Address:
  • Passthrough DHCP Lease: (see paragraph below for possible change)

4.  It is no longer necessary to configure your home router with a static IP address; the NVG510 will now honor the IP Passthrough setup and pass the WAN IP settings through to the device specified by the Fixed MAC Address.  This resolves the issue originally mentioned by ktalley back in post #15 of what happens when the public IP of the NVG510 changes (which as most of you know, almost NEVER occurs!).

 

One more caveat: when I changed my router (DLink DIR-330) setup from a static IP to using a dynamic WAN IP address, everything appeared to work EXCEPT a site-to-site VPN tunnel I had configured would get torn down and rebuilt every few minutes.  I "fixed" this one issue by changing the "Passthrough DHCP Lease" time (under Firewall -> IP Passthrough) from the default (10 minutes in my case) to the maximum (99 days!).

 

I'm guessing this now works (as opposed to NOT working back in 2011 when this thread was started) because of firmware updates (2d30 or 2d45) made by AT&T over the last couple years (As of today, the current firmware rev on the NVG510 is v9.0.6h2d45).

 

Hope this helps anyone still struggling with this modem,

 

[Third party link removed]

 

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.