lisfolks's profile
lisfolks
Helpful 1
Supersonic 25!
#1 Star!

Mentor

 • 

40 Messages

Tuesday, October 4th, 2011 2:28 PM

NVG510 Bridge Mode???

Just switched from DSL (Motorola 2210) to UVerse (Motorola NVG510). I set the 2210 into bridge mode and ran my home network from an Apple Airport Extreme Base Station (AEBS). I have some complex configurations on my network and figured I'd be able to do the same thing with the NVG510. However, it seems the NVG510 uses different terminology than I am used to.

 

Under Firewall/IP Passthrough, I set:

Allocation Mode to 'Passthrough'

Passthrough Mode to 'DHCPS-Fixed'

Passthrough Fixed MAC Address to the AEBS' MAC address

And, I left the Lease at the default 10 minutes.

 

On the AEBS, under Internet/Internet Connection, I switched from 'PPPoE' to 'Ethernet'. I left the Ethernet WAN Port value at 'Automatic (Default)'. And Connection Sharing is set to 'Share a public IP address'.

 

This apparently is not enough, though. The AEBS reports that the "Wi-Fi base station does not have a valid IP address", and that there is a "Conflicting DHCP Range".

 

How do I turn off the DHCP on the NVG510? And, what are the correct settings to put the NVG510 into bridged mode?

x0rg

Teacher

 • 

24 Messages

11 years ago

I guess many problems would disappear if a switch behind the NVG510 would be used instead of using another router behind that router, which is not a good idea at all. Below is my network layout where VPN is working fine, but MicroCell is not working.

 

Network Map

MicroCell is more important for me, so I switched to the second configuration, where IP Passthrough is turned OFF, MicroCell is connected to the modem directly and working fine, DIR-655 is connected to the modem. My computer was connected to DIR-655 and now is connected directly to the modem. VPN (PPTP) didn't work in both cases and I saw "GRE blocked" on the DIR-655, when my computer was connected to it.

x0rg

Teacher

 • 

24 Messages

11 years ago

I don't even see VPN requests from my home computer to the router at work (router's logs), which means the VPN stops on my modem at home, right? But when the modem is in Passthrough configuration - the VPN is working fine. This is weird.

x0rg

Teacher

 • 

24 Messages

11 years ago

OK, as I was told by AT&T tech, there is no PPTP passthrough in NVG510. Let's hope they fix it in the next firmware update.

mccwam01

Explorer

 • 

7 Messages

11 years ago

I was able to get my setup working using pass-through on the NVG510. My Cisco router supports loopback so I don't have to change anything when I take my laptop outside my intranet. The router also forwards the right ports to each (different) servers.  The MicroCell seems to work (cellphone clarity is very good). The Netgear WPN824 was my router (some time ago) but I've repurposed it as an access point (only) now.

 

My laptop can also VPN back into my intranet using Cisco's QuickVPN Client software.

 

For clarity I chose not show all my network attached devices   

 

 

 

 

 

 

House.png

brianb_1

Teacher

 • 

14 Messages

11 years ago

If you still need a solution, I've got one. Just did this myself. Took all bleepin' week before I got it worked out. If you have a block of public static addresses DO NOT bother trying to get "passthrough" mode to work, it is not necessary.

 

Simply do the following:

 

On the NVG510, go to Home Network tab, then Subnets and DHCP under that.  Go to Public Subnet Enable, and turn it On.

 

Place the last available address in your static public subnet in the "Public IPv4 Address" field. This is now the router's address in your public subnet block. Set the Subnet Mask appropriately (I have 5 usable in a subnet of 8, so I put 255.255.255.248). You can put the range of addresses in, not sure if it is necessary or not. I set the primary DHCP Pool to Public, but in hindsight that is most likely unnecessary, and perhaps even a bad idea. The KEY thing is that you turned it ON and set the IP address of the router... This lets the router know what the public address block is, and allows traffic to flow to devices on the LAN side that are assigned (by DHCP or statically) addresses in that block. I think if you leave that "Primary DHCP Pool" at private, you could leave the wireless option ON and devices could then get to the internet that way, but be given addresses from the "private" DHCP pool. They won't really be on your real private network, though, because that's setup on your other "real" router... And this NVG510 has NO static routing capability, at least none that you are allowed to set, so you cannot send traffic from its wireless clients back to your other router... But I digress...

 

Now, I have a Cisco 877, and I plugged FastEthernet0 port into the back of the NVG510 router. I then manually configured a vian with the rest of the addresses in my public block, and set the default route to the address you put into the NVG510's "Public IPv4 Address" field. Well, here are the details, including the fact that I had a site-to-site VPN setup (crypto map), and that is indeed working once again with the new default address of vlan2 below. For demonstration purposes, assume my public IP block is the 1.1.2.56 255.255.255.248 block...

 

Here are the relevant sections of my configuration:

crypto map myMapKey local-address Vlan2

!

...

interface FastEthernet0

switchport access vlan 2

no cdp enable

!

...

interface Vlan2

 description internet

 ip address 1.1.2.57 255.255.255.248

ip address 1.1.2.58 255.255.255.248 secondary

ip address 1.1.2.59 255.255.255.248 secondary

ip address 1.1.2.60 255.255.255.248 secondary

ip address 1.1.2.61 255.255.255.248 secondary

ip nat outside

ip virtual-reassembly

crypto map myMapKey

!

...

ip route 0.0.0.0 0.0.0.0 1.1.2.62

...

ip nat inside source list 110 interface Vlan2 overload

ip nat inside source static tcp 192.168.1.10 80 1.1.2.57 80 extendable

ip nat inside source static tcp 192.168.1.20 80 1.1.2.58 80 extendable

ip nat inside source static tcp 192.168.1.30 80 1.1.2.59 80 extendable

 

You'll have to figure out how to do this similarly with your router, I don't know anything about that one... Hopefully this is relevant and useful for setting that router up as well...

brianb_1

Teacher

 • 

14 Messages

11 years ago

There is also a "Cascaded Router" option that may work for you as well, I have firmware 9.0.6h0d48, and the Home Network Subnets and DHCP page looks like this: 

Subnets and DHCP

 

And instructions look like this:

Cascaded Router Instructions

 

That sounds exactly what a lot of users could use!  I didn't try it, but it may be easier to configure for some people than the way I explained in my previous post.  Hope you find this helpful.  I spoke with someone at Motorola (1-877-466-8646 ) and they don't have much additional documentation on this feature. I asked that they consider writing it up and making it easily accessible.  They have a site http://motorola.com/mygateway where I found several documents about the NVG510, but they look out of date by a few months and the firmware is getting better and better...

 

Voyager

 • 

3 Messages

11 years ago

Great help, thanks all. 

 

Switched to AT&T to save a few bucks and guess I learned why/how they can do that after spending a day of my life reconfiguring the home network.

 

Anyway, just wanted to add or maybe emphasize a couple things that might be helpful, particularly to those using Cisco Linksys E2000 routers:

 

1.  Yes, you DO hook it up through the physical INTERNET port on the back of the unit.  There are nice pictures posted that show this in this thread, and while you might get internet to work with the RG plugged into ports 1-4 (I did), it really needs to be in INTERNET port for important reasons (Other pass-through capabilities).

 

2.  On the E2000 In Advanced Routing make sure that NAT is switched ON, and Dynamic Routing is turned OFF.

 

Generally, when making all the changes it's helpful to make sure everything wireless is turned off.  I had a wireless print server, a wireless security camera and some Blackberrys all getting assigned local IP addresses during setup which was annoying, as I focused on getting reliable Bridge AND most importantly, VPN to work properly through the bridge, which I did.  Next on the list is Remote Desktop.  Not working yet, but hopeful.  Smiley Happy

Contributor

 • 

2 Messages

11 years ago

Thank you for the solution. Is this still the way to go? I saw there was a cascaded router option, but I'm not sure why that might be better if it would would at all.

lisfolks

Mentor

 • 

40 Messages

11 years ago

I tried using the cascaded router option 1st thing, since that seemed like it would make the most sense. However, I couldn't get it to work. That's when I came up with the solution here. I haven't seen any better solution so far (nor have I seen the firmware update AT&T's support was promising to come in late December!).

 

Good luck!

Contributor

 • 

2 Messages

11 years ago

i changed all the same settings on the nv510 that you did. 

 

Under Firewall/IP Passthrough, I set:

Allocation Mode to 'Passthrough'

Passthrough Mode to 'DHCPS-Fixed'

Passthrough Fixed MAC Address to the AEBS' MAC address

And, I left the Lease at the default 10 minutes.

 

on my airport extreme with the newest firmware and the newest airport configuration utility 6.0. i set this. 

 

on the internet tab

ip address : 192.168.1.1

subnet255.255.255.0

router address  192.168.1.254

 

and i used different DNS settings because for some reason this nvg510 will fail on DNS

so i put in the open DNS servers

 

primary DNS  208.67.222.222

secondary DNS  208.67.220.220

 

under network tab. i picked DHCP only.  

with the default DHCP ranges of 192.168.1.2 - 192.168.1.200

 

now each and every device connects to my AEBS, and gets the open DNS  servers so i don't have pages or images not loading on the page anymore.

 

what's really bad is that i tried taking the airport extreme out completely and i still got the DNS issues where pages wouldn't load certain images and stuff.  the NVG510 needs a firmware update pronto.

 

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.