Skip to main content
AT&T Community Forums
denkopf

Tutor

 • 

2 Messages

Wed, Sep 11, 2013 2:02 AM

Motorola NVG589 port forwarding

U Vers replaced my 2-Wire with the  NVG589, I have several security camers installed and i am trying to set up port forwarding for them. They left me no manual. I have tried web searches, nothing. I was able to set the cameras up on the 2-wire, the Foscam web site does not have anything for the 589. on the NVG589 I set up in Nat/gaming what I thought was correct but outside the house I can not gain access. it states "Privite Network" "this camera is on a privite network and will not work". typically when port forwarding it sets up a http address. I cant find where or how it does that.

so I need help please.

dennis

Responses

Contributor

 • 

1 Message

6 years ago

pgamboa,

 

I just recently received my NV589 and I tried to set up my Foscam FI9821W and I can access locally in the network, but once I try to connect to it using the DDNS address, it will show the logon window but after I enter the credentials, it will say "Connect failed. Try again later."

 

What was your setup that made it work so that it can be accessed from outside the network? Please advise. Thank you.

Teacher

 • 

20 Messages

6 years ago

Well, I did have some progress made on this front. Some.

 

A buddy of mine who knows networking really well got the firewall issue solved. I think he did one little minute detail I omitted, but good enough, got that working!

So I can access the site, both by IP and DDNS, from remote locations, my phone, etc.

 

Problem is, I can't see it remotely at all from any type of browser or any Android device I have.

I think this is likely a Q-See problem rather than an AT&T issue though.

I get a choice to choose the Main or Sub stream on each camera but nothing shows. Google chrome even shows a QuickTime plugin trying to load, but nothing ever happens.

 

While this may be slightly OT from being an AT&T issue, if anyone knows how to address this, please share!


Thanks!

Smiley Frustrated

Voyager

 • 

2 Messages

6 years ago

I see a few that say they got it working. Yet I don't see any solid steps taken. I have a Lorex that requires 35000  and 35001 ports forwarded as well as 80 which might be the problem. It would be much simpler if this router had a DMZ like most other routers. I don't even know what the dedicated server setting is. It sure does not do anything.

An IP passthroug kills the other devices on the network from the internet. So I assume, although I have not tried it, it is handing the WAN IP to the assigned device which the rest of the clients on the network will have to get a LAN IP address from. But will the TV still work as well as those extra wireless TV receivers for the other rooms?

The port fowarding should work and be good enough but not here. I so dislike these proprietary routers.

 

And I have done the basic static IP to the NVR. It is .170 and works find on the network. The NVR picks up the 12 IP cameras as well. All are viewable. But the NVR is not available outside the LAN. I tried it via a remote computer and my cell phone mobile data. I check the NVR and the DDNS is not connected. It shows failed.

ATT support is worthless. He just flat told me it would be paid support (for THEIR router?) Give me a break. He also said I might need to buy a static IP address. No, I do not. I just need this router to do what it should do and is supposed to do. Port forwarding is not something the came about last year. It has been around years and years. So what's up, ATT?

Voyager

 • 

2 Messages

6 years ago

I think I know the best solution. Get rid of ATT UVerse and switch to another ISP that doesn't use some proprietary router with their firmware. Port forwarding is a major requirement for many people who want sureveillance systems. And I get the strong impression the ATT techs don't know how to open up the ports either.

It sure isn't just a simply port forwarding issue as it should be. This router is a the problem. I am going to try using passthrough hoping it is the same idea as bridge mode  without having the PPPOE login on the bridged device. Or does ATT use DHCP instead of PPPOE now?

I don't have access to that router right now. If it was mine I would have already cancelled ATT. If this issue is not resolved, the client will as well.

 

Teacher

 • 

20 Messages

6 years ago

Yeah, at best case it's unfortunate and at worst it's downright unconscionable or egregious for AT&T to not allow these ports to be properly forwarded.

 

I get the idea though that there's some little well kept secret and AT&T techs are purposefully kept in the dark as to not accidentally spill the beans on this service.

 

I have a neighbor who has his alarm service that he pays a monthly fee to AT&T on. We both have Uverse. However I have a different alarm service and don't feel the need or desire to switch to AT&T simply to get my surveillance cameras working. I get gouged for over $200 a month as it is on the 400 package! That's why I bought a set of cameras to incur a one-time expense, not  a monthly fleecing!

 

But the guy at AT&T has TWICE told me it would be an extra charge monthly. Q-See support is hardly any better. They gave up and told me to call the provider (AT&T) and tell them to open the ports, to which this is their answer!

 

But if AT&T is installing alarm systems with cameras, someone there has to know how to open ports accordingly. My neighbor said he didn't pay close attention to what the tech did when he configured it! : (   -- too bad!

 

Maybe people will start cancelling in droves over this and then they'll come around!

Teacher

 • 

20 Messages

6 years ago

And FWIW, in IE I get a "Failed to parse domain" error message when I log in remotely, either via the DDNS or the actual external IP address.

 

In Firefox or Chrome I get a prompt to allow QuickTime to run and then I choose yes. It appears to try and load the QuickTime plugin in the browser but nothing ever shows.

 

Q-See claims this to be an AT&T port problem. I'm sure the AT&T tech guy will come on here soon and tell me that's not the case, though I spent hours on the phone of my life that I can't get back now only to have their support guy give up and tell me to call AT&T to open the port.

 

Contributor

 • 

1 Message

6 years ago

There is clearly an issue with port forwarding on the NVG589 router.  I have an TV-IP651W camera, which I could remotel access via timewarner and ATT DSL using own router.  I upgraded from DSL to Uverse and they installed the NVG589 router.   Access to the camera interface is via port 8080.  Per the manual, I setup configured the router to forward port 8080 to the camera.  I verfied the port 8080 was open using canyouseeme.org

port.png

Attempting to access the camera produced the login screen and portions of the page rendered.  

issue.png

Attemps to reload the page produce slightly different results each time (more or few images load). I can access the camera via the local network. As I stated above, I previously accessed the same camera via via timewarner and ATT DSL (both with lower bandwidth limits then I currently have with uverse). It is clear the the NVG589 is not performing correctly.   This is a big problem for me.     

Teacher

 • 

20 Messages

6 years ago

openport,

 

We're all in the same boat. They close the UDP port, but the http or tcp one at 8080 can  be open.

 

I have a different mode, the HG38 whatever it is, but it's the same pathetic story!.

JefferMC

ACE - Expert

 • 

18K Messages

6 years ago


@redraidersrule wrote:

 

We're all in the same boat. They close the UDP port, but the http or tcp one at 8080 can  be open.

 

 

Huh?  What?  

Award for Community Excellence 2020 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Teacher

 • 

20 Messages

6 years ago


@JefferMC wrote:

@redraidersrule wrote:

 

We're all in the same boat. They close the UDP port, but the http or tcp one at 8080 can  be open.

 

 

Huh?  What?  


What do you mean huh? What?

Those of us who are encountering port forwarding problems are in the same boat.

Q-See expressly told me that the UDP port was closed, which any diagnostics run confirms. i.e. canyouseeme.org, the fact that the camera or plug-in doesn't work, etc.

I don't have this NVG model myself, but rather an HVG3810 model or some older 2WIRE model.

 

This doesn't make sense to you? That's the way it's working (or rather, not).

JefferMC

ACE - Expert

 • 

18K Messages

6 years ago

UDP and TCP ports may be opened or closed separately.   There is no such thing as a model 3810 (3800, 3801 maybe).  Would you care to post a screenshot of your FW configuration page?

 

Award for Community Excellence 2020 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Contributor

 • 

2 Messages

6 years ago

First, this Arris device is really obnoxious and I've wasted a lot of time trying to get it working properly with a Tenvis security cam.  That said, I was successful using the NAT/gaming port forwarding.  lapsmith's post helped with some ideas.  I'll try to be concrete with info.

 

My issue was that I could not get the Tenvis webcam accessible from outside the modem (Arris) - I would validate this at http://www.canyouseeme.org/ (port checker).  Here are things I had to do:

 

* In my Tenvis configuration, I set it to a static IP (unchecked DHCP).  Pick a higher IP #, which will become apparent below.

** Also ensure the default gateway and DNS server is correct - for this modem it's 192.168.1.254. Many default devices will have this set to 192.168.1.1 so doublecheck.  W/o this, DDNS will fail (though that doesn't affect f/w accessibility).

* On the modem config, under Home Network->Subnets and DHCP, set the DHCPv4 Start and End range so that your device IP (from bullet 1) is outside/above the end of the range.  e.g. set range from .64 to .100 and have your device set to .115.

* After that, retest that your device is acquiring the static IP by restarting your device (in my case the Tenvis).  Under Device->Device List you can clear the list the scan - your device should appear as "static" next to Allocation.  If not, you didn't set your device properly.

* Now under Firewall->NAT/Gaming you should add your "custom service" then go back and add your hosted application.  This is discussed several times in other posts here so won't rehash (plus if you're reading this thread you've probably tried that a bunch of times already).

*Now test again using http://www.canyouseeme.org/, making sure to enter in the right port from the prior step.  Note this website derives your modem's public IP automatically.

 

This worked for me.  I haven't thought about "why" but it seems like a bug with the firewall and DHCP allocations.

 

I had also tried both passthrough and default server which failed miserably - again there's no reason for those to fail so badly.  I did not futz with another router fyi.

 

Hth, good luck folks.

 

 

JefferMC

ACE - Expert

 • 

18K Messages

6 years ago


@playactn wrote:

First, this Arris device is really obnoxious and I've wasted a lot of time trying to get it working properly with a Tenvis security cam.  That said, I was successful using the NAT/gaming port forwarding.  lapsmith's post helped with some ideas.  I'll try to be concrete with info.

 

My issue was that I could not get the Tenvis webcam accessible from outside the modem (Arris) - I would validate this at http://www.canyouseeme.org/ (port checker).  Here are things I had to do:

 

* In my Tenvis configuration, I set it to a static IP (unchecked DHCP).  Pick a higher IP #, which will become apparent below.

** Also ensure the default gateway and DNS server is correct - for this modem it's 192.168.1.254. Many default devices will have this set to 192.168.1.1 so doublecheck.  W/o this, DDNS will fail (though that doesn't affect f/w accessibility).

* On the modem config, under Home Network->Subnets and DHCP, set the DHCPv4 Start and End range so that your device IP (from bullet 1) is outside/above the end of the range.  e.g. set range from .64 to .100 and have your device set to .115.

* After that, retest that your device is acquiring the static IP by restarting your device (in my case the Tenvis).  Under Device->Device List you can clear the list the scan - your device should appear as "static" next to Allocation.  If not, you didn't set your device properly.

* Now under Firewall->NAT/Gaming you should add your "custom service" then go back and add your hosted application.  This is discussed several times in other posts here so won't rehash (plus if you're reading this thread you've probably tried that a bunch of times already).

*Now test again using http://www.canyouseeme.org/, making sure to enter in the right port from the prior step.  Note this website derives your modem's public IP automatically.

 

This worked for me.  I haven't thought about "why" but it seems like a bug with the firewall and DHCP allocations.

 

I had also tried both passthrough and default server which failed miserably - again there's no reason for those to fail so badly.  I did not futz with another router fyi.

 

Hth, good luck folks.

 

 


I don't see anything in here that is unexpected:

  • You have to tell the camera where the gateway (router) is.  AT&T has chosen to default to 192.168.1.254, while the camera defaults to expecting 192.168.1.1; either could be changed to make the other happy.  Change the camera is the simplest.
  • When you assign the device a static address, you need to put that address outside the range of addresses provided by the gateway via DHCP so that there is no conflict.  
  • You have to tell the Gateway that external requests for a given port need to be directed to the camera's IP address.  Otherwise it doesn't know what to do with it.
  • I do not know why you had to make the device address static vs DHCP issued, other than it may make the process of setting up the port mapping easier.
  • Passthrough is not intended for this situation, though I don't know why it wouldn't work.
  • Default server should also work, but since you still need to create rules to pass traffic, so I don't see the point in doing so vs. Port Forwarding the port the camera needs.

Award for Community Excellence 2020 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Teacher

 • 

20 Messages

6 years ago


@JefferMC wrote:

UDP and TCP ports may be opened or closed separately.   There is no such thing as a model 3810 (3800, 3801 maybe).  Would you care to post a screenshot of your FW configuration page?

 


Sure. Yeah, it's a 3800HGV-B - sorry! I'm usually not at home when replying to this and didn't have it to look at right away!

 

Is this enough? Or do you need a screen shot of other settings?

 

ATT_firewall_scrshot.jpg

Get started...

Ask a new question