Uniquely for you. Preorder the new Google Pixel 6.
nixhead's profile

Contributor

 • 

2 Messages

Sun, Apr 19, 2015 4:47 AM

Apple TV app authorization behind 3rd party router.

Howdy,

 

I finally give up. I added a tp-link archer c8 router behind the uverse nvg589 to improve things using this guide. The biggest improvement I noticed was my apple tv. However, i noticed that certain apps that need provider authorization (that make sure that channel is in your tv package) is no longer working. Apps for example are espn, disney XD/JR/etc, FXnow. All require a provider activation. These were all working before my changes to my net gear. The remote activation works (going to es.pn/activate, put in the code, and the app starts ok on my apple tv). However when I go to play something, it says its not part of my tv package (FXNow) or Error: noAuthz (Disney apps). Obviously its checking for something locally that my configuration has left out. 

 

After fiddling a bit, I configured my router to use a static IP instead and magically the Watch ESPN app started working again. Still the same things on the other apps even after re-registering.

 

My Configs:

 

NV589

 

Device IPv4 Address172.16.0.1
DHCPv4 Netmask255.255.255.224
DHCPv4 Start Address172.16.0.7
DHCPv4 End Address172.16.0.14
DHCP Leases Available7
DHCP Leases Allocated1
DHCP Primary PoolPrivate

 

Allocation Mode: Default Server

Default Server Internal Address: 172.16.0.13

 

Archer C8

WAN Connection Type: Static

IP Address: 172.16.0.13

Subnet Mask: 255.255.255.0

Default Gateway: 172.16.0.1

 

Would love to know if anyone else has this issue, and if they were able to solve it.

Community Support

 • 

6.7K Messages

7 y ago

Hi @nixhead,

 

I am sorry about the issues you are having with your Apple TV, but I would be glad to help. With the same settings, if you connect the Apple TV directly to the U-verse gateway, does it work, or does it still have the same authorization issues? To my knowledge, the connection is server side checked, and there should not be any issues with the private IP pool you decide to use. The only thing I can think of is if your router has a proxy program, but it is odd that it worked after you configured it Statically. 

 

One thing you can try is setting your Archer C8 in passthrough to see if that helps. Here is a post that goes over it. 

 

-David T

Contributor

 • 

2 Messages

7 y ago

Looks like this is actually the issue:

https://forums.att.com/t5/Troubleshoot-Internet-Service/Watch-ESPN-User-not-authorized-error/td-p/4189590

 

Tried the password reset to sync the DBs and will test later. The issue extends to my phone and laptop when I try to use any of those apps.

Need help?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.