Cyber Monday: Get a FREE Samsung Galaxy S22 with eligible trade-in & Free Galaxy Buds2 - while supplies last!
ChromaBurst's profile

Teacher

 • 

16 Messages

Wed, Dec 14, 2011 3:28 PM

3600HGV will not forward ports for Steam or Battlefield 2!

Manufacturer     2Wire, Inc.
Model     3600HGV
Hardware Version     2700-100727-008
Software Version     6.3.7.42-plus.tm
DSL Modem     3.73 SW:9_158_16_100526

 

I've tried everything to make this RG forward ports - it refuses to open the following ports for BF2 and Steam:

 

            UDP     1500-4999
    
            UDP     16567
    
            UDP     27900
    
            UDP     29900
    
            TCP     4711
    
            TCP     27901
    
            TCP     28910
    
            TCP     29900
    
            TCP     299
    
    
            UDP     27000-27015
    
            UDP     27015-27030
    
            TCP     27014-27050
    
            TCP     27015
    
            UDP     3478
    
            UDP     4379
    
            UDP     4380

 

 

I've used UV Realtime and Nmap (Zenmap GUI) to confirm whether the ports are opened or not. Just doesn't do it! I was able as a last resort to get eMule to run it's port test (UDP/TCP) and connect to an external site during it's Wizard - odd!

 

I'm ready to return this RG to AT&T - clearly the firmware is in error here or some convoluted configuration. I had a 3800HGV RG at another location and it worked fine - I didn't even need to forward ports! 

 

I've tried connecting hard-wired via a single static IP and DHCP for the PC/laptop that I'm trying to port forward. After some intense debugging, it's not my Apple gear, not Steam but it's that piece of junk 2Wire (now Pace, great!) 3600HGV.

 

Any suggestions?

 

-chromaburst

Accepted Solution

Official Solution

Teacher

 • 

16 Messages

11 years ago

SOLVED

 

FAULT FOUND

Bad gateway! Second level support could not remotely control the gateway AND using the 3600HGV's IP Utilties certain sites could never complete their trace routes.

 

ACTION

Replaced with 3800HGV-B.

 

Manufacturer     2Wire, Inc.
Model     3800HGV-B
Hardware Version     2700-100531-006
Software Version     6.3.7.42-plus.tm

 

Thanks for everyone's helpful suggestions! We got there... and surprisingly Steam works, no firewalls pins or any special configuration. This was painful after 2.5 months of wondering.

 

Regards,

chromaburst

Anonymous

New Member

 • 

25.7K Messages

11 years ago

You do not have to forward or open anything. Are you trying to run a server, or trying to play Battlefield 2 in multi-player, with others?

Teacher

 • 

16 Messages

11 years ago

gregzoll_1 - Not trying to run BF2 server. Yes, would like to play on-line but more importantly connect the the EA network to validate account/game stats for BF2. My main focus has been with getting Steam to run.

 

-chromaburst

Teacher

 • 

16 Messages

11 years ago

More information from the 3600HGV System Log (INF msgs) at boot-time of the gateway:

 

INF     P0000-00-00T00:01:03     

lmd: rnat0: Added a pinhole[1]: nat_addr=, dest_addr=192.168.0.26, proto=17, alg=0, port=1500-4999

INF     P0000-00-00T00:01:03     

lmd: rnat0: Added a pinhole[2]: nat_addr=, dest_addr=192.168.0.26, proto=17, alg=0, port=16567

INF     P0000-00-00T00:01:03     

lmd: rnat0: Added a pinhole[3]: nat_addr=, dest_addr=192.168.0.26, proto=17, alg=0, port=27900

INF     P0000-00-00T00:01:03     

lmd: rnat0: Added a pinhole[4]: nat_addr=, dest_addr=192.168.0.26, proto=17, alg=0, port=29900

INF     P0000-00-00T00:01:03     

lmd: rnat0: Added a pinhole[5]: nat_addr=, dest_addr=192.168.0.26, proto=17, alg=0, port=27000-27030

INF     P0000-00-00T00:01:03     

lmd: rnat0: Added a pinhole[6]: nat_addr=, dest_addr=192.168.0.26, proto=6, alg=0, port=4711

INF     P0000-00-00T00:01:03     

lmd: rnat0: Added a pinhole[7]: nat_addr=, dest_addr=192.168.0.26, proto=6, alg=0, port=27901

INF     P0000-00-00T00:01:03     

lmd: rnat0: Added a pinhole[8]: nat_addr=, dest_addr=192.168.0.26, proto=6, alg=0, port=28910

INF     P0000-00-00T00:01:03     

lmd: rnat0: Added a pinhole[9]: nat_addr=, dest_addr=192.168.0.26, proto=6, alg=0, port=29900

INF     P0000-00-00T00:01:03     

lmd: rnat0: Added a pinhole[10]: nat_addr=, dest_addr=192.168.0.26, proto=6, alg=0, port=299

INF     P0000-00-00T00:01:03     

lmd: rnat0: Added a pinhole[11]: nat_addr=, dest_addr=192.168.0.26, proto=6, alg=0, port=27014-27050

 

The firewall pins are being created (or so the device thinks!) but it does not allow Steam to connect. Steam is trying ports 27017 and 27019 (shown below) but to no avail...

 



[2011-12-13 17:58:26] Log session started

[2011-12-13 17:58:26] [0,0] SetSteamID( [U:1:0] )
[2011-12-13 18:01:10] [0,0] SetSteamID( [U:1:0] )
[2011-12-13 18:01:10] [0,0] SetSteamID( [U:1:0] )
[2011-12-13 18:01:10] [1,2] Connect() starting connection (eNetQOSLevelLow, 81.171.115.6:27019, UDP)

[2011-12-13 18:01:15] [1,2] ConnectFailed('Connection Failed') (81.171.115.6:27019, UDP)
[2011-12-13 18:01:15] [0,0] StartAutoReconnect() will start in 10 seconds
[2011-12-13 18:01:25] [1,6] Connect() starting connection (eNetQOSLevelLow, 208.111.133.85:27017, UDP)

[2011-12-13 18:01:30] [1,6] ConnectFailed('Connection Failed') (208.111.133.85:27017, UDP)
[2011-12-13 18:01:30] [0,0] StartAutoReconnect() will start in 18 seconds
[2011-12-13 18:01:48] [1,8] Connect() starting connection (eNetQOSLevelLow, 68.142.83.182:27018, UDP)

[2011-12-13 18:01:53] [1,8] ConnectFailed('Connection Failed') (68.142.83.182:27018, UDP)
[2011-12-13 18:01:53] [0,0] StartAutoReconnect() will start in 43 seconds
[2011-12-13 18:02:37] [1,10] Connect() starting connection (eNetQOSLevelLow, 72.165.61.188:27018, UDP)

[2011-12-13 18:02:42] [1,10] ConnectFailed('Connection Failed') (72.165.61.188:27018, UDP)
[2011-12-13 18:02:42] [0,0] StartAutoReconnect() will start in 34 seconds
[2011-12-13 18:03:16] [1,11] Connect() starting connection (eNetQOSLevelLow, 81.171.115.8:27017, TCP)

[2011-12-13 18:03:51] [1,11] ConnectFailed('Invalid State') (81.171.115.8:27017, TCP)
[2011-12-13 18:03:51] [0,0] StartAutoReconnect() will start in 39 seconds
[2011-12-13 18:04:31] [1,13] Connect() starting connection (eNetQOSLevelLow, 72.165.61.175:27017, TCP)

[2011-12-13 18:04:52] [1,13] ConnectFailed('Invalid State') (72.165.61.175:27017, TCP)
[2011-12-13 18:04:52] [0,0] StartAutoReconnect() will start in 444 seconds
[2011-12-13 18:10:10] [0,0] SetSteamID( [U:1:0] )
[2011-12-13 18:10:10] [0,0] SetSteamID( [U:1:0] )
[2011-12-13 18:10:10] [1,16] Connect() starting connection (eNetQOSLevelLow, 68.142.83.180:27019, UDP)

[2011-12-13 18:10:15] [1,16] ConnectFailed('Connection Failed') (68.142.83.180:27019, UDP)
[2011-12-13 18:10:15] [0,0] StartAutoReconnect() will start in 232 seconds
[2011-12-13 18:10:26] [0,0] ResetVoiceRecording() (was recording: 0) (last get voice time: 720 seconds ago)
[2011-12-13 18:10:26] [0,0] Log session ended


[2011-12-13 20:25:20] Log session started

[2011-12-13 20:25:20] [0,0] SetSteamID( [U:1:0] )
[2011-12-13 20:25:41] [0,0] ResetVoiceRecording() (was recording: 0) (last get voice time: 21 seconds ago)
[2011-12-13 20:25:41] [0,0] Log session ended


[2011-12-13 21:04:23] Log session started

[2011-12-13 21:04:23] [0,0] SetSteamID( [U:1:0] )
[2011-12-13 21:04:31] [0,0] SetSteamID( [U:1:0] )
[2011-12-13 21:04:31] [0,0] SetSteamID( [U:1:0] )
[2011-12-13 21:04:31] [1,2] Connect() starting connection (eNetQOSLevelLow, 72.165.61.174:27018, UDP)

[2011-12-13 21:04:36] [1,2] ConnectFailed('Connection Failed') (72.165.61.174:27018, UDP)
[2011-12-13 21:04:36] [0,0] StartAutoReconnect() will start in 11 seconds
[2011-12-13 21:04:39] [0,0] SetSteamID( [U:1:0] )
[2011-12-13 21:04:39] [0,0] SetSteamID( [U:1:0] )
[2011-12-13 21:04:39] [1,6] Connect() starting connection (eNetQOSLevelLow, 68.142.83.180:27017, UDP)

[2011-12-13 21:04:44] [1,6] ConnectFailed('Connection Failed') (68.142.83.180:27017, UDP)
[2011-12-13 21:04:44] [0,0] StartAutoReconnect() will start in 15 seconds
[2011-12-13 21:04:59] [1,8] Connect() starting connection (eNetQOSLevelLow, 68.142.83.183:27017, UDP)

[2011-12-13 21:05:03] [1,8] ResetVoiceRecording() (was recording: 0) (last get voice time: 40 seconds ago)
[2011-12-13 21:05:03] [1,0] Log session ended


[2011-12-14 08:15:14] Log session started

[2011-12-14 08:15:14] [0,0] SetSteamID( [U:1:0] )
[2011-12-14 08:16:41] [0,0] ResetVoiceRecording() (was recording: 0) (last get voice time: 87 seconds ago)
[2011-12-14 08:16:41] [0,0] Log session ended

This is the connection_log.txt file from C:\Program Files\Steam\logs under Windows XP SP3.

JefferMC

ACE - Expert

 • 

30.2K Messages

11 years ago

We've got Steam running on a PC behind the 3800 RG (which is much the same as the 3600) and have no special FW exceptions.  On the other hand, we've not been using it for Multiplayer, which could be a whole different ball of wax.

 

Anonymous

New Member

 • 

25.7K Messages

11 years ago

I would be looking at the firewall on the computer that you are running BF2 on, vs. hardware.

Teacher

 • 

16 Messages

11 years ago

gregzoll_1 - I've tried this on three different Steam configurations; WinXP(32), Vista64 and OSX. All were previously working fine. On Windows, I removed previous firewall settings to force Windows to display dialogs to allow ports through.

 

-chromaburst

Anonymous

New Member

 • 

25.7K Messages

11 years ago

If it worked with other computers, and it is not with this one, that means that it is a firewall issue with that computer, not with the RG. If you have made changes with the firewall on the RG, it is a possibility that you have already caused more problems, than how it was originally set up.

Suggest doing a reset on the RG to place it back into the original settings, then review the firewall on the computer in question, by just disabling the firewall. BTW, what firewall Software & what OS is on the machine that you are attempting to run BF2 on?

Teacher

 • 

16 Messages

11 years ago

FYI - in a former life, I was an embedded software developer working on bridges and routers.

 

It worked at a different physical location, with a differnet modem (3800HGV)

 

 

I've tried a factory reset - no difference.

Tried dropping the firewall - no difference.

Laptop/desktop directly to RG - no difference.

Bad RG Ethernet ports - no difference.

 

I'm not too concerned about BF2 - I'm only using this as another test to determine the port forward is not functioning. I already have a e-paper support ticket trail with Valve - the router/gateway/DSL modem looks like the problem - otherwise why would Nmap mention that no ports are open?

 

I'm using the standard Windows Firewall on Vista64 and WinXP32. On OSX, the standard Application firewall - haven't touched it.

 

Thanks for your assistance so far... it's appreciated!

 

-chromaburst

Anonymous

New Member

 • 

25.7K Messages

11 years ago

I did a search, and remember when Steam started, they were having problems with their service. So, it does not surprise me that you can not connect to them to do anything, and have done everything that you can on your end, to make sure everything is correct.

I would write it up to the fact that Steam is in the same position of how bad their service is, for the past what, 8 years, 9 now going forward.
Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.