Our Community Forum will be shutting down on June 27, 2024. Please visit att.com/support for all your support needs.
Get superfast AT&T Fiber internet
Joshherman321's profile

1 Message

Friday, July 21st, 2023 8:39 PM

5G Channel speeds horrible!!!

My gateway receives the expected speeds, I have my channels splits, my 2.4 runs normally but my 5G barley gets 5mbps and we pay for fiber 500. The smart home app just tells me to change the channel and it works we get 500 Mbps but after 5 minutes my 5G goes back to barley getting 5mbps or less. We just got this new modem installed yesterday and this is the only issue, any tips on how to fix??? 

Community Support

 • 

232.8K Messages

11 months ago

Glad to help you improve your 5GHz channel speed, Joshherman321.

 

Begin by restarting your gateway. This will refresh and should stabilize your connection. Unplug the power connection behind the gateway for ~15 seconds, plug it back in, and wait for the Broadband light to turn green. If you have the BGW320 model, wait for the light on the front to be solid white.

 

If you don't see an improvement, you can perform a factory reset. This will return all gateway settings to a default state. Any custom Wi-Fi passwords, Wi-Fi names, SSID, Static IP, and Port Forwarding rules will be lost, but they can be restored after the gateway is back up and running. Locate the small red button and pinhole on the lower rear of the gateway and depress for ~15 seconds.

 

We also suggest checking out our article that covers Troubleshooting Slow AT&T Fiber to learn what could be causing your speed to slow down.

 

If you need more troubleshooting options, let us know.

 

Aminah, AT&T Community Specialist

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.