Get superfast AT&T Fiber internet
bobster2's profile

Tutor

 • 

5 Messages

Thu, Aug 15, 2019 7:34 AM

TP-Link Archer C2300 in Acces Point mode resolves WiFi speed and connectivity issues with BGW210

The short version: The BGW210-700 WiFi is awful. Disabling its WiFi and connecting a TP-Link Archer C2300 in Access Point mode resolved all of my WiFi issues.

 

My system:

 

ATT Fiber 300.

 

Wired devices include: Marantz AV7005 AV Preamp, Synology DS218+ NAS (used mainly for streaming my iTunes library both locally and remotely), an old Apple TV (2d or 3d gen), an old Panasonic TV, an Oppo BDP-83 Blu-Ray player, and a Hackintosh (desktop PC running macOS).

Wireless devices: iPhone 6s, iPad Air 2 (WiFi only), 2012 MacBook Pro 15", stereo pair of Sonos One speakers (1st gen).

 

All devices have the latest OSes (iOS 12, Mojave 10.14.6, etc) and all apps are current.

 

Until last month, I had Comcast internet, using my own Arris cable modem, the C2300, and two simple (non-configurable) Ethernet switches. Everything worked fine.

 

When I switched to ATT, several issues arose. For example, web pages loaded more slowly than I expected on the iPad.

 

One of the most annoying problems was this:

 

I use Synology's DS File app on my iPad to stream audio from the NAS to the Marantz Preamp via Apple Air Play. It worked fine before, but with the BGW210, DS File began disconnecting randomly (and frequently) from the Marantz. Dragging the playback head in DS File while the audio was paused (which I need to do frequently) seemed to cause - or was at least associated with - the disconnection.

 

Even if the Marantz was still connected, pressing "play" after moving the playback head would cause the head to move, but there would be no sound.

 

Often, I'd only be able to play one file successfully. With the next file, if Air Play hadn't already disconnected, I'd have to manually disconnect and reconnect before I'd get sound again.

 

During a test today, an audio file (AAC at 256 or 320 kbps, a five-minute mono file) took several minutes to load into DS File instead of a second or less. (BTW, I think DS File uses the iPad's built-in audio player, not a proprietary one.)

I never had any of these problems when I was using the cable modem and C2300.

 

I use audio streaming for practicing and teaching music. It's embarrassing to have tech issues disrupt the flow of lessons, wasting my and my students' time.

 

Twice (once last month and again today), I ran tests by switching everything over to the C2300 (not connected to the Internet) and the WiFi issues went away.

 

Today I did something I've never done before (but now realize I should've done long ago): I put the C2300 into Access Point mode, connected its WAN port to a LAN port on the BGW210, and turned off the BGW210's WiFi.

 

POOF! All these problems vanished.

 

Not only that, but web pages load faster on the iPad (in Safari) - and I think even on my (wired) Hackintosh.

 

When using the HBO Now app on the Apple TV, videos load faster, and the app is more responsive.

 

In other words, disabling the BGW210 WiFi dramatically improved internet and LAN performance all around.

 

I'd rather use the C2300 for all routing, but apparently IP passthrough mode slows down the internet connection. (I experienced this first-hand with the Pace 5268AC in DMZ mode, which slowed my connection from 300 Mbps to 50 or less.) AT&T calls this a bug, but I imagine it's a feature. Shame on them for giving out such lousy hardware and for not making it easier to use our own router for everything.

 

I hope this helps others with similar issues.

No Responses!
Need help?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.