Skip to main content
AT&T Community Forums



2 Messages

Tue, Apr 7, 2020 10:32 PM

Mitel 5340 IP phone not working with 5268AC

With the new WFH requirements, I am trying to connect my Mitel 5340 to my 5268AC. I originally tried using a Netgear 350P switch w/ PoE but couldn't find the phone in the device list on the network. My IT department suggested it might be a quirk going from the router to the switch so I added a PoE adapter and connected this directly to the router, but I still cannot see anything connected to that port. I've tried changing ports, but still cannot see the Mitel phone in the device list. After configuring the phone for teleworker set up and restarting the phone, the phone still indicates it's in DHCP discovery mode and not connected. My IT departments ideas have been exhausted. Any help would be appreciated.


Brand User

Community Support


140.8K Messages

8 months ago

We are here to help, @LonestarHockey.


We recommend that you contact your manufacturer for further help with setting up your phone.


Let us know if you have any further questions or concerns.


Thank you for choosing AT&T.


Marc, AT&T Community Specialist

Still need help? Ask a question! Our 1.4 million members typically respond within 1 hour.

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.

Get started...

Ask a new question