AT&T Holiday Deals & Gifts - Don't miss these holiday deals on the latest devices!
Get superfast AT&T Fiber internet
fayer1971's profile

New Member

 • 

1 Message

Sun, Oct 2, 2022 4:04 PM

Irobot j7 not connecting

Hello,

We just switched to AT&t fiber service. For whatever reason now my iRobot will not connect to my phone. I have rebooted the robot, rebooted the router, taken off the app and redownloaded, and I made sure we are on the right Wi-Fi connection in regards to the robot. Any additional advice?

tonydi

ACE - Guru

 • 

8.6K Messages

2 months ago

Some iRobot vacuums only do 2.4GHz wifi so the combined 2.4GHz and 5GHz bands on the AT&T gateway may stop them from connecting to the network.

You've got two options.....you have to separate the bands OR enable the Guest Wifi Network which is 2.4GHz only and point the vacuum to that.

To go with the first solution, go to http://192.168.1.254/cgi-bin/wconfig.ha In the 5GHz section change the Network Name (SSID) to something else.  I usually suggest just adding a -5 onto the end of the current name.  Scroll down and hit Save.  Oh, ignore the dire warnings about the end of civilization if you change the name.

After this, any devices that work better on 5GHz will need to be told to connect to the new SSID you just made but the exiting 2.4 devices should just keep working.  Then see if the iRobot is happy.

If you'd rather go the Guest Wifi route, go to http://192.168.1.254/cgi-bin/wconfig_unified.ha and Enable the Guest SSID and point the vacuum to that Guest Network Name.  Again, don't forget to click Save.

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.