Announcements

For the latest on our response to Coronavirus (COVID-19), click here.

Teacher

 • 

10 Messages

Mon, Apr 8, 2019 3:05 PM

iPhone wifi slow on AT&T fiber

Looking for a solution to an issue with wifi on my home AT&T Fiber network 1000 Mbps. This only occurs with iPhones connected to the my home wifi. The majority of the time my iPhone X is very slow when connected to my home wifi (10 mbps or less). The exact same behavior occurs on my wife's iPhone X as well. Only if I disconnect and reconnect to the wifi via the phone directly or resetting the router does the connect start off fast for about 5 minutes or less.  Does not matter what the signal strength is or where in the home the phone is located.

Other connected devices, such as my Macbook, TVs, Firestick, etc. do not get a slow connection. They get 200+ Mbps over wifi.

Connecting to other wifi spots that are not our home wifi the wifi works as expected and extremely well on the iPhones, which leads me to believe there is a setting / recognition from AT&T router or service that  is specifically slowing the iPhone. Does anyone else have this problem?

- iPhone connects to the 5ghz band

- Tried manually specifying the DNS server to use, such as 1.1.1.1, on the iPhone

- Tried assigning IPV4 address to iPhone when it connects, rather than letting the router choose

- Changed channels of wifi and used AT&T mobile app to auto-optimize channel selection

- Reset of router does not resolve (ARRIS BGW210-700, Software version 1.8.18)

- When wifi is turned off on iPhone to disconnect from home wifi, LTE connects and is instantly faster

Responses

Accepted Solution

Official Solution

gr8sho

ACE - Professor

 • 

2K Messages

6 months ago

IMHO, that type of mix and match doesn’t yield desired results.  but to answer the question, you wouldn’t use Passthrough mode if the personal router is configured as an access point, only if it’s in true router mode.  

Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Accepted Solution

Official Solution

gr8sho

ACE - Professor

 • 

2K Messages

5 months ago

@JC0460 
Personally I both sympathize and empathize.  I’ve been through this meat grinder myself. Any concerns should be communicated via escalation.  That’s the only way I know your voice will be heard.  
In the end a compromise may be required. The basic internet access is fine.  The gateway leaves a lot to desired.  check over on dslreports.com to see what others are doing, specifically around the topic of bypass.  You have options, and yes you’ll have to spend more money, but in the end you’ll have something more workable.  

Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Teacher

 • 

10 Messages

a year ago

Also, router info:

ARRIS BGW210-700

Software version 1.8.18

Tutor

 • 

5 Messages

a year ago

I’m having the same problem. I just recently got AT&T Fiber 1Gb and it’s only effecting my iPhone X. While everyone else has cheap phones and seems to work better than my phone...

Contributor

 • 

2 Messages

a year ago

Exact same situation here. My computer and iPad do just fine, as does my roommate’s pixel phone (usually well over 200 mbps). My iPhone XS Max and the Apple TV, however, are incredibly slow. I usually get around 2-6 mbps on my iPhone, and I’m not sure about the Apple TV, but ever since I switched to att fiber a couple of weeks ago it requires very frequent buffering. Has anyone been able to figure this out?

Contributor

 • 

2 Messages

a year ago

Hey! I think I figured out what was going on! It looks like the “band steering” feature of the AT&T router was consistently sending my iphone and Apple TV  to the 2.4 ghz band instead of the 5 ghz band. You can check that by going to the “advanced device configuration” address on your router and you can see which band each connected device is using. If this is what’s happening for you, go in to your WiFi advanced settings and change the name of one of the networks (I just put 2.4 on the end of the default name for the 2.4ghz). Then you’ll have a choice of which to connect to! Some older devices can’t connect to 5ghz, so I wouldn’t recommend turning it off completely, but this has solved my iPhone and Apple TV problem for the time being!

Teacher

 • 

10 Messages

a year ago

Thanks @Jenn0772 - unfortunately that's not the case for me. The iPhone X is connecting to the 5GHz band. I've confirmed by looking at the router configuration and confirming which band each device is connected to. 

New Member

 • 

5 Messages

did you ever find the solution?i got sonic but AT&T provides the fiber optic. And yes it is the router it’s doing something to it the iPhones. Lagging them.

I think it’s the phone adapter . When I restart router and use without phone adapter connected it woks. But I didnt tested for long. So where you able to find what the router is doing to the iPhones? I know the only choice we got is to get a diffrrnt brand router .i just don’t wanna have 2 routers .

Please let me know if you found the solution. PLus always named your WiFi signals. In auto the router really starts to lagg . But like you said it’s a configuration problem.

Teacher

 • 

10 Messages

a year ago

I'm seeing the same thing on multiple iPhones. Interesting that the SpeedCheck app (speedspot.org) on the iPhones consistently shows a good speed of at least 100 Mb/s although it goes up and down (100 to 300) much more than other wireless or wired devices. iPhones streaming video frequently stop to buffer where they never did with 50 Mb/s AT&T copper.

Contributor

 • 

1 Message

a year ago

I am having the exact same issue on the 5ghz band

Teacher

 • 

10 Messages

a year ago

I turned off IPv6 on the router and the problem went away. I'm not seeing any side effects. To try this, log into the router,then "Home Network" tab, then IPv6 sub-tab, then IPv6 to Off and Save. Please post if this also helped you, thoughts on why this helps, or any information on downsides of doing this.

Tutor

 • 

5 Messages

a year ago

I will try this once I get home. But you know what’s the reason for this IPv6 being on or off ? 

Teacher

 • 

10 Messages

a year ago

Turning off IPv6 shouldn't be necessary but doing so forces devices to use the older but perfectly adequate IPv4. This seems to avoid some bug with IPv6 either in the router or the iPhone. That's my best guess at least.

Tutor

 • 

5 Messages

a year ago

I checked it and it was already turned off so idk... I need to get this fixed because this is getting very upsetting. 

New Member

 • 

5 Messages

Teacher

 • 

10 Messages

a year ago

Same, checked IPv6 and it's already off on the router.  

 

Yeah, very upsetting! I pay for 1G fiber in my home and then I have to use my iPhone AT&T data plan (LTE) if i want to access anything on the internet on my phone rather than use home wifi. Every other device in my home seems to work fine at the expected high-speeds on my home network, but the device I use most often doesn't.  WHY!??!?

 

There has to be something the iPhone is looking for via the router and is not getting it so it times-out and goes elsewhere, thus the lag, or the router itself recognizes the iPhone device and is doing the same. Like I said, I tried changing the DNS server, but that hasn't resolved the issue. 

Tutor

 • 

5 Messages

a year ago

It has to be on the iPhone and apple products itself with the problem I think. No other device and even cheap phones experiencing this issue... We need to raise the issue to apple so they can take a look at it. 

AT&T TV – All Your Entertainment In One Spot.  Learn more…