Our Community Forum will be shutting down on June 27, 2024. Please visit att.com/support for all your support needs.
Get superfast AT&T Fiber internet
BoshJeach's profile

1 Message

Wednesday, May 15th, 2024 8:18 PM

How To Make Dedicated (Valheim in Unraid) Server Reachable?

Hi there,

I'm looking for assistance in allowing those outside my network to see & connect to my Valheim server, which is setup locally on my Unraid machine. I've read countless threads on this and no one seems to be doing it with AT&T without using the IP Passthrough mode. I have already setup Plex & everything else to work perfectly with just the AT&T modem/router, so I'd prefer not to have to get a new router & re-do it all again. I'm decently versed in all this, but I've only ever done it through Windows & my old router.

This is the guide I referenced & it would work if it wasn't for AT&T only having one public facing IP & I'm unsure how to get around that!
I'm able to connect locally just fine, but outside that I am having 0 luck.
I have the correct ports forwarded TCP/UDP: 2456-2458 to the server, but that won't help since they only can see the public IP.
I also have a domain so I can setup routing to the public IP, but it still will fall flat in the same spot when they can't reach the server itself.

How do you route traffic / bypass the public IP in this case? Is there a way to do so without a new router? Thank you!!

Guide I used for reference:

https://unraid.net/fr/blog/unraid-valheim-dedicated-server

The port forwarding & current IP passthrough setup to the server:



Accepted Solution

ACE - Professor

 • 

5.7K Messages

1 month ago

@BoshJeach 

Either use port forwarding OR  IP passthrough, but not both.  

Accepted Solution

Scholar

 • 

4.2K Messages

1 month ago

 I have already setup Plex & everything else to work perfectly with just the AT&T modem/router

Since you have Plex setup correctly then the Issue is not with AT&T but your configuration. Skip the custom DNS name for now and only test by your Public IP assigned to your AT&T Gateway. 

You can't have NAT/Game Rules for a device and also have the device setup in the IP/Passthrough page settings as the Default router. Reread the box on the right next to the settings on the IP/Passthrough page.

Dave

ACE - Expert

 • 

35.9K Messages

1 month ago

The very idea of port forwarding is that people use your public IP on the Internet to reach devices in your network "behind" your Gateway.  Port forwarding "forwards" the traffic that arrives, unsolicited, at the public IP to the specific private IP that you've said when it matches the port number you specify.

So, no one outside your home needs to know or use your private IP.  Now... as to why it isn't working so far for you, I do not know.

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.