Skip to main content
AT&T Community Forums

New Member

 • 

4 Messages

Mon, Apr 6, 2020 5:40 PM

Fiber/BGW210-700 problems on Apple devices

We have no problems with Windows devices. Browsing is fast.

However, for Apple devices (iPhones, iPads, and Macs), there is a problem. If I attempt to load the exact same page using Chrome on Windows and Safari on a Mac, it will load almost instantly on Windows while Safari sometimes sits there for up to 10-20 seconds before it's able to load. Oddly enough, opening up a 2nd tab in Safari and loading another page seems to "push" the 1st tab along.

This behavior isn't constant, but occurs roughly 75% of the time.

Speedtest.net on the Apple devices still shows very high speeds in the 300 mbps range. The issue isn't with speed -- it seems to be with the communication between the device and the gateway.

I've tried all the basic troubleshooting tips like restarting the gateway. It's not a gateway-specific problem. It's a problem with how Apple/Safari communicate with the gateway. I didn't have this problem with XFinity's router/modem.

I've tried disabling IPv6 with no success.

This occurs on all Apple devices, so it has nothing to do with location or distance from the gateway.

Responses

davemize

ACE - Professor

 • 

3.2K Messages

8 months ago

@gr8sho I seem to remember some setting(s) you used to refer to concerning Apple device performance on wifi? I tried searching and couldn't find it. Maybe I'm hallucinating...

"Don't make me summon the flying monkeys...."

Award for Community Excellence 2020 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

New Member

 • 

4 Messages

8 months ago

I've done some experimenting on my Mac/Safari, and the results are bizarre.

The "delayed page load" occurs roughly 75% of the time. When it happens, the progress bar at the top of the browser gets to about the 10-15% mark and then just stops. If I wait it out, the page usually loads within 20-30 seconds. Bear in mind that on my Windows machine (using Chrome or IE), that same page loads almost instantly.

But what is odd is that if the 10-15% page load incident occurs and then I immediately click on another open tab in Safari and then go back to the original tab, the page is loaded. In other words, I can avoid this "delayed page load" by simply clicking on another tab and then back.

This seems to support the theory that the problem lies in the communication between the BGW210-700 device and Mac/Safari.

New Member

 • 

6 Messages

5 months ago

Any updates on this? I too have the same problem. My iPad and iPhone will intermittently hang before loading web pages. My Windows desktop and Mac laptop work fine.

New Member

 • 

6 Messages

5 months ago

I found an answer on another forum and it worked for me. I think this answer should get more attention as it's potentially the only real fix I found after combing through all the posts.

 

To summarize the process:

  1. In a browser, go to 192.168.1.254 (or whatever your router's advanced device configuration address is listed as on the router).
  2. Click Home Network.
  3. Click MAC Filtering.
  4. Type the access code listed on your router.
  5. Under MAC Filter Entry, select your iPhone or iPad device from the MAC Address dropdown menu.
  6. Select the 5 GHz Home option and deselect the other boxes.
  7. Click Add.
  8. Repeat for each iPhone / iPad device you own.

That's it. You do not actually have to enable Home SSID Filtering for the 5 GHz Radio band, so try leaving that disabled to see if it works for you. If not, enable it.

 

If any devices that connect to your 5 GHz band start having trouble connecting, then just add them to the filter list using the same steps.

(edited)

tonydi

Guru

 • 

1.3K Messages

Thanks for bringing that here!  Can you point me to a source for this info, I'd love to see an explanation (if there is one) for why this is necessary.

New Member

 • 

6 Messages

I don't have an explanation for why it works. After scouring the internet, the only reliable solutions I ran across were:

  • Buy your own router and bypass the ATT gateway
  • Have ATT replace your equipment with an older model
  • Run a utility that constantly pings a random server so that the connections don't time out on Apple devices (not a particularly feasible option for most non-tech people)

I found a few other solutions, but these didn't seem to work for everyone and also required you to sacrifice functionality, speed, or security:

  • Disable IPv6
  • Set DNS settings manually
  • Switch your Apple devices to 2.4 GHz (less speed)
  • Disable the ATT firewall

The MAC filter solution worked for me and two other neighbors, and it doesn't seem to have any real drawbacks. The only one I can think of is that you might have to manually add devices to the filter list if you want them on the 5 GHz band, but this should only apply to the Apple phones and iPads that you own. Any guests can use the 2.4 GHz guest network if you enable that in the router, and devices like Rokus and AppleTVs default to the 2.4 GHz band anyway and don't seem to have any reported problems.

 

 

(edited)

tonydi

Guru

 • 

1.3K Messages

I understood that you didn't have that info and I'm aware of all of the other "possible" solutions that work for some but certainly not all.

 

That's why I was asking where you found the Mac address procedure, hoping that whoever came up with it might offer an explanation.

New Member

 • 

6 Messages

The poster is orivero3 on the thread: https://forums.att.com/conversations/att-fiber-equipment/iphone-wifi-slow-on-att-fiber/5df024cdbad5f2f6068888a7?page=8

(edited)

tonydi

Guru

 • 

1.3K Messages

Ok, thanks.  Looks like a drive-by posting without any explanation on how he/she found it or why it works.  Unfortunately, I think this is yet another one of the "possibles" since it clearly doesn't work for everyone.

 

But hey, I'm super glad it works for you!

New Member

 • 

4 Messages

logicalhare,

 

Thanks for posting this.  Unfortunately, when I select a device from the MAC Address dropdown list, it immediately switches my selection back to "Select from this list".  It won't let me modify anything.

New Member

 • 

6 Messages

Hey jrush,

 

After you select the device, the menu defaults back to "Select from this list". However, you should see that the Manual Entry field was populated by your selection. At this point, proceed with selecting the 5 GHz checkbox and disabling the others. Then click Add. In the end you'll see your device added to the MAC Filter List with an asterisk in the 5 GHz Home column. Hopefully this fix works for you too.

New Member

 • 

4 Messages

Thanks!  So far, the early returns are promising.  I'll give it a few days to see if it's permanent or just coincidental, but we aren't seeing the delays we saw before (so far).  

New Member

 • 

8 Messages

4 months ago

I have DSL with the BGW210-700 and was getting intermittent broadband freezing on each device, as well as poor performance with macbook pro web browsing.

just did the mac filtering steps and at least the poor performance with macbook pro seems fixed.  will report back if it's not.

 

think i'll need a tech for the random internet freezing

New Member

 • 

1 Message

3 months ago

ISSUE FIXED: The AT&T modems don’t play nice with Apple devices for some reason. I added a VPN (i.e. 1.1.1.1. app, etc.) to the devices (I suggest doing this as well) and that seemed to help some; however, the fix was/is to buy a small Wifi extender that plugs into a wall socket, connect it via Wi-Fi to your modem, then connect the Apple devices via Wi-Fi to the extender (essentially a bypass of connecting directly to the modem itself). I can almost guarantee this will fix it permanently and it’s much easier/cheaper than buying another modem and no need to play around with settings on the devices. I did this months ago and have had zero issues since.

(edited)

dave006

Scholar

 • 

1.1K Messages

3 months ago

The reason this works is the Wi-Fi extender uses 5 Ghz to communicate with the Gateway and it also allows your iPhones and other 5 Ghz devices to be close enough to get a 5 Ghz connection to the extender.

 

Dave

Get started...

Ask a new question