Find the perfect gift for the grad in your life with Graduation gifts that connects us from AT&T.
Get superfast AT&T Fiber internet
Mistine's profile

New Member

 • 

1 Message

Wednesday, June 8th, 2022 9:36 PM

Double NAT on Xbox’s

Hello,


I’ve spent countless hours with ATT/Eero support to try and fix numerous issues. One that seems to be re-occurring and miraculously fixing itself AFTER I’ve spend hours on the phone with support is my NAT type reverting back to Strict on 1, 2, or all three of the Xbox’s I have hooked up directly through Ethernet. The combination of strict NAT type changes, but ultimately at least one, two, or all Xbox’s still seem to have Strict NAT after each “fix” from eero or ATT. 

With the help of either ATT or Eero (at one point I had both techs from each company on the line in two separate cell phones!) - We’ve tried, IP Passthrough and DMZ setup, Port forwarding, enabling and disabling the “Optimize for Conferencing and Gaming” and “WPA3” Eero labs settings in the app, changing DNS setting in Eero app, port forwarding settings in modem login settings… There been so many troubleshooting steps we’ve taken that I’ve lost track, but if you asked - I’d probably remember.

Ultimately, I know the issue… After becoming more familiar with networking than I ever expected to be due to the frustration of my issue - I’ve googled and read multiple forums… Including this one. 

Issue is, that my ATT gateway (BGW320-500) is unfortunately a modem/router combo. The Eeros being connected as well is causing a double NAT with the router portion of the BGW320. The fix should be putting the BGW320 in IP Passthrough, but that’s been done and the NAT issue still persisted. It sure if the “techs” gave me the right configuration settings… 

@JefferMC you have been the one person on here that I’ve followed rigorously! You seem to have the knowledge and expertise that I desperately need! Could you please try helping me out with this??

My configuration :

- eero Pro 6 gateway hub connect directly to ATT BGW320-500 through Ethernet connection. (This is the only thing connect to the ATT gateway) 

- 1st Xbox is connected through Ethernet (CAT-8 25ft) cable to the eero gateway itself.  

-2nd and 3rd Xbox’s are connected to 2 separate eero Pro 6 hubs in two different rooms in the house through Ethernet cable. 

If there’s anything else you need, please don’t hesitate to ask… I’m sure I’m missing something.

ACE - Expert

 • 

35.6K Messages

2 years ago

The IP Passthrough is the correct configuration.  The struggle may be to get the eero to properly obtain the Dynamic Public IP address on its WAN interface so that it can properly do the NAT to the Dynamic Public IP so that the Gateway doesn't have to (if it doesn't get the public address on its WAN, then it NATs to the IP it does have, and the Gateway has to NAT it again to the public).

So, step one is to configure the BGW for IP Passthrough to the eero.

Turn them both off.  Turn the BGW on and wait 10 minutes.

Turn the eero on and let it boot up.

Check its WAN IP.  If 192.168.1.x, turn it off, wait 10 minutes, and go back to the previous step.

Once you have the Public IP on the eero's WAN, then try to make sure you can access the Internet from behind the eero.  Then try your gaming systems.

Report back and let us know how it's going.

1 Message

2 months ago

@JefferMC , I know this feed is old, but I just came upon it having same equipment as this member. If both networks were active (Eero Pro 6 plugged into BGW320) Would connecting Xbox and Playstation 5 to the BGW using ethernet cables bypass the Eero network and eliminate the double NAT issue since it is not using Eero? I would use Eero for wifi to all other devices. 

(edited)

ACE - Expert

 • 

35.6K Messages

2 months ago

Yes, connecting directly to the Gateway would bypass the NAT done by the Eero, and so their traffic would only be NATted once, by the Gateway.

Keep in mind that the Gateway doesn't do UPnP, so you may find that you have to do some port forwarding to get some game features to work the way you expect.

ACE - Professor

 • 

5.6K Messages

2 months ago

@lopijr 

Do you have the Eero properly setup with ip passthrough?

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.