Find the perfect gift for the grad in your life with Graduation gifts that connects us from AT&T.
Get superfast AT&T Fiber internet
esullivan_1's profile

Contributor

 • 

6 Messages

Saturday, September 17th, 2022 2:01 PM

BGW320-505. IP Passthrough. Crappy device

For as large as AT&T is, you'd think they could provide a better device. The routing\firewall\DHCP configurations are all crap.

I'm trying to put this thing in IP passthrough mode. Which I can "get to work" and my actual device is getting a WAN IP. 

However. It appears I cannot use the 192.168.1.1 subnet because this device is using it. It also appears that, even in the home network settings, for the LAN DHCP, if you turn that off it turns off the DHCP that it gives to my router. The WAN one. That's crap, should be separate.

Can't even change the local DHCP range be use the at&t modem is on that subnet.

This thing is absolute dog (Edited per community guidelines). There has to be a better option. 

ACE - Guru

 • 

9.9K Messages

2 years ago

Both devices can't be on the same subnet, change one or the other.  I chose to change the BGW to 192.168.2.254 because I wanted to keep my third party router on the 192.168.1.xxx subnet.

Contributor

 • 

6 Messages

2 years ago

I understand that both cannot use the same subnet.  I am saying that turning off DHCP should not stop the modem from giving my router an IP.  Should be local DHCP only since it's under home network.

ACE - Guru

 • 

9.9K Messages

2 years ago

DHCP is how the gateway gives the WAN IP to your third party router in IP Passthrough.  We can argue whether or not that's a crappy way to work but given how many other crappy things the AT&T gateways do (or don't do) it's just par for the course. 😕

Scholar

 • 

4K Messages

2 years ago

@esullivan_1 

You don't have to use the Gateway's DHCP Service to use IP/Passthrough mode.

  • DHCPS-dynamic: The public WAN IP address is delivered by the AT&T provided RG's DHCP server to the first device that requests a DHCP address on the LAN.
  • DHCPS-fixed: The public WAN IP address is delivered by the device's DHCP server to the device whose MAC address has been specified.
  • Manual: A LAN device must be manually configured with the AT&T provided device's assigned WAN IP address and gateway information. To use this method, you will need to contact Customer Care to obtain your Wan IP Address, default gateway, and subnet mask.

You might want to try the Manual IP method below. Along  with changing your BGW320's subnet to any valid non-routable Class A network. Examples: 10. 172. 192.

Manual WAN IP Assignment

  1. Open a browser on a computer that is directly connected to the RG.
  2. In the address bar, enter http://192.168.1.254.
  3. Select the Firewall tab in the RG GUI page.
  4. Select IP Passthrough below the Firewall tab.
  5. Enter the Device Access Code if prompted.
  6. Select Passthrough option from the Allocation Mode drop-down menu.
  7. Select manual from the Passthrough Mode drop-down.
  8. Select Save. A re-starting gateway reminder message appears. 
  9. Select Restart Now to complete the setting change.
  10. Manually configure your device to use the WAN IP address, default gateway, and Subnet mask provided to you by customer care.

Note: The WAN IP, default gateway, and subnet mask the AT&T gateway is sharing are assigned to the gateway through DHCP. If AT&T gateway receives a different WAN IP, you will lose connectivity on your device until you manually update its settings. Using the DHCP-fixed option is recommended.

Default Server
Motorola gateways also include an option to use Default Server mode. Default Server mode allows the AT&T provided gateway to forward all externally initiated IP traffic (TCP and UDP protocols only) to a specified device (default host) on the LAN. A device configured for a default server will continue to receive a LAN IP address, instead of being assigned a WAN IP.

Configuring Default Server Allocation Mode
  1. Open a browser on a computer that is directly connected to the RG.
  2. In the address bar, enter http://192.168.1.254.
  3. Select the Firewall tab in the RG GUI page.
  4. Select IP Passthrough below the Firewall tab.
  5. Enter the Device Access Code if prompted.
  6. Select the Default Server option from the Allocation Mode drop-down menu.
  7. Enter the IP address of the Device to be set as the default server in the Default Server Internal Address field.
  8. Select Save. A re-starting gateway reminder message appears.
  9. Select Restart Now to complete the setting change.

Dave

(edited)

ACE - Guru

 • 

9.9K Messages

2 years ago

🤣@dave006   Arrgh, you beat me to it!  I was just thinking about this and remembered the Manual option for IP Passthrough. 

Contributor

 • 

6 Messages

2 years ago

If I use manual, I would need to enter an IP though, correct?  I won't get one from AT&T?

ACE - Guru

 • 

9.9K Messages

2 years ago

No, you'd enter your public IP address.  Essentially the same as happens now with DHCPS, just manually so you could shut down DHCP on the BGW.

1 Message

7 months ago

Thanks for the explanation on how to setup pass-through mode, Tony. I was having issues with subnet conflicts with my personal router and the AT&T router (battle of the DHCP servers!).  Moving the DHCP server for the AT&T router to another subnet and am good to go now. I'm tempted to go manual for pass-through, but what happens if my WAN IP changes when the lease is up for it? I'd rather not have to deal with manually updating the WAN IP when needed. Wish there was a bridge mode for the AT&T router!

7 Messages

2 months ago

The DHCP lease is really long, I believe 24 hours.  As such I have not seen my public/WAN IP change ever since I started service in January/months.  But as you note that is the warning, and DHCP Static is the preferred method, where you select the MAC that receives the WAN IP.

There appeared to be a bug when I restarted my 3rd party ASUS router when I reboot it it would then be assigned a local IP of the form 192.168.1.xxx, but I have since switched to using the BGW320-500 as router sans WiFi, and my ASUS network still does AiMesh so I'm okay.

I still pop in once in a while hoping to see AT&T change their policy.  Oh well, one can stay hopeful...

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.