Available Now: Buy the new iPhone 14, iPhone 14 Pro and iPhone 14 Pro Max from AT&T!
Get superfast AT&T Fiber internet
J

New Member

 • 

6 Messages

Thu, Apr 29, 2021 3:40 AM

BGW320-505 Double NAT Asus XT8 Strict NAT vs Open NAT & Double NAT on XBOX

OK - I have the BGW320-505 and was using Orbi mesh system. Recently upgraded to ASUS XT8...I'm a noob when it comes to this stuff

-BGW has antennas turned off

-Xbox keeps getting double NAT when connected to XT8

-troubleshooting with Xbox tech support lead us to connect Xbox via cable directly to modem which gave strict NAT setting

-then connected to the hot spot on my iPhone bypassing ATT all together and didn't get double NAT

-Xbox tech support says ATT needs to set NAT to OPEN

-spent 1 hour with Advanced ATT tech support (not sure about that) and they say that the antennas need to be on to have the NAT OPEN. If true, that defeats whole purpose of mesh system and I'll never get rid of double NAT.

Any advice on how to correct this is greatly appreciated.

Accepted Solution

Official Solution

JefferMC

ACE - Expert

 • 

29.9K Messages

1 عام مضت

  1. Go to the BGW 320 Gateway's internal pages at http://192.168.1.254/
  2. Click on the Firewall tab
  3. Click on the IP Passthrough sub tab
  4. Enter the password from the sticker on the side of the Gateway, press Continue
  5. You should see Allocation Mode set to passthrough
  6. You should see Passthrough Mode set to DHCP-Fixed
  7. Click on the dropdown beside Passthrough Fixed MAC address that says "Choose from list", and select your new ASUS router from the drop down (you may need help recognizing it... look at its MAC address and match it up).
  8. Click Save

Reboot the Gateway... just to be sure.  Wait a few minutes.  Then Reboot the ASUS Router.

JefferMC

ACE - Expert

 • 

29.9K Messages

1 عام مضت

AT&T, per se, doesn't have to do anything to change your NAT type.  You have to make changes in the Gateway or your network equipment to make that happen.

  1. Did you have the BGW320 set up to put the Orbi in IP Passthrough mode?
  2. Did you change that setting to the ASUS XT8?
  3. Did you have UPnP enabled in the Orbi?
  4. Do you have UPnP enabled in the ASUS XT8 (not that this will matter until you resolve #2 above)?
  5. If you didn't have UPnP enabled in the Orbi, did you have a list of port forwards in the Orbi?  Did you transfer those to the ASUS XT8?

New Member

 • 

6 Messages

1 عام مضت

JefferMC - thx for the response. I will check those things. Don't recall the settings in the Orbi, but will get with Asus TS and see if we can check those points you mentioned. Agai, thx!

JefferMC

ACE - Expert

 • 

29.9K Messages

1 عام مضت

The IP Passthrough set up will be in the BGW 320.  Proper setup would have been to configure the BGW 320 to handle the Orbi in Passthrough mode.  This would have been done by the Orbi's MAC address.  The ASUS will have a different MAC address, so the BGW 320 IP Passthrough setup has to be changed from the Orbi to the ASUS.

Until this is done, the ASUS has limited capabilities.  Once this is done, then the ASUS can do Port Forwarding, UPnP, etc.

ATTHelp

Community Support

 • 

200.4K Messages

1 عام مضت

We're here to help with your Orbi system, @JudoStud.

 

 

Thank you @JefferMC for the great information. 

 

 

Here is more information on how to Connect Orbi Wi-Fi to an AT&T Modem and how to configure IP passthrough. This will show you how to use the Orbi as your primary internet source. 

 

 

Let us know if this helps. 

 

 

Elmi, AT&T Community Specialist. 

New Member

 • 

6 Messages

1 عام مضت

JefferMC - can you walk me through the steps I need to take in the 320 GUI to do those things, please?

New Member

 • 

6 Messages

1 عام مضت

ATTHelp - no longer using the Orbi, but using the ASUS XT8. Do you have specific instructions for that?

Thx

New Member

 • 

6 Messages

1 عام مضت

ATTHelp - also using BGW320-505 modem and hoping you have specific instructions for that model to connect to an ASUS XT8.

Thank you, again

ATTHelp

Community Support

 • 

200.4K Messages

1 عام مضت

Thank you for the updated information, @JudoStud.

 

 

You will have to configure IP passthrough and DMZ plus. This configuration is often suitable for connecting third party equipment for networking, such as a router, to the AT&T provided gateway

 

 

Let us know if this helps or if you have already done this.

 

 

Elmi, AT&T Community Specialist. 

New Member

 • 

6 Messages

1 عام مضت

JefferMC - you the man!!! The wrong MAC address was in that setting. I selected the correct one and all is working correctly!!!

ATTHelp - I wasted many hours with "Advanced" support on this issue and NONE of them suggested this simple fix. If your people would have just given me simple directions like JefferMC did, I would not be a ticked off ATT customer. We are not all experts in Networking/Connectivity and sending articles or the link you provided would still not have solved my problem. I hope you see the above as an example of what REAL customer service is supposed to look like.

JefferMC

ACE - Expert

 • 

29.9K Messages

1 عام مضت

The "wrong MAC address" was 99.44% likely the MAC address of your older Orbi system.  It just needed to be changed because you changed routers.  If you get another router, you'll have to change this again.

ATTHelp

Community Support

 • 

200.4K Messages

1 عام مضت

@JudoStud, @JefferMC, thank you for your commutations on this double NAT issues.

We are delighted to see a resolve has been found, and other Community Forums members will benefit from this discussion.

 

 

If you have any additional concerns, please feel free to reach out to us.

Thank you for contacting us on AT&T Community Forums!

 

Lafayette, AT&T Community 

New Member

 • 

4 Messages

1 عام مضت

@JefferMC - I have the same issue - Double Nat - also I am verifying this by using the cmd command: tracert 8.8.8.8

The initial two responses I get both start with an IP of192.xxx.xx.x.  One is for my google nest and the other for the BGW320-505.

I assumed if I have the BGW320-505 in passthrough mode I would only get the one for my Google Nest?  but that isnt happening

JefferMC

ACE - Expert

 • 

29.9K Messages

1 عام مضت

That doesn't necessarily mean you're actually doing double NAT.  If your BGW 320 is in IP passthrough mode to the router your traffic is passing through, it's not performing an additional NAT operation, but it would respond with 192.168.1.254 (or whatever its IP is).

Check that your router's WAN address is your public address.  If so, then it is doing the only NAT operation.

New Member

 • 

4 Messages

8 m مضت

I'm digging into this same problem on my BGW210, with an Asus RT-AC68U router behind it. The BGW210 has passthrough on, DHCPS-fixed mode with the Asus router's MAC address set and confirmed, packet filter disabled, and "Firewall Advanced" options all off. Everything rebooted. The BGW210's Home Network / Status page shows "IP Passthrough Status" as "On (public IP address)" and shows the "IP Passthrough Address" as the correct WAN address.

Buuuut the Asus shows its WAN IP as what it's getting from the BGW210: 192.168.1.2 :(  And traceroute shows the Asus, then the BGW210, then out. The Asus's LAN is 192.168.21.x fwiw.

Is there anything I should be doing in the Asus's WAN config?

Or should I configure the cascaded router? I tried, but it doesn't like "192.168.21.0" for Network Address, tells me "Cascaded Router Network Address must be a WAN-side subnet" which didn't help. I used to have the Asus on a 10.stuff.stuff.0 addressing scheme but it didn't like the 10.... so I changed it to this [sigh].

Any insight appreciated! I know it's an old thread and all, helpful just to post it all the same thanks.

(edited)

Need help?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.