Available Now: Buy the new iPhone 14, iPhone 14 Pro and iPhone 14 Pro Max from AT&T!
Get superfast AT&T Fiber internet
srudenko's profile
srudenko
Rising Star
Supersonic 25!
#1 Star!

Mentor

 • 

46 Messages

Wed, Feb 16, 2022 1:06 AM

BGW320-500 issue with own router and security DVR

My parents switched from Xfinity to ATT today.

They have their own router (TP-Link M4R AC1200). It was configured to be 192.168.1.1 and provide DHCP addresses on that network.

After the tech connected the ATT gateway to the router it somehow automatically changed it's LAN IP to 192.168.0.1 which is fine. I updated the static IP on the DVR and updated port forwarding as well to reflect new IP. All ports are same.

ATT gateway is in Passthrough mode

DHCP-fixed and the MAC of the router is selected.

Everything is working except the DVR cameras.

I can't figure out why because the same exact setup worked with Xfinity.

Any advice?

ATT Screenshots:

TP-LINK Screenshots

Accepted Solution

Official Solution

tonydi

ACE - Guru

 • 

7.4K Messages

7 m مضت

It's late and the fog is starting to roll into my head but shouldn't the Internet (WAN) IP on the TP-Link be showing the public IP?

JefferMC

ACE - Expert

 • 

29.9K Messages

7 m مضت

How are you testing it?  From inside your network or out (e.g. over the Cellular network)?

srudenko

Mentor

 • 

46 Messages

7 m مضت

I tried both inside and out. Also tried through the various port checking sites. All the ports the DVR uses are not accessible which makes no sense because all the port forwarding rules in the TP-Link are same as they were when it worked when Xfinity was the provider.

Only things that changed are:

-Gateway device/internet provider

-IP and DHCP of the router. Went from 192.168.1.x to 192.168.0.x

-Updated static IP on the DVR

-Updated port forwarding rules to update the destination device/IP

I even tried deleting all the port forwarding rules and created one with a range to open all ports. That didn't work...

I have ATT fiber at home with nearly identical setup and my DVR connection works fine. Main difference is I have the older gateway (black) but the web interface and settings appear to be identical.

So I'm stumped...

I guess I can try connecting the DVR directly to the ATT gateway via Ethernet instead of the router, change it's IP to be in same range and then create forwarding rules on the gateway but have to figure out how that's done.

srudenko

Mentor

 • 

46 Messages

7 m مضت

@tonydi 

I think you are right but I can't figure out why. IP Passthrough is enabled on ATT gateway. Both the gateway and router have been rebooted.

TP Link article says there maybe another NAT device connected to the WAN port of the ATT gateway but if there is I'm not sure what it is or where it is or what to do about it.

TP Link KB:

WAN IP should be a public IP address. The WAN IP is assigned dynamically by ISP. If the WAN IP address of the router is not a public IP address, but a private IP address, that means there is another NAT device connected to the WAN port of the router. You need to open the service ports on that device as well. 

browndk26

ACE - Professor

 • 

4.8K Messages

7 m مضت

You might consider factory resetting both devices and starting over. There may be a setting in the router from the previous setup affecting the cameras. What else is connected to the gateway if anything? Any switches in use? I had a situation once when two Ethernet cables connected to my gateway and switch prevented me from getting to the internet. Disconnected one cable and all worked fine. 

srudenko

Mentor

 • 

46 Messages

7 m مضت

I can try resetting the TP-Link Deco to factory as last result although other than WiFi there are hardly any other customizations.

What about the ATT Gateway? How do you reset that and what all would have to be reconfigured? Is it something simple like going back in and turning off WiFi again and enabling IP Passthrough or will other things that get reset need to be reconfigured as well for the internet to work?

It seems like IP Passthrough isn't working properly even though its enabled and the correct device/MAC is selected.

browndk26

ACE - Professor

 • 

4.8K Messages

7 m مضت

Hold the red reset button on the back of the gateway until it restarts. ATT gateways are glitchy sometimes. Factory resets usually help. If you are using ip passthrough, and the tplink Wi-Fi, turn off the gateway Wi-Fi. No need to have both in. 

srudenko

Mentor

 • 

46 Messages

7 m مضت

I will try the ATT Gateway reset. Just want to make sure that it won't 'reset' something that I can't reconfigure myself afterwards ;)

Is it safe from end user perspective? I don't want to call ATT support.

browndk26

ACE - Professor

 • 

4.8K Messages

7 m مضت

It’s safe to do. All passwords, Wi-Fi network names and access code are changed to factory. So you’ll need to change them if you had previously changed them. All are on the gateway info plate and usually a yellow sticker. 

srudenko

Mentor

 • 

46 Messages

7 m مضت

Issue resolved

Ultimately it was a problem with IP Passthrough and the TP-Link router not getting a public WAN IP. Instead it was showing the ATT Gateway private IP. Thanks to @tonydi for pointing that out which provided the correct cause of the problem.

I did end up resetting the ATT Gateway. I am not sure if that helped overall but it did help to clear out the drop down where you pick the device / MAC to use for IP Passthrough. Original list had a lot of items in it with non-existent IP's instead of names. After the reset I made sure to only have my laptop and the TP-Link router connected. So there were only 2 devices in the drop down and TP-Link actually had it's name in there before the MAC. After selecting and saving it I rebooted the router but it still didn't have the public WAN IP. I then rebooted the gateway and that did it.

This probably could all have been avoided if I was present during the installation because I would have asked to only connect the gateway and leave our own router unplugged. I then would have changed the ATT gateway to be on the 192.168.0.x network instead of 192.168.1.x because that caused the TP-Link device to freak out and change its network settings automatically. Lessons learned.

Thanks everyone

Need help?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.