Check out AT&T's Valentine's Day Gift Guide for ideas & deals on the new Samsung Galaxy S23!
Get superfast AT&T Fiber internet
S
seegem
20th Community Anniversary
#1 Star!
The 5th element!

New Member

 • 

67 Messages

Friday, February 12th, 2021 10:12 PM

BGW320-500 Bridge Mode and/or IP Passthrough Question

Hello everyone,

I have 1Gbps home fiber from AT&T.  I've had it for 2 years, works great.

Yesterday, a tech visited to upgrade my equipment to a brand new BGW320-500.  I also ordered a static IP address.

What I want to do is have this device be as "dumb" as possible.  I have a Ubiquiti Dream Machine Pro, and I want to configure this device with the static IP address I have, and, have it handle all routing/security/etc.  i.e. I want the AT&T device to do nothing (no wifi, no firewalls, nothing), and, I also do not want the AT&T device to give out its own IP addresses (I want my Ubiquiti Dream Machine pro) to handle everything (as if it was directly connected to the internet itself).

I've been told what I want/need is to configure the AT&T device to be in "Bridge Mode".  However, I cannot find this setting in the config menus.  I do find "IP Passthrough" which people have told me is essentially the same thing. Is that accurate?  Is "IP Passthrough" what I want?

If IP Passthrough is what I want, then how do I configure the AT&T device, with a static IP address?  Or no IP address?  

Any help & guidance would be appreciated.  I've searched the forums and cannot make clear sense on what I've found there.

Thank you,

Mark

Tutor

 • 

11 Messages

2 years ago

I can get the BGW to pass the static IP to my MacBook by plugging directly in, so not sure why it won't pass to my edge router which is plugged into a separate port and Is locked to the IP passthrough by MAC address. Maybe  I shouldn't use IP passthrough with the edge router? Ill have to try that

seegem

New Member

 • 

67 Messages

2 years ago

Yeah your router should be in static IP mode, that's how I got it to work

Tutor

 • 

11 Messages

2 years ago

I put it in manually define and enter the static IP that works on my MacBook but I lose connection when using it in the edgerouter. I have to leave it in DHCP for it to have internet

JefferMC

ACE - Expert

 • 

31K Messages

2 years ago

Trying to mix IP Passthrough mode to a Router with a Public Static Block on that same router is going to make your life miserable.

Either you need to handle the Public Static Block on the Gateway itself, or you need to dedicate a router to just the Public Static Block and not point IP Passthrough to that router.

Tutor

 • 

11 Messages

2 years ago

So do I need to turn IP passthrough off completely? Im still wanting to bypass the bypass the gateway and use my edge router. Will giving the edge router a static public IP allow it to bypass the firewall of the gateway?

JefferMC

ACE - Expert

 • 

31K Messages

2 years ago

If you want a router to handle your Public Static Block, the prescribed way of doing that is to move your subnet information from Public Subnet to the Cascaded Router section. 

Your Cascaded Router should be set up so that its WAN address is just an IP on the Gateway's private LAN subnet, which can be done by Assigned DHCP address or by assigning it an address outside of the Gateway's DHCP pool and manually configuring the WAN on your router.

You would manually configure your router's LAN address to be the public static's router address (the 7th number in the block) and set the subnet mask to 255.255.255.248.  You can either do DHCP on your router's LAN for the 5 public static or manually configure them on each device.

You could do IP Passthrough to a different router at the same time if you want, but asking your router to handle both a NATted private subnet and the public static block by direct access at the same time is beyond the capabilities of most consumer routers.

 

Alternately, with the Public Subnet in place in the default configuration, you can manually assign one of the 5 IPs to a device, set its gateway to the router address, give it the 255.255.255.248 subnet, and hook it directly to the Gateway and it should function immediately.  That device could be a router, and that router could do NAT for a private subnet behind it.

(edited)

Tutor

 • 

11 Messages

2 years ago

OK so I am now passing one of my public static IPs on the my ubiquiti edgerouter. I turned IP Passthrough OFF, and entered one of my static public IPs into the edgerouter (the tech had already entered my static range into the gateway when installing). Thats all I did. I didn't do anything with the cascading router options. https://www.reddit.com/r/ATTFiber/comments/iikbvv/bgw320_ip_passthrough_wfirewall_wan_ports_on_a/

I reference this to help, i'm in basic routed mode

JefferMC

ACE - Expert

 • 

31K Messages

2 years ago

That's fine as long as you only want to use one of your static public IPs.  This is basically what I said in my last paragraph.

If you don't want to use the second or third (etc.) public addresses then you're all set.

(edited)

Tutor

 • 

11 Messages

2 years ago

I can confirm that I have 2 different routers plugged into the gateway with both using different public static IPs. both are passing traffic to the internet without issue.

JefferMC

ACE - Expert

 • 

31K Messages

2 years ago

I can confirm that I have 2 different routers plugged into the gateway with both using different public static IPs. both are passing traffic to the internet without issue.

Cool.  And if you want to dedicate another IP to another router, that's fine.  What I was trying to indicate is that if you wanted to put a machine "behind" one of those two routers with one of the other (now 3 remaining) public IP addresses, that will be rather difficult.

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.