Learn how you can get the iPhone 13 now!
boviner's profile

Tutor

 • 

4 Messages

Mon, Feb 11, 2019 5:35 PM

BGW210 broken for Nighthawk 4XS / AC2600 / R7800 running DD-WRT

(Note: Apologies for the formatting, although this MCE editor allows indents, the back-end scrubs them out.)

 

Hello World, I'm at a bit of a loss after troubleshooting for the past few days.

 

Over the past two weeks--excluding 02/09 - 02/11--the following setup has been working perfectly.

 

Components:

1. (C1) BGW210-700 Router/Modem (ONT connected to wall-mounted terminal via Cat5e)

2. (C2) NETGEAR R7800 (Nighthawk 4XS / AC2600; Router flashed with DD-WRT version 10/10/18)

3. (C3) Laptop

 

Configuration which worked for the two weeks from the install date (01/25/19 until 02/09/19):

1. C1...

Public Subnet (Static IP block)

Private Subnet

Default DHCP-Pool is "Public"

IP Passthrough (dynamic)

Wi-Fi OFF

2. C2...

DHCP ON

Successfully received Public IP from C1

QOS OFF

IPTables ON

Firewall spoof-protections ON

VPN Server ON

VPN Client OFF

+ other (W)LAN-based configurations

 

As of 02/09/19--in the wee-hours of the morning--that configuration no longer works.

 

I expect C1 to recognize C2 within the menu Device > Device List and provision it an IP address as configured.

 

What actually happens:

1. C2 is working as expected, deduced by the following facts:

- Network activity looks normal for C2 (Note #8) and all other rather complicated networking operations of C2 is working as expected;

- prior history of C2 is 100% solid working as expected ever since it was setup early last year w/ Comcast.

2. C1 only assigns an ip address to C2 at 3AM in the morning (Note #6); but to C3, on-demand.

 

Notes:

1. I've been on the phone with support for ~ 3 hours. Compared to Comcast AT&T Support staff is fantastic. They take notes & are not afraid to pass the ball to a higher-tier support staffer although they seem to have no control over the router's firmware version.

2. I've found links to C1 firmware online. Both versions flashed successfully (the ONT cable needed to be unplugged to prevent AT&T from re-flashing the device with 1.8.18). Neither flashes fixed the issue.

1.7.17 @ http://gateway.c01.sbcglobal.net/.../1.7.17.bin

1.8.18 @ http://gateway.c01.sbcglobal.net/.../1.8.18.bin

3. I've tried three different cables (Cat6/7/7).

4. This C2 setup worked with Comcast for months and with AT&T for the past two weeks.

5. I've flashed the firmware on the Nighthawk starting with a fresh DD-WRT install to no avail.

6. At 3AM last night, it seems that C1 recognized C2 per the following entry under C1 menu Device > Device List:

 

MAC Address FF:FF:FF:FF:FF:FF (C2 MAC)
IPv4 Address / Name 69.xxx.xxx.xxx / passthrough (AT&T-provisioned IP)
Last Activity Mon Feb 11 03:03:25 2019
Status off
Allocation dhcp
Connection Type Ethernet LAN-1
Mesh Client No

 

This entry is backed up by packet metrics under C1 menu Home Network > Status:

LAN Ethernet Statistics

  Port 1 Port 2 Port 3 Port 4
State up up down down
Transmit Speed 1000000000 1000000000 0 0
Transmit Packets 245422 442146 0 0
Transmit Bytes 23588686 167977371 0 0
Transmit Unicast 0 0 0 0
Transmit Multicast 0 0 0 0
Transmit Dropped 0 0 0 0
Transmit Errors 0 0 0 0
Receive Packets 36156 179205 0 0
Receive Bytes 2516398 41544206 0 0
Receive Unicast 0 0 0 0
Receive Multicast 0 5606 0 0
Receive Dropped 0 0 0 0
Receive Errors 0 0 0 0

 

Normal NAT entries via Diagnostics > NAT Table for C2 are seen when C1 is apparently recognizing C2 overnight (i.e. italy / moscow ips *cough*62.173.145.72*cough* scanning for pbx-related vulnerabilities).

7. C1 is assigning C3 IP addresses, both public/private as expected. This points to C1 handling C2 and C3 different which I find interesting.

8. C2 graphs for the WAN eth0 interface are showing the following:

image6845.jpg

 

This looks like C2 is trying to get C1 to do something like give it an IP address.

C1 more or less acknowledges C2 by showing the C2-connected eth port as being "up"; but shows C2 in Device > Device List as status: off

9. I've tried a static ip setup on C2 with setting up C1 for manual passthrough to no avail.

10. I've tried the "Cascaded Router" setup (requires public dhcp to be off, non-optimal) to no avail.

11. Since I've started writing this post, Port 1 under C1 menu Home Network > Status reflects the C2 graphs in Note #8 with 7153 more packets received (457792 bytes). Last activity under Device > Device List for C2 remains to be Mon Feb 11 03:03:25 2019

 

Any advice/help from the community/AT&T would be greatly appreciated.

- Does anyone else seeing a similar issue with BGW210-700?

- Does anyone have a replacement suggestion for BGW210-700? Alternatives sound buggy as well (w/ passthrough) and slower.

- Might someone know of an online bug tracker for BGW210-700 firmware?

- Might someone know if anything related to this setup changed on BGW210 / AT&T infra the morning of 02/09/19?

 

Best regards,

John

1 Attachment

Tutor

 • 

4 Messages

3 y ago

Just an update in case anyone is following, those outbound requests from the nighthawk (C2) was a machine behind the router. Inside DD-WRT I left default configurations: "Default Gateway: 0.0.0.0" which is saying "let any device on the router be the gateway, including myself." BGW210-700 was like, "Hey, I'm a default gateway". And DD-WRT was like, well, there you go. And the machine behind DD-WRT was provisioned a public ip address via BGW210.

 

Since I've corrected "Default Gateway" to be the DD-WRT's address the outbound requests shown in the chart above has flat-lined. I've ordered an 5628AC (the pace one) per the reps suggestion as well as a new nighthawk I hope to return in the box. If the Pace box doesn't work I'll try the new nighthawk and see if I can get a return under some kind of warranty.

 

Best regards,

John

Tutor

 • 

4 Messages

3 y ago

For anyone who's following, the solution was replacing the Nighthawk. Happy to have installed the 5268AC as a step in the troubleshooting process (a bit faster than the BGW210 it seems) but alas the Nighthawk's WAN port was fried. Also ran into a post somewhere online where this happened to someone else as well.

 

AT&T firmware is working great! Thanks for a great network w/ great support.

 

Best regards,

John

Contributor

 • 

7 Messages

1 y ago

Amazing how helpful ATT is isn't it...

Need help?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.