Get superfast AT&T Fiber internet
P

New Member

 • 

7 Messages

Monday, February 8th, 2021 4:08 PM

AT&T Fiber - Disbale DFS on 5 GHZ radios

I'm trying to install a Roku Stick+.  Roku tells me that their device will NOT connect to the 5 GHz radios in the AT&T Fiber Router as long as the 5 GHz range are in the DFS range.  So the questions are 1) Is there a way to manually set the 5 GHz channels on a Nokia BGW320-505 router OR 2) is there a way to disable DFS on the router?

Teacher

 • 

115 Messages

3 years ago

This will require a bit of research on your part regarding channel selection. Assuming this is still relevant, in the US, non-DFS channels on 5ghz are 36-48, and 149-165. So if the router is using a channel that is outside of these parameters, then is using a channel that is DFS. Unfortunately due to FCC requirements and to avoid interference with radar equipment, DFS cannot be turned off. Your best option is to manually select a channel that is not restricted or subject to DFS.

ACE - Expert

 • 

35K Messages

3 years ago

You can manually select the channels on the BGW 320 gateway.  Home Network > Wi-Fi > Advanced Options 

Scholar

 • 

3.8K Messages

3 years ago

@patricka02 just change the SSID (name) of the 2.4 or 5 GHz radio network on your BGW320 and connect your Roku to the 2.4 Network ID.

Note: This will break your ability to use the full Mesh capabilities of the BGW320 but how many devices do you use while roaming round your location.

The other quick option is to enable the Guest network as it will be 2.4 GHz only and you can connect your Roku to it. The Roku does not really need 5 GHz speeds.

Dave

New Member

 • 

7 Messages

3 years ago

Thanks for the feedback.  Just to be clear, the Roku currently connects to the 2.4GHZ network (I have the same SSID for both bands per AT&T recommendation), but I'm trying to put it on the 5 GHZ network, so I can get away from neighborhood congestion on the 2.4GHZ band.  As such, I turned off the 2.4 GHZ radio and rebooted the router.  Strangely, the router rebooted and the the 5GHz radio came up with one non-DFS channel (52 & 149) and the Roku connected to it.  Then I turned the 2.4 GHz radio back on and rebooted again. The router came back with DFS channels (52 & 100), so the Roku device will NOT connect at 5 GHz.

Finally, a comment to @JefferMC and @bogar90706:  It appears that AT&T introduced a bug into firmware 2.10.6 which disabled the ability to manually select the 5 GHz channels.  Here are a couple links:

https://forums.att.com/conversations/att-fiber-equipment/missing-5ghz-wifi-channel-selection-on-bgw320/5fd641377288d52d004c4cbd

https://forums.att.com/conversations/att-fiber-equipment/second-5ghz-radio-disabled-on-bgw-320500-320505/5fcbd7f6b763bd30fe151af3?page=4

Scholar

 • 

3.8K Messages

3 years ago

It appears that AT&T introduced a bug into firmware 2.10.6 which disabled the ability to manually select the 5 GHz channels. 

Not a bug it appeared to be a planned change to reserve the High band 5 GHz radio for Mesh client support.

Since you can't control which 5 GHz channels you will be assigned that's why I suggested you change you SSIDs to be unique or use the Guest SSID on 2.4 GHz for your Roku.

Dave

New Member

 • 

7 Messages

3 years ago

Hi @dave006.  Thanks for your prompt message.  I'm not sure why moving to the guest 2.4GHz helps me.  As mentioned above, it currently connects on the 2.4 GHz radio, but I have a lot of neighbors that are on the 2.4GHz band, many of them on weird channels like 4 that are bleeding over and interfering.  This is why I want to get to 5 GHz.

Can you explain your idea again?

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.