Get superfast AT&T Fiber internet
FrogFan's profile
FrogFan
20th Community Anniversary
#1 Star!
Helpful 1

Teacher

 • 

53 Messages

Monday, December 5th, 2022 5:20 PM

5G channel selection on BGW320

Hello,

I have AT&T's fiber 300 service with a BGW320 gateway.  I have separate networks defined for 5G and 2.4G.  5G channel selection is set to "Automatic", and when I go to "Advanced options", there is no option to change the channel.  The problem I'm having with that is that the gateway will change the wifi channel from time to time and, invariably, when it does, the 5G network is not recognized by my TCL Roku TV.  To "fix" the problem, my only option is to go into the gateway settings for 5G and select "find the best channel" and cross my fingers that it finds one that is recognizable by my TV.  I could also force the TV to use the 2.4 network, but that is highly congested and I'd rather not do that.

This issue is evidently part of a larger problem with the firmware on this gateway if I'm understanding other posts correctly.  Rather than dive into those details, which I really don't understand, I'm wondering if there is any way to "fix" the gateway so I can change the channel and tell it to leave it alone.  Or, do I need to make a service request of AT&T and try to get them to replace the gateway?

Incidentally, my gateway does allow me to change the 2.4G network channel from "Automatic" to a specific channel.  This is what I'd like to see for the 5G network as well.

Thanks very much for any help!

FrogFan

Teacher

 • 

53 Messages

2 months ago

Just a quick followup.  First, gateway is a BGW320-505 (Nokia).

I've continued to poke around and I'm discovering that the option to change 5G channels was deliberately removed by AT&T several months ago for whatever reason.  If they'd have done that in a way that didn't disrupt my TV viewing, I probably wouldn't have noticed or cared.  I'm also seeing that the suggested way around this is to use a third party router, possibly with passthrough to the BGW.    If that's the only way to stabilize the 5G connection to the TV, then I'd be interested in what third party equipment to buy and maybe a link to how to set it up.  I'm a pretty simple user and I don't need a complex network setup.

None of my other devices connected to the 5G network (cell phones, laptops, etc.) seem to be bothered by this, although my Windows 10 PC sometimes connects to SSIDName 2 instead of SSIDName, where SSIDName is the name of my 5G network.  I have not defined a network named SSIDName 2.

Again, thanks for any help.

ATTHelp

Community Support

 • 

207.3K Messages

2 months ago

We're here to help get you connected, @FrogFan!

 

The 5GHz radio wave is made to deliver a higher speed but is only reliable for a short distance. Meanwhile, the 2.4GHz radio wave provides a slower speed, but gives you a consistent connection from a farther distance.

 

If your TV is connecting to whichever frequency it believes is best, this means that bandsteering may be enabled, and you would need to disable it to further troubleshoot. Bandsteering uses the AT&T Gateway to connect you to the best Wi-Fi frequency for you automatically. To disable it, simply follow these steps:

  1. Sign in to Smart Home Manager.
  2. Select My Wi-Fi.
  3. Choose Edit next to the name or password.
  4. Select X to clear existing info, then enter a new name or password. Make sure that both Wi-Fi names are different, otherwise bandsteering will remain enabled.
  5. Select Save.
  6. Reconnect your devices with the updated network info.

We also suggest using the Smart Home Manager's Network Health Check tool to see if there is anything occurring between your TV and the Gateway. It will automatically let you know if something is causing interference. You can also use the Channel Scan tool to let it search for the best channel for your connection, so that you no longer have to change it from the Gateway settings manually.

 

If you have definitely decided on getting a third party router to connect to your AT&T Gateway, we have some steps regarding setting it up that is available to you.


Let us know if this helps!


Donovan, AT&T Community Specialist

tonydi

ACE - Guru

 • 

9.5K Messages

2 months ago

@FrogFan   Please excuse ATTHelp Donovan.  🤦‍♂️

Not surprising that AT&T did that, or why.  I don't think any of the regular contributors here have a 320 so the change would have escaped our attention.

Pretty much any third party router will work and you set it up using IP Passthrough.  HERE is a great little write up on how to configure that.

As to which one to get, that really depends on a lot of factors like home size, layout, building materials, where you need wifi in relation to where the gateway is, budget, etc etc.  I usually recommend looking at current router reviews on trusted tech websites and find something that sounds like it might fit your needs.  If you have a larger home a wifi mesh system (essentially one router and then one or more satellites) might be a better choice.  Then get it from a source that has a good return policy if you end up making a bad choice.  😁

browndk26

ACE - Professor

 • 

4.9K Messages

2 months ago

The fact that the TV is the only device with a connection problem would point to the TV being the problem. Your TV may not have a 5g radio. As far as I know, the only 5g band you cannot access is the Backhaul channel for mesh. Scroll down the screen for another 5g band. 

FrogFan

Teacher

 • 

53 Messages

2 months ago

Thanks all for the comments.

@browndk26 The TV does have a 5G radio; it's been connected to the 5G network for months at a time.  As I tried to explain, when the BGW changes channels (I have no idea why it does that), it sometimes changes to a channel that is not recognized (recognizable?) by the TV.  I don't understand the detail, but my cell phones and laptops are not affected; they recognize whatever channel the BGW tunes to.  I suspect it has something to do with defense department or weather channel stuff on 5G, but again, I don't know.  Also, I can't change the channel myself; that option is not available.  All I can do is "scan for the best channel" and hope whatever the BGW chooses is recognized by my TV.  This problem has happened twice now in the last 6 months.

@ATTHelp You missed the entire point of my post.  When the BGW "automatically" changes channels, it sometimes changes to a channel my TV doesn't recognize.  In that case, the 5G network doesn't even show up on this list of available wifi networks.  It might be helpful if you could see if someone might consider changing the behavior of the router so it doesn't do that, or perhaps give us a choice to pick a channel and leave it alone.  As it stands, it seems like all I can do is fiddle around finding the best channel every time it changes it to something not recognized or buying another router and bypassing the BGW, as suggested by @tonydi .  The 2.4G band is very congested here and bandwidth suffers considerably as a result.  5G here does not have that problem and is perfect for use with my TV.

@tonydi Thanks for the help and the reference to passthrough instructions.  I'll dig into those and see if I can fix the problem.  My network requirements are quite simple.  I have a two story house and the BGW is on the ground floor in the middle of the house.  I have devices that connect to wifi on the ground floor, the second floor, and outside on the patio.  I don't have any problem with signal strength, so I'm thinking just a plain competent router that offers 2.4G and 5G radios would work.  One question:  I've seen around here that some users keep the BGW radio on and just plug an ethernet port on it into the WAN port of the third party router, in which case both routers are handing out DCHPs.  That sounds simple to me and makes me think that I could leave everything in my house alone except the TV, and change it's connection to the third party router and whatever SSID name I give it's network.  Does that make sense, or should I go "all the way" and use passthrough, thereby effectively turning the BGW "off" and then reconnecting all my devices to the new router?  I'm not very technically knowledgeable about this.  Also, I'm curious about why AT&T did this, especially since it effectively disrupts service to its customers.  Any insight might be helpful to me, although I understand if you'd rather not go there.  Thanks for any help.

browndk26

ACE - Professor

 • 

4.9K Messages

2 months ago

Are you sure you cannot change channels?

I have a bgw210. Advanced, 5g, channel, select automatic and I see multiple channels. Bgw320 should be similar. 

I do use a mesh Wi-Fi system in place of the 210. More so for more router features than the bgw210 but also better Wi-Fi in a 2 story house. 

(edited)

tonydi

ACE - Guru

 • 

9.5K Messages

2 months ago

Before I forget again, it's not uncommon for Windows machines to do that SSIDName 2 thing.  The 2 isn't part of the SSID name, it's just Windows saying "hey I found another network of the same so I'll call this one 2".  If it "finds" the same SSID yet again, you'll see SSIDName 3.  No idea why it thinks it's actually a new network. 

I did look around a bit online and some TCL Roku TVs do seem to fight back when connecting to 5GHz bands and not just with AT&T.

If you do IP Passthrough that's exactly how you'd connect it but you wouldn't hook anything else up to the BGW.  And in that mode it's generally suggested to disable the wifi on the gateway so as to avoid interference with the third party wifi. If you do that you can name the bands the same as they were on the BGW and avoid any config changes with the wifi devices.

If you can currently hit both floors and a patio with the BGW then I agree, a "regular" router should be more than enough.

No idea why AT&T did that but the cynic in me would probably want to guess that there were other issues and maybe disabling that capability covered up those issues.  😁 

Oh, abandon all hope of ever getting anyone you can talk to at AT&T to pass on any sort of suggestion for changes to equipment (or anything else for that matter). 

FrogFan

Teacher

 • 

53 Messages

2 months ago

I did a bit more research and had a couple follow ups.

First, @tonydi The link you provided is very helpful.  I think I can do it.  The piece I found missing is to how to physically connect the BGW to the third party device.  I'm assuming I plug an ethernet cable into one of the ethernet ports on the BGW and the other end to the WAN port on the third party router.  Is that correct?

Also, I have one device connected via ethernet to the BGW.  Do I need to connect it to the third party router after the passthrough or leave it alone?

Second, @browndk26 Evidently Roku players that support 5G do not support DFS channels ((UNII-2, UNII-2e bands [channels 52-144]).  The BGW appears not to have a problem choosing one of those channels, and that's why my Roku TV won't connect.

Thanks again for the help.

FrogFan

Teacher

 • 

53 Messages

2 months ago

@browndk26 Yes.  I'm absolutely sure I can't change the 5G channel.  My interface is different from yours.  It specifically does not allow for 5G channel selection.  Only "Automatic".

@tonydi Thanks again for the second round of help.  Note from my previous post that the problem with Roku is DFS channels.  It doesn't support them but the BGW chooses them sometimes.  That's why my TV won't connect

tonydi

ACE - Guru

 • 

9.5K Messages

2 months ago

Yes, that's exactly how you connect it.  I tend the discourage connecting wired devices to the AT&T gateway when using IP Passthrough because sometimes those are devices that one might want access to/from other network devices.  Some types of devices won't care, but others will just not be able to see "across" the networks.  So on my setup the only thing plugged into my BGW is my mesh wifi system.  Everything else is plugged into the mesh's router.

Interesting about the DFS channels, good sleuthing. 

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.