Let AT&T help you elebrate your dad with Father's Day Gifts that connect us.
What is happening with 3G?
dterry42's profile

New Member

 • 

17 Messages

Saturday, September 9th, 2023 3:26 AM

Will AT&T Cell Boosters solve issues with SMS/MMS messaging not solved with Wifi-C

Would the AT&T Cell Booster Pro (femtocell) device provide a solution for the following scenario using an iPhone 14 Pro over the AT&T network:

  1. Weak to no AT&T cell signal (1 bar at approx. -110 to -120 dBm)
  2. Strong AT&T fiber 1Gb internet connection and 300-500Mb Wi-Fi distributed over house
  3. WiFi-Calling enabled with *reasonable* success calling/receiving voice calls
  4. Apple iMessages of all types sent and received normally
  5. PROBLEM: ALL SMS/MMS messages (non-iMessage) carrying any sufficient load (1 pic, 1 gif or more than 1 pic) will send EXTREMELY slowly (long delay with green bar) or FAIL.  However, same MMS message sent from iPhone when in range of a slightly stronger AT&T signal 2+ bars will send virtually immediately.

Current use of strong WiFi-C in home does not seem to solve the issue of the very low cell signal under this SMS/MMS use case.  Would the AT&T Cell Booster provide some workaround that better handles or solves this issue to where it acts like it has a reasonable cellular network connection?
-OR-
Would this provide no other benefit over Wifi-C and simply a stronger, direct cell signal is required using other possible alternate solutions with cell boosters and antennas directed at the AT&T towers? 

Accepted Solution

ACE - Expert

 • 

24.7K Messages

9 months ago

The Cell Booster will probably not correct the issue as it is probably related to either your iPhone settings (model of phoned iOS?) or an account configuration on AT&T's end. 

I tested the Cell Booster for AT&T for quite some time, and still have one that I use on occasion to keep my Cell Booster account active and to get any updates if available. Other than that, we use WiFi-C exclusively on our iPhones (7, 8, 12, XS, etc) and have no issues sending/receiving MMS/SMS messages from our Android friends. iMessage goes thru Apple's servers exclusively, not AT&T's so there's no issue there. I just use iMessage for everything and whether it's another Apple user or an Android user it just works. I did not see any difference between the Cell Booster and WiFi-C with regards to iMessages or SMS/MMS to our Android friends.

You need to leave WiFi enabled as well as WiFi-C and make sure that iMessage is setup correctly for SMS/MMS. You might also want to try Reset Network Settings but keep your network info on hand in case you need to re-enter any of that. If your phone is 5G capable, you might want to try and set it to LTE only. WiFi Assist should also be disabled.

ACE - Sage

 • 

118.1K Messages

9 months ago

I have to agree with OttoPylot.

Even in areas where the signal is very poor and I'm getting a DBM of -120 I can still send and receive a text over cellular, but never a problem sending or receiving over Wi-Fi call/text when available

I'm not sure why random people are having problems with Wi-Fi texting. And why this particular complaint is with an iPhone. Usually the complaint I see is Android users complain they cannot text over Wi-Fi. 

I've never had a problem on Samsung or Google phones.

Android devices on AT&t use advanced messaging, which uses data, not SMS.   So just like iMessage, there should be no problem sending and receiving over a Wi-Fi connection.  

I know there is a setting an iPhones to send and receive via phone number. This is important between iPhone and Android. Perhaps this is the setting that is incorrect?  

New Member

 • 

17 Messages

9 months ago

Thank you both @OttoPylot and @formerlyknownas so much for your quick feedback!  I also have come to believe that this is likely an AT&T network configuration handling issue.  This is such a weird issue, but I have found that many others have encountered this same problem.  I’ll clarify my details further based on your input also if helpful and for future reference. And I’ll tell you below what I’ll try next.

  1. Yes, I am using an Apple iPhone 14 Pro (had same issue with iPhone 12 Pro – issue has persisted for over 2 years on all iOS versions)
  2. Always running the latest version of iOS (currently 16.6.1)
  3. Yes, I always use iMessage for messaging all contacts  
  4. Yes, my AT&T 1Gb internet+wifi is always enabled and I have the iPhone’s Wifi Calling turned on at all times
  5. Under iMessage Settings, both MMS Messaging and Group Messaging are always on.  (a separate iPhone setting for iMessage is “Send as SMS” is also always on which “Sends as SMS when iMessage is unavailable”.  This however I would presume would only apply to Apple network iMessages anyway and would not affect non-iMessage SMS/MMS texts to Androids, etc. I can try turning this off also if you think it has any bearing.
  6. I have tried multiple Reset Network settings with no improvement

THE PROBLEM (with greater detail): iMessages to other iPhone users over Apple networks always works consistently well.  The issue is only encountered for me when using iMessage to non-iPhone users of course (SMS/MMS).  Further, if it is a simple “text only” message (light load), this works generally fine and unnoticeably different.  This will always succeed for me.  However, if the message contains even 1 large photo or gif attached to the message (larger load) to a single non-iPhone user or one non-iPhone included in a group text with iPhone users, the message is sent MMS of course (outside of Apple network) and the issues begin and is very perceptible.  The message is extremely slow to send (you can watch the green bar slowly move across the screen in iMessage while it attempts, often getting "hung" near the end).  I can usually get a message to send with a standard, large photo after about 30-60 seconds (irritating as others may have already responded, but eventually works).  If more than one photo is attached, video or larger gif, the message will generally time out and fail to all participants – have to break everything up to be able to send.  Same message with multiple images sent while away from house under better AT&T connectivity and the message sends instantly.  For some reason, these specific messages (MMS) using iMessage on iPhones do not seem to accept sending on the AT&T network over the very solid 1Gb internet connection that is available and it reverts to trying to use the 1 bar cell signal is all that I can guess.  I would love to know if you can send an iMessage from an iPhone to an Android contact with a large photo or two attached under these conditions.

Thanks again @OttoPylot, you had two other suggestions:

  1. Disable 5G:  My iPhone is set on 5G Auto for “Voice & Data”.  It will use 5G where available and switch to LTE at times when only that is available.  It would be a bummer to have to eliminate 5G and switch the phone setting to simply LTE, but I will try this.  I actually think I have attempted this with prior testing, but I am reminded by you now to try it again to see if the AT&T network will respond any better if I limit my phone to Only LTE at all times.
  2. Disable Wi-Fi Assist: Yes, Wi-Fi Assist on iPhones is enabled by default, but I have long been aware of this “possible” solution and have had Wi-Fi Assist turned off with no improvement.  Maybe I should try it back ON again.

Not sure what else to try and my suspicion, as you have also noted, is that the AT&T Cell Booster is unlikely to improve this at all.  Let me know if I have missed anything.

Currently, I just have to drive away from the house about a mile to get a better signal and then I can send large messages using iMessage to non-iPhone users (much like they did back on Green Acres).
Thank you again.

(edited)

ACE - Expert

 • 

24.7K Messages

9 months ago

@dterry42  My iPhone is 5G capable but I just leave it on LTE all of the time because 5G in our area in just to variable to be worth it to me. My iPhone 12 is setup like this:

Wi-Fi Calling is On and Wi-Fi is enabled. At home, my phone has the AT&T Wi-Fi alpha tag to indicate WiFi-C

Cellular Data Options -> Roaming Off -> Voice & Data -> LTE, Allow More Data on 5G

Settings -> Messages -> Sends as SMS and MMS Messaging both enabled

iOS 16.6.1 and Carrier 54.0.1

Internet speed is really a non-factor but WiFi reliability is. I use a Mesh WiFi 6 system (router and two hard wired satellites). Speeds, coverage, and reliability is excellent.

We had a similar issue a few years ago when we upgrade to a 5G plan. AT&T installed new SIMs (for free) and I even Reset Network Settings but that didn't work. I contacted the Office of the President and a Senior Manager with one of his team members were able to isolate and fix a corrupted account setting on the back end. That corrected the issue on our phones and our kids phones who were on our Family Plan at the time. Do you have any issues with receiving 2FA text messages as well?

New Member

 • 

17 Messages

9 months ago

Thanks again @OttoPylot , I definitely have some specific thoughts, comments and a question on your additional details above for me.  Unfortunately "College Football Saturday" has me tied up right now, but I look forward to digging into this and getting back to you likely tomorrow.  Have a great day!

ACE - Expert

 • 

24.7K Messages

9 months ago

@dterry42  You're welcome. There's always an ACE around to answer your questions and help where we can.

New Member

 • 

17 Messages

9 months ago

@OttoPylot  Yes, it looks like we have the exact same configuration on our iPhones for these few settings and also display the AT&T Wi-Fi alpha tag (with the 1 exception of LTE v 5G Auto which I will test again).  If you also have only 1 bar or less of AT&T cellular signal and use a strong internet connection with Wifi-C to transmit iMessage text messages with large images to non-iPhone users (MMS) and it sends normally as if you are on a strong cell signal, then something else is certainly different.  Since it is not entirely unique to me however and I have found many on forums describing this same frustrating issue, I continue to try to narrow toward a solution.  

Thanks for also describing and pointing out the specifics of your own internet/wifi network as this is of course another variable in the chain.  If I would have done a better job initially, I would have listed mine as well.  Like you however, I also have a very strong internet deployment using commercial-grade Araknis router/switches and 5 separate access points distributing the AT&T fiber 1Gb service (typically measuring 900mb+ ethernet and 200-500Mb wifi on devices throughout).  Now, that being said, I have also been curious if there is some “common” router configuration or something that others of us share which “confuses” or limits our ability to properly handle the above communications.  As an example, I had found some time ago that Araknis routers have “IPSec Passthrough” disabled by default on the router and needs to be enabled to better handle WiFi Calling.  This of course I have done, but I am no network engineer, and just curious if there might be other nuanced settings that many of us share that could be reconfigured as an issue to this narrow, but crippling problem.

OR, are there still other common Apple settings that are not working well with the AT& network?  As an example, some time ago Apple introduced the “Private Wi-Fi Address” feature which is also defaulted On.  Could this be adversely affecting the communications between our devices/networks and the AT&T networks in some way that it adversely affects this send/receive and we should be disabling this feature for our own internal networks?  Other??

Thanks for also pointing out the 2FA issue – you have a great memory.  Yes, I ran into this issue also when switching from the iPhone 12 Pro to the new iPhone 14 Pro device (new eSim).  I encountered this right away and had to contact AT&T Support to have them correct “something” on their “backend” which then resolved this issue also.  This other MMS issue though described above was ongoing prior to this device and has persisted again with the new device without regard to the separate 2FA issue apparently.

So, I guess where I am left is that if you and others have tested and confirmed that the AT&T network does in fact reliably process large MMS messages (more than just text) from iMessage over a strong WiFi-C connection where there is simultaneously a non-zero, but extremely minimal (1 bar-ish) cellular connection, then my guess is that there are only 3 locations for the variable problem:
1) A user’s own internal internet router configuration settings that may be causing a conflict
2) The user’s Apple iPhone settings for which we have narrowed/eliminated most if not all
3) The A&T Network’s handling of these messages under these same settings as above

@OttoPylot   You are far more expert on all of this than me however, so please le me know if I have this incorrect or if any of this has led you to think of another specific place that I could be checking and testing for those of us that have this issue.  Thanks again for all of your time and consideration.

P.S.  I am happy to throw any amount of money at this also if I could simply solve the problem, but it just doesn’t seem like Cell Booster technology (those taking moderate signals from outdoors and casting them stronger indoors would serve any purpose for me as my *outdoor* signal strength is the problem, not just indoor) and the AT&T Cell Booster which is really femtocell and seems better described as an alternate WiFi-C solution doesn’t seem to provide me with anything greater than what I already have under my current WiFi-Calling configuration over my A&T 1Gb fiber.  Hmmmm….  Open to any and all suggestions.

ACE - Expert

 • 

24.7K Messages

9 months ago

I've always found the more simple your internet setup is, the more likely you are to not have issues. Mine is simple. Xfinity cable (800/20) comes into the house and connects to a Motorola DOCSIS 3.1 modem. The modem is then connected to a Netgear AX4200 Mesh WiFi router. The upstairs satellites are hard wired back to the router with solid copper core (non-CCA/CCS) CAT-6 cable. Typical speeds to the router are a consistent 920/25 and to the WiFi 6 capable devices, 697/28 typically. Coverage and speed is consistent throughout our 3500 sq.ft home on a 1/2 acre. 

Is your AT&T gateway set to pass through mode if you are using the Araknis router to handle all of the router and WiFi duties. Switches may be an issue and are your access points (satellites) hard wired?

Cellular boosters work well if your outside signal strength is at least a consistent 1, and preferably 2 bars of signal strength. I'd also recommend getting a professional installation if you want to go that route. They have the equipment to identify signal bands, frequencies, strength, and direction. They can then recommend which of their products would serve you best. There's an outdoor antenna as well as an indoor antenna (or two depending on coverage). 

AT&T's Cellular Booster (femtocell) does work well for a lot of folks but it's not without its issues. I only bring mine out of the closet every few months for a couple of weeks to keep my account active and to receive any updates that may be available. After that, it goes back in the closet and I re-enable WiFi-C. That being said, AT&T's WiFi-C uses two of the same four ports that the Cell Booster uses so if there are any issues with those ports, that may affect the reliability of either connection technology. However, the ports required (listed in my Tech Guide) are fairly common so it's doubtful that they would be blocked. You just need to make sure that the other router requirements are being met. A 1Gb fiber connection means nothing. For the Cell Booster all you need is a consistent 5Mbps down for the Cell Booster and 25Mbps down for the Cell Booster Pro as well as a strong WiFi signal. For WiFi-C you just need a strong and consistent WiFi signal. Keep in mind that the Cell Booster is LTE only so you need to keep your phone on LTE at all times.

Have you installed a new SIM and Reset Network Settings?

New Member

 • 

17 Messages

9 months ago

Yes, same – all 5 access points are connected CAT6 back to network rack.  Not certain of the specific AT&T gateway settings along with Araknis router as this was installed by AT&T and my home network AV company.  While testing right now, Speedtest from iPhone Wifi is showing 451Mb down/505 Mb up.

Yes, have also performed Reset Network Settings previously without success. 

Will continue to look at other unique variables such as Apple’s “Private Wi-Fi Address” feature, etc. that might be throwing our own networks into performance limbo periodically or having issues “playing well” with the AT&T network.  Not sure.

Since you have already expertly answered the primary question of this post that the AT&T Cell Booster devices would not likely provide a solution to this issue, we can close this down and I’ll go back to other threads that focus on this lingering issue to see if others have found any further clues.

ACE - Expert

 • 

24.7K Messages

9 months ago

Ok. If you have any other questions that I may be of help, just post back to the Cell Booster forum or the Community Forum in general. One last thing, I don't think Apple's Private Wi-Fi address has anything to do with it. We use them on all of our Apple devices without any decrease in performance. I would look at how the AT&T Gateway is setup (WiFi thru them leaves a lot to be desired) or how your home network AV company setup your network/router. My feeling is that's where the issue lies.

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.