Available Now: Buy the new iPhone 14, iPhone 14 Pro and iPhone 14 Pro Max from AT&T!
What is happening with 3G?
microtrauma's profile

Teacher

 • 

11 Messages

Fri, Sep 26, 2014 6:39 AM

MicroCell TroubleShooting Questions and TP-Link TL-ER6120 Dual WAN VPN Router not compatible?

OttoPylot, an Ace Master troubleshooter (and not an ATT employee) has kindly put together a list of things to check when your MicroCell does not / will not work.


This is copied from a somewhat extensive troubleshooting session that I dived into the end of and thought it would be easier to start a brand new post with his list and then my answers.  (Otherwise, if you are looking for answers like this, it would be at the bottom of a long discussion)

 

As with all electronics, there are quirkiness issues that can create immense frustration, so take a deep breath and be thankful there are people like OttoPylot and Avedis53 who are willing to take their time to try and help troubleshoot these things.

Here is the question list (put together from their experiences with helping out others)
 
Edited by OttoPylot on Sep 25, 2014 at 6:26:46 PM


MicroCell TroubleShooting Questions:

  1.     Do you have an active postpaid AT&T mobile account?
  2.     Do you have a combined modem/router or a separate modem and router?
  3.     What are the model numbers?
  4.     Have you met the minimum requirements for router configuration as outlined in the Tech Guide?
  5.     What are your download and upload speeds?
  6.     What kind of internet service do you have (ADSL, cable, WiFi)?
  7.     Are you using the basic connection (modem -> router -> MicroCell) or the alternate connection (modem -> MicroCell -> router)?
  8.     What other equipment (computers, WiFi TV’s, Xboxes, Playstations, etc.) do you have connected to your network?
  9.     What does the light pattern look like on the MicroCell (power, ethernet, GPS, and 3G)? Are they all a solid green or is any of them blinking green or red, and if so, which one?
  10.     Does the ac adapter feel warmer than the top of the MicroCell where the vents are?
  11.     Are all of the cables firmly in place?
  12.     Have you checked your line speed (http://www.speedtest.net/)? If so, please post results.
  13.     Have you checked to see if you line is adequate for VoIP (http://www.voipqualitytest.com/)? If so, please post your results.
  14.     Have you checked the Tech Guide?


And here are my answers, and although I'm no guru, my gut is telling me this TP-Link TL-ER6120 is likely over-managing the DMZ zone and can't be easily made to work with a MicroCell. 

 

I'm looking at other dual WAN routers such as a Peplink Balance 20 Dual-WAN in hopes it may work.

 

Do you have an active postpaid AT&T mobile account?

Yes, 3 in the house, plus friends who stay over have had on / off access via MicroCell

Do you have a combined modem/router or a separate modem and router?

DSL Modem and separate firewall/router.

I've tried Internet->DSL Modem->Router->MicroCell, and it currently is either flaky or does not work.

Direct? (DSL modem -> MicroCell) connects every time, super fast, in typically under 10 minutes. Everything works on the MicroCell when placed in direct mode.  Trouble is, all my LAN wiring (10+ cables) are at the far end of the house and since it's brick, I need the MicroCell in the middle of the house so everyone gets great reception.  I did try the MicroCell centrally in the attic, it could not get a GPS lock, even after 48 hours of trying.

What are the model numbers?
DSL Modem, Siemens SpeedStream 4100
Old firewall/router: Linksys BEFSX41 Firmware Version: 1.52.15 Deactivated because it is flakey. Keeps locking up on the rest of the SOHO LAN and was flakey but occasionally worked with MicroCell when I placed the MicroCell in a static IP mode and put that static IP into the DMZ.

New firewall/router: TP-Link TL-ER6120 Dual Wan Router SafeStream latest version, 1.6  just purchased in the last week to resolve flakey Linksys Firewall/Router

 

Have you met the minimum requirements for router configuration as outlined in the Tech Guide?
-DHCP is on (also tried both limiting IPs to one and reserved / static IP in DMZ)
-Port Blocking is either turned off or allowing ports 4500 and 500 (Tried forwarding and tried putting separate limited or static IP into DMZ)
-MTU size is set to 1492
-MAC address filtering is either turned off or allowing the MAC address of the AT&T 3G MicroCell (With the MicroCell in the DMZ, MAC filtering is normally not an option)
-IPSec Pass-Through is Enabled  (With the MicroCell in the DMZ, IPSec Pass-Through should be on, but who knows in these more complicated routers)
-Block Fragmented Packets is Disabled (Cannot uncheck this option in the TL-ER6120, it is grayed out, but this theoretically should not occur with the MicroCell IP set in the DMZ)
-If using multiple routers, the 3G MicoCell must be connected to the first router connected to the broadband modem
-If the 3G MicroCell is connected to a router that is connected to a modem and both the router and the modem have NAT (Network Address Translation) enabled, disable NAT either in the router or the modem.

TCP/UDP Ports
NOTE: All ports listed need to be configured for inbound and outbound connections.

(Tried port forwarding bidirectional via LAN settings and even tried when the MicroCell was in the DMZ.)
-123/UDP: NTP timing (NTP traffic)  
-443/TCP: Https over TLS/SSL for provisioning and management traffic
-4500/UDP: IPSec NAT Traversal (for all signaling, data, voice traffic)
-500/UDP: IPSec Phase 1 prior to NAT detection (after NAT detection, 4500/UDP is used)
-4500/UDP: After NAT detection, 4500/UDP is used


What are your download and upload speeds? As advertised? 6016 Kbps (downstream) 768 Kbps (upstream)
What kind of internet service do you have (ADSL, cable, WiFi)? ADSL
Are you using the basic connection (modem -> router -> MicroCell) or the alternate connection (modem -> MicroCell -> router)?  
Could not get the "basic" connection to work at all with the TP-Link router--it was flaky with the Linksys, but the Linksys was flaky just as a firewall. Going direct, modem -> MicroCell works consistently and perfectly.
What other equipment (computers, WiFi TV’s, Xboxes, Playstations, etc.) do you have connected to your network?
The following are connected to the firewall/router when not testing MicroCell directly:
Airport Extreme 802.11n 4th generation connected via Cat5 to firewall/router, set in bridge mode
Airport Express 802.11n 1st generation connected to Airport Extreme via Cat5, also in bridge mode
NetGear Gigabit unmanaged switch connected via Cat5 to the following devices:
- Apple TV 1st generation connected via Cat5
- 2 macs on Cat5
- Brother all-in-one printer on Cat5
- 2 Windows XP boxes connected on Cat5, but are mostly off
- 3 additional Cat5 cables for working with various other laptops / computers but are not used when testing network

Apple WiFi
- 3 mac laptops connected on WiFi, off and on depending on who is here
- 3 iPhones connected off and on to WiFi
- 1 Android, rarely connected to WiFi
- Various mobile phones / laptops of friends connected to WiFi when they are here

What does the light pattern look like on the MicroCell (power, ethernet, GPS, and 3G)?
With  modem -> router -> MicroCell?  Green power, ethernet, GPS, and slow blinking green 3G light
With DSL Modem->MicroCell? All solid green and all iPhones work. (Friends non-iPhones have worked also)
Are they all a solid green or is any of them blinking green or red, and if so, which one?

With DSL Modem->MicroCell, all solid green and all phones work
Does the ac adapter feel warmer than the top of the MicroCell where the vents are? No
Are all of the cables firmly in place? Yes
Have you checked your line speed (http://www.speedtest.net/)? Yes
If so, please post results. Average download runs 1.5 - 5 Mb/s and upload is a more consistent .58-.60 Mb/s
Have you checked to see if you line is adequate for VoIP (http://www.voipqualitytest.com/)? If so, please post your results.  
Tried. I've got all computer systems set so tight, nothing would run the java script the website is looking for, but using just DSL modem -> MicroCell, the MicroCell VOIP works consistently.  More importantly, text from phones other than iPhones works also.

TP-Link has reporting capability.  When I put the MicroCell into the DMZ, I see consistent upload packets but zero download packets.
Hence, the reason for my previous questions regarding known working routers and settings. 

I believe that with a reasonable router which does the proper "no manage" thing in the DMZ zone, the MicroCell will work perfectly in "basic" mode because it worked previously.

 

The challenge is finding the right dual WAN SOHO firewall/router and getting the firewall/router settings correct.

 

Suggestions?

 

Thanks!

Accepted Solution

Official Solution

Teacher

 • 

11 Messages

8年前

Gentlemen,

My sincere apologies for not responding more quickly to your rapid and extensive trouble shooting comments. Between finishing our taxes, which were on extension, and a few other issues, resolving this ending up taking an extended back seat.

Thanks to both of you for your extraordinary efforts regarding these MicroCell questions.

With your various suggestions and recommendations, I finally resolved both the MicroCell problems and a consistent ATT bandwidth challenge I had.

It turns out that the Siemens SpeedStream 4100 was one sent by SBC in a "SBC Starter Kit".  It's not a true 4100, but is closer to a 5100B.  I thought that this line from another forum, "It is closer to a bridge than a NAT router (though bridges don't do NAT)", would mean that this modem would work consistently with a MicroCell. In the end, between the SBC / Siemens ADSL modem and the LinkSys BEFSX41, I could never get them to work consistently, even after hours and hours of trying various things. Perhaps it was a double NAT that Avedis53 mentioned.  I never did find a way to turn that off in the SBC bundled version of the Speedstream 4100.

For others using this modem, for more specific comments on issues related to the SBC Siemens SpeedStream 4100, check out these two URLs.
http://www.dslreports.com/forum/remark,15607820
http://zumaz.com/speedstream_5100B.html

I did try going with the "private" mode on the SpeedStream as Zumaz.com suggested, which did help, but I still had to do a crazy thing every couple of days to keep the MicroCell working. After a few days, the MicroCell would loose the bottom link light and start blinking.  To resolve it, I would unplug the direct ethernet cable from the LinkSys/MicroCell and replug the MicroCell Ethernet cable directly into the SpeedStream modem, wait until I got solid greens on all lights on the MicroCell, then very quickly switch the ethernet cable back into the LinkSys BEFSX41 DMZ connection.  It would work for a few more days, and then loose the connection again.

So, I purchased a TP-Link TD-8616 ADSL modem that would ONLY do bridging. (I know, after a terrible experience with zero support from TD-Link, why buy anything from them again?  Amazon reviews covered the "how-to" and very few other modems are simple bridge only ADSL modems)

I also purchased a PepLink Balance 20 router based on Amazon reviews and PepLink forums.

On Friday, after plugging everything in, the MicroCell came up almost immediately!  And, everything has worked 100% with no downtime. AWESOME! (fyi, the PepLink luckily has a WAN PPPoE user/password area for use on the dual WAN or the TP-Link modem would have never worked.)

One of the things I did test, based on OttoPylot's statements about the sensitivity of phone lines in a house, was to pull my home phone connection and go outside and connect directly and exclusively to ATT.  My speedtests outside actually were lower across the board, but I believe that it was more about the 15 minutes it took for me to reconnect everything outside and test, then it being a case of a slow down related to wiring.  

Why slower outside?  I did the Speedtests on inside wiring right around 3:30pm and I believe that by the time I did the outside exclusive tests, local students had all gotten home from school and were sucking bandwidth from the oversubscribed ATT line.  Given this slowdown happens consistently Monday through Friday around 3:45pm to 4:00pm and lasts until around 10:00pm, I think it's a logical conclusion.

One very cool additional feature on the PepLink Balance 20 is that it will bind a USB wireless modem connection.  I've got a rooted Samsung Galaxy GS4 phone and initially tried various tethering apps, including PDANet+FoxFi (which work perfectly for WiFi tethering for me) and could never get the Peplink to connect.  I was told via the forums that only carrier authorized tethering / approved USB WiFi modems worked.  I assumed there was some type of hack, but as an amateur, I was concerned I would screwup using a terminal app to hack the settings in the phone, so after much searching, I finally found a brief comment in an Android root article and it worked!

Previously, I installed an app called the Xposed Installer framework so I could use another app called XPrivacy to dramatically increase/improve Android privacy settings.  There was an add-on I was not aware of called Wanam Xposed designed for the GS4.  Once I installed Wanam Xposed, I just went to to system and clicked Disable Tether Provisioning.  Then I simply rebooted and everything worked!

Now I have a DSL line with a router capable of bonding a USB tethered cell phone whenever I want. This means we can now live stream HD movies---historically it has been impossible at this location.  In addition, even when the DSL line is oversubscribed (I've seen 33.3 kb old school modem speeds), we now have backup bandwidth to resolve the problem.

So, everything is working completely well and with great speed! I've seen over 16 mb/s down, 3.5 mb/s up on speedtest.  

Communication and equipment:

Connections:
ATT DSL line 6016 kbps down  / 768 kbps up
Cellular LTE 10 plus megs down / 3 plus megs up via USB tethering

Equipment:
TP-Link TD-8616 bridged ADSL modem (no PPPoE authentication option, only bridging to a router)
PepLink Balance 20 router
ATT MicroCell (Supporting an iPhone 5s and two iPhone 5 phones along with various friends and relatives who need ATT when they stay over)

All connected to Apple AirPort Wifi and a NetGear Gigabit unmanaged switch with all working beautifully together.

Many, many thanks, OttoPylot and Avedis53. I don't believe I would have arrived at this splendid resolution without your direction and guidance.


Another ATT MicroCell customer's problems resolved by OttoPylot and Avedis53  Man Very Happy

OttoPylot

ACE - Expert

 • 

18.8K Messages

8年前

Ok, just a couple of things off the top of my head.

 

The alternate connection works just fine, modem -> MicroCell, so the MicroCell is not the problem.

 

It appears then that one, your speeds are questionable if your put the MicroCell behind the router and two, some of the router settings may be affecting initialization.

 

Advertised speeds are 6.0Mbps/.78Mbps.

 

 

Actual speeds via SpeedTest are 1.5Mbps - 5.0Mbps or an average of 3.3Mbps.

 

AT&T says that 1.5Mbps is the minimum but I think in reality that should be 3.0Mbps. Your average speeds meet that but with the apparent fluctuation, and the number of devices you have on your network, a stable VPN to AT&T's Mobility servers can't be established or maintained.

 

Line quality may be an issue. I have ADSL+ and I know that the lines need to be really clean with tight connections (no corrosion, taps,etc). I tapped into the DMARC at the MPOE and ran a single, shieled two-wire line to my computer room and connected it to it's own RJ-11 jack. Nothing else is connnected to that line. That way I know for sure that my "internal" wiring is perfect from the phone jack to the phone box. The rest is the responsibility of my ISP. The DSL filtering is done at the phone box between the pre-installed house lines and the Test jack of the phone box.

 

Your MicroCell location is a difficult one because of the house construction. I'd have to think about that (Avedis53 may have a thought on that one).

 

Port forwarding may help but it sounds like you're having difficulty in setting that up. I just set my to forward the necessary ports and protocols for public and private. Don't know about bi-directional use I just assumed that's what it did to communicate back and forth. I did permanently assign the first available ip address in my DHCP table to the MicroCell based on its MAC address and I've limited the number of addresses that can be assigned to 10 because that's all I need or want to have available.

 

Block fragmented packets may also be an issue if you can disable that.

 

So, what to do?

 

MicroCell works as designed based on the alternate connection so that can be ruled out.

 

Network setup and MicroCell location. That's the problem area. The MicroCell will need as direct of a connection as possible to the router (single line, so switches or hops). The router's settings need to be confirmed and set properly to meet minimum requirement, or you need to maybe place a single switch so that the MicroCell can use the alternate connection.

 

Line quailty needs to be checked and fixed/repaired if possible (either your internal wiring or the ISP).

 

The problem seems to be line quality, the router settings, and/or the MicroCell location.

Avedis53

Professor

 • 

2.2K Messages

8年前

I don't see this discussed in your posts but I'm curious if you have tried this connection method (Modem > Router > Mcell) with the rest of your network disconnected?  This would eliminate something in the rest of your network as a potential cause of your problem and point towards the TP-Link router if you still can't connect.

 

I'm also curious as to why you would need the TP-Link TL-ER6120 in the first place.  Do you need 100 IPSec VPN tunnel capability for your home network?  Why dual WAN?  Do you have two ISPs?  I don't understand your need for a router that is unnecessarily more complex than you require.

 

Your subscribed bandwidth is marginal at best given the requirements of the Mcell and the other connected equipment.  Is this causing your problem?  Hard to say but a half dozen computers, 4 smartphones, and streaming TV on a DSL connection running 1.5 Mbps/0.6 Mbps has got to present problems at times.

 

VOIP line quality is an unknown and could be a problem given the low subscribed bandwidth available.

 

However, when I research the SIEMENS SpeedStream 4100 Ethernet ADSL Modem online and look at the user manual, it appears to me that this is a gateway....modem and router combined.  Please verify this as this may be the cause of your problem.  If this is the case, then you most likely have a double NAT conflict between the 4100 and the TP-Link, which the Mcell will not like.  You will need to disable NAT in the 4100 and leave the NAT duties to your router....or perhaps put the 4100 in bridge mode since that is not the default setting.

OttoPylot

ACE - Expert

 • 

18.8K Messages

8年前

Thank you for your rather extensive report. You do have a slightly more complicated setup than most but we're glad to hear that even elaborate systems can work with the MicroCell. It's unfortunate that you had to go thru all of that but at least it all works now to your satisfaction.

Avedis53

Professor

 • 

2.2K Messages

8年前

I have to admire your determination in working through your problem.  Most people would have thrown in the towel given the complexity of your home network.

 

I had a suspicion that your original modem/router combination was the cause of your Mcell problem and fortunately you had the resources to go out and replace the offending hardware to resolve it.  Based on my observations of posts in this forum, there are routers, gateways and even modems that simply won't work well with the Mcell for whatever reason.  What makes troubleshooting them so difficult is the fact that there are so many them out there and they are changing in design on a routine basis.  Keeping a list of offending hardware here is pointless because it is a moving target.

 

Glad to hear that you finally have a working Mcell and we hope your problems are solved on a permanent basis.

 

 

Need help?
Fix, replace or check device delivery
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.