Find the perfect gift for the grad in your life with Graduation gifts that connects us from AT&T.
What is happening with 3G?
Graylane's profile

Teacher

 • 

12 Messages

Monday, September 22nd, 2014 6:46 PM

MicroCell Connection NIGHTMARE

THIS IS NOT A HARDWARE PROBLEM OF ANY KIND e.g. cables, ports, etc. It is most surely the settings in my D-Link DGL-4100, or something in the firmware. If anyone has this configuration, please let me know.

 

 

I have a new DPH-154.

It has connected and activated when connected directly to my Motorola Surfboard SB6141 (Modem) and works fine.

 

I CANNOT leave it this way for obvious reasons.

 

When connected to my D-Link DGL-4100 it refuses to make a connection. Power light/Solid, Ethernet light/erratic blinking (like the data light on a router or Modem). GPS light/NOTHING  Network light/NOTHING.

 

I have played with nearly everything in my Router settings that I can think of. Forwarded 123, 500, 4500 UDP and 443 TCP. shut off SPI, deselected IPSEC/VPN-(ALG) given the Microcell a static IP 192.168.0.68, deactivated MAC filtering, set the MTU to 1492, checked the CAT 6 cable and the Router port. I even put the Microcell IP on DMZ.

 

BUT STILL NOTHING

 

I'm pulling my hair out. when I call AT&T, I get some robot that wants me to Cycle the MC and go through all of the idiotic items on the menu she/he is reading. right down to restarting my Desk top computer, as if that has something to do with it.

 

PLEASE, Help

ACE - Expert

 • 

24.5K Messages

10 years ago

I've been evaluating the DPH-154 for some time now and have not had any of the issues you describe. I have it connected directly to my Apple Extreme Base Station router, as it should be.

 

If you can connect directly to your modem (alternate connection), and the MicroCell works as you expect it to, then there is nothing wrong with the MicroCell or your ISP.

 

The problem appears to be in the D-Link settings somewhere. The MicroCell is a relatively dumb device in that all it needs is to create a secure VPN back to the AT&T Mobility servers.

 

The requirments to do so are:

 

 

Ports 123 UDP, 443 TCP, 500 UDP, and 4500 UDP to be open.

IPSec Passthrough enabled.

Block Fragmented Packets disabled.

DHCP enabled

MTU 1492.

Only one device performig NAT duties.

Port forwarding to a static IP address tied to the MAC address of the MicroCell also gives it better reliability in a lot of cases.

 

You mentioned that the ethernet light on the MicroCell starts to blink when connected to the D-Link. That indicates that there is no ethernet connection. The fact that the MicroCell works when in the alternate connection again points to the D-link as the problem. No ethernet, no MicroCell.

 

I would try to connect a different device into the same ethernet port on the D-link and see if that connection works. If it does, then I'd go back to the settings on the D-link and see why it isn't seeing the MicroCell.

 

It appears that the D-link uses some form of SIP ALG (IPSEC/VPN-(ALG)). This is becoming more common in some routers. ALG is used to try and avoid configuring static NAT on a router and a lot of routers come with this enabled by default. The MicroCell doesn't use SIP protocols so in theory there shouldn't be any interference. But the problem is a lot of routers have this configured so poorly that it can affect MicroCell traffic even though in theory, it shouldn't. I'm not saying this is the problem but the issue is clearly something in the way the router is configured.

 

Unfortunately, AT&T is not responsible for router configurations or setups because of obvious liability and the sheer number of different routers and LAN configurations.

 

Your desktop computer was an interesting suggestion because it's not connected at all to the MicroCell and you are right, it has nothing to do with the MicroCell, unless you need to have your D-link configured a specific way for your computer which may not be compatible with AT&T VoIP services.

 

If  you can verify that the above mentioned router configs are met, I'd try a hard reset on the MicroCell and see what happens. Turn off the power to the MicroCell, push a paperclip into the reset hole on the back and then restore power while holding in the paperclip for about 30 seconds longer. That resets the MicroCell back to factory defaults and forces the MicroCell to gl thru the Initial Activation sequence again (see my Tech Guide, link in my sig, for details).

 

If that still doesn't work, and you are still able to get a reliable, solid connection using the alternate method, then it's the D-link and a setting somewhere.

Professor

 • 

2.2K Messages

10 years ago

What do you mean by "checked the Cat 6 cable and router port"?  Do you mean you tried another Ethernet cable and got the same result?  Have you tried connecting to a different router port? 

 

Sounds to me like your connection is bad given that the Ethernet light is flashing.  Either your Ethernet cable is bad or your router port is bad.  Do you have any other equipment connected to your router by Ethernet cable?  Have you swapped ports?

 

No sense messing with router settings until you sort out the connection problem, unless you have shut off ports.

ACE - Expert

 • 

24.5K Messages

10 years ago

Doh! I missed the CAT-6 part. In either case yeah, verify that the router ethernet port works with another device, minus the CAT-6 before doing anything else. This is more than likely a setup/device issue because the MicroCell/ISP connection works fine.

 

Maybe the OP is using CAT-6 to extend his ethernet connection.

Professor

 • 

2.2K Messages

10 years ago

What's wrong with Cat 6 cable?

ACE - Expert

 • 

24.5K Messages

10 years ago

Nothing if you connect it correctly. I use CAT-6 (in a conduit) as an ethernet connection to connect my router to our HTS.

Former Employee

 • 

52 Messages

10 years ago

Hi there Graylane!  Just to start off, I'm not the resident expert on Microcells.  But I do the technical support and yes I am one of the robots that reads those scripts LOL.  Have you tried running the device in priority mode?  This involves situating the microcell between the modem and the router.  This way the mcell has a direct connection to the modem, completely bypassing the router.  Basically, you connect the ethernet port of the mcell to an open ethernet port on the modem, and the computer port of the mcell to the internet or wan port of the router.  This configuration gives 'priority' to the AT&T 3G Microcell over all other computer connections.  I would advise this if you have not tried it yet, and power them on in the order of modem / mcell / router, waiting for each device to fully green up before powering on the next one in the chain.

Teacher

 • 

12 Messages

10 years ago

scorpdog93,

 

Thanks for the attempt but, as I said in the first sentence of the post, I have had this MC connected directly to the modem, and it DOES work fine. It cannot stay that way, becuase i have a NEW DPH-154, it only has 1 RJ45 port not 2. SO; when connected to the Modem, I have no internet connection for the rest of my network.

Former Employee

 • 

52 Messages

10 years ago

Aaahhhhh gotcha yes that would indeed pose a problem. I'll be sure to post back here if i find any useful information for ya 🙂

ACE - Expert

 • 

24.5K Messages

10 years ago

@Graylane - can you give us a little more detailed desctiption of your setup? It still sounds like a router configuration issue but a little more clarity on how you physically have it setup would be helpful. Oh, and connecting directly to the modem is called the alternate connection. Priority is an old term that was confusing to some so it was changed to alternate. See my Tech Guide (link in my sig).

Professor

 • 

2.2K Messages

10 years ago

That "confusing to some" was me!  I'm the one who bugged you to change it to "alternate connection", remember?

 

The new Mcell has never worked with the D-Link and works when connected directly to the modem.  This eliminates the Mcell and the ISP as the problem.  Therefore, the router is the problem.  Could be a Ethernet port plug problem.  Really need to determine that the router ports are working. 

 

In addition, we have seen that some routers do not play well with the Mcell.  Your D-Link DGL-4100 is no longer in production from what I can find.  Even if the ports on the router prove to be functional, and you've done all the router settings recommendations, you may want to consider replacing the router.  This is assuming that you have completely eliminated any cabling issues by replacing the Ethernet cables with known good ones.

 

I'll bet there is a router incompatibility issue here somewhere.  In fact, I'll bet Otto's life on it!  The erratic flashing Ethernet light might also make me suspect the AC adapter if it weren't for the fact that the Mcell can be connected in the alternate manner and function properly.  

 

You can always return the new router if it isn't the problem....  

 

 

 

 

Not finding what you're looking for?
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.