Skip to main content
AT&T Community Forums
Willaguna

Tutor

 • 

4 Messages

Tue, Sep 26, 2017 11:31 PM

Visual Voicemail Issues in iOS 11

The "visual" part of Visual Voicemail is no longer functioning. I get a screen with a text box "Call Voicemail" which calls and requires me to enter my password. How do I get this function working properly?

Responses

Contributor

 • 

2 Messages

3 years ago

Also tried resetting my voicemail and I did the newest iOS update 11.2.2

Tutor

 • 

3 Messages

3 years ago

John, I went through the same issues that you went through. 

 

See my post here about how I got it fixed... Re: Re: Visual Voicemail not working

Contributor

 • 

1 Message

3 years ago

It is definitely an AT&T problem because my bf is with Verizon and doesn’t have this problem! We should switch and maybe AT&T will stop blaming Apple

Contributor

 • 

1 Message

3 years ago

I gave my iphone 7 to my husband when we switched carriers from Verizon to AT&T.

His voicemail just says, "call for voicemail" ... when I had that phone I had the visual voicemail feature working just fine.  I tried the network reset, the airplane mode reset, rebooting... I can't get the visual voicemail to work!  Help! 

Contributor

 • 

1 Message

3 years ago

Switching Airplane mode on/off worked the first time. Visual Voicemail message removed! Thank you

Contributor

 • 

1 Message

3 years ago

I was initially getting voicemail transcription, then it stopped.  Messages just said "transcription not available."  I tried resetting network settings, that did not work.  What WORKED was what someone else here suggested:  From my cell phone I called my own phone number, and voicemail answered.  It asked for a password--I put in the code I use to unlock my phone.  It then asked if I wanted to play my messages.  I played all my messages (as each one started playing, I pressed the button to "skip" the message).  After they were all done, voicemail gave me more options and I pressed the star button to exit.  After that, I had my transcription back 🙂

 

Teacher

 • 

16 Messages

3 years ago

Have tried all the suggestions. Nothing worked.  I figure it's never going to work right until AT&T and Apple decide to work together.

 

Teacher

 • 

16 Messages

3 years ago

OK Just gave it another shot...this time I changed my Siri to American English, set up Hey Siri again, then did a hard restart (Power button and volume down button on my 7+).  Called my cell from my home phone and left a message to myself, and it is now working.  Hadn't tried anything in awhile because nothing was working.  Did the "call from my phone and enter password" first, and nothing...then did the Siri thing again (It hadn't worked last time I tried) and Voila!! Hopefully it stays working.

Contributor

 • 

1 Message

3 years ago

I have had the same issue where visual voicemail will appear and display messages and then, later on, have a message to call voicemail.  I have turned the phone off and then back on to restore visual voicemail (I.e. reboot).  I agree that AT&T and Apple need to solve this annoying issue.

Contributor

 • 

1 Message

3 years ago

This did not work for me. I also called AT&T and was put through to someone in India whose dialect I could barely understand. He said to turn the phone off and back on and he would call me back. He did not. I have now gone through every step on here and still have no visual voicemail, just a box on the voicemail screen saying 'Call Voicemail' on it. This is so frustrating.

Contributor

 • 

1 Message

3 years ago

maybe this will work for you as it did me...

1. Turn airplane mode on then off

2. Go to settings, then to Siri & search, turn off "press home for Siri", confirm disable, then turn "press home for Siri", confirm enable.

3. Volume up once, volume down once, press and hold power button until the apple logo disappears.

4. Power back up and see if that worked

 

good luck

Contributor

 • 

3 Messages

2 years ago

So this worked for me:

- go into the Phone App

- press the voice mail icon bottom right of screen

- press Greeting upper left of screen

- set recording to Custom and then record a new greeting then save

 

now all my visual voice mails showed up!  I think the upgrade sets the value back to Default which is the ATT voice message.

 

hope this works for others!

Contributor

 • 

3 Messages

2 years ago

Well, that solution was short lived.  I set a Custom voice message and somehow the iPhone and ATT connected and I magically saw 8 voice messages, but all subsequent voice messages don't appear.     Granted, I'm on a pre-paid plan, but it shouldn't matter.

Contributor

 • 

3 Messages

2 years ago

So after looking at some other posts, I did two things:

1) Set Siri to US English (I had it to Australian) and went through the re-training of Siri.  Not sure why this would impact voice mail, but was seeing this as a possible solution

2) Went to Settings -> Phone -> Change Voicemail Password.  I entered in the same voicemail pin used when you press '1' on your phone keypad and are asked to enter your pin.

 

Did a test call and the Visual Voice Mail prompt and Voice Mail sound occurred.  I think #2 is the key.

Contributor

 • 

2 Messages

2 years ago

Hi there,

 

The variation that worked for me is the Settings > Phone > Change Voicemail Password

but "changed" the VM password to the current PIN.  I noticed after I did this and tried the long-hold 1 to access my VM it told me someone was already logged in with that PIN. This indicates that you need to log-in to VM with your PIN. I did a hard restart (sleep + home) just to make sure it stuck, and *fingers crossed* it's OK for now.

Get started...

Ask a new question