Announcements
You Could WIN A Year Of Wireless Service – Learn More!

Contributor

 • 

1 Message

Mon, May 28, 2018 7:51 AM

trying to unlock iphone6 but AT&T say's that IMEI # doesn't match a compatible device

I originally bought my daughter an iphone6 back in 2014 when we were still with AT&T and we switch to a different carrier back in 2016. I was able to unlock her iphone6 and my daughter have been using the phone for almost 2yrs under a different carrier. I recently brought in the phone to Apple to get a screen replaced but because the calibration test failed they had to give me a new phone. The new phone that they game me was an AT&T phone because they said that the device I brought in still says that it was an AT&T device. I was told that I just needed to request to get the new iphone unlock through AT&T. I tried requesting to unlock the phone but I keep getting an AT&T error stating that the IMEI entered doesn't match an AT&T device. I had called AT&T customer service and was told that I needed to activate the phone with an AT&T account which I did buy purchasing a prepaid sim card. The phone is activated, however, when I try to request to unlock the device again, it still gave me an error that IMEI# entered doesn't match an AT&T device.

 

Please help, my daughter has been without her phone for a week now and it's been really inconvenient for me.

Responses

Accepted Solution

Official Solution

Constructive

Employee

 • 

5.9K Messages

2 years ago

yikes inserting the prepaid card may be the downfall ATTCares may be able to help but as far as the unlock page is concerned you do not meet the criteria all the self service website sees is a new prepaid that hasnt had 6 months of service, good luck i hope it works out, when kids phones stop working its as if the world is ending for them

  • AT&T PREPAID (formerly GoPhone®) devices must have at least 6 months of active service.
-------------------INCLUDED IN EACH POST FOR CLARIFICATION______
While AT&T employees do look at forum posts from time to time, we are here to represent the forum with our experiences as customers and do not represent AT&T in any official capacity with our responses and do so on our own time unpaid and off the clock. As employees we are not rewarded nor compensated to participate in these forums This forum is comprised of regular customers to communicate with other customers to offer advice and share experiences same as any other user Although there is a small team of customer care specialists that monitor the forums the sheer volume of posts are simply too many posts for these agents to respond to each one of them.
*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
Brand User
ATTCares

Administrator

 • 

107.5K Messages

2 years ago

Hello @xxuauxx,


Thanks for posting on the Community Forums.


Sorry to hear about the issue with submitting an unlock request! I can definitely lend a hand and investigate further. In order to discuss this, I will be sending you a private message and gather more information. Please check your Forum's Inbox for this!


Thank you very much.


Donna, AT&T Community Specialist

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.
lizdance40

ACE - Sage

 • 

69.4K Messages

2 years ago

@xxuauxx

If you have any further trouble, file an FCC complaint

(The following is included after all posts to save typing) I don’t work for AT&T. My replies are based on experience and reading content available on the website. Our answers are honest, but not always appreciated. If you posted personal information, please edit and remove.
Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Contributor

 • 

3 Messages

9 months ago

I am having same issue and need help please.