Announcements
Don’t miss your chance to add AT&T Protect Advantage. Peace of mind, starting at $15 per month. Open enrollment ends 3/31. See all protection plans.

New Member

 • 

4 Messages

Tue, Jan 21, 2020 2:37 PM

Switched to AT&T: Gmail doesnt work. Says "No Internet Connection"

recently switched to AT&T. Noticed my GMAIL does not work. tell me to update password. When I open mail account settings anythgin i click says "No Connection to Internet". AT&T Forum recommended removing and re-adding account. I removed gmail account and when I click GOOGLE to add account it again says "No Connection to Internet". Everything else works fine. I have internet access through cellular and WiFi. Any suggestions??

THX

Responses

New Member

 • 

4 Messages

a month ago

*****UPDATE****. was able to fix issue. Shut off cellular and enabled WiFi. Then went back in and did “Add Account”. It allowed me to add Account and configure mail. Enabled cellular and then refreshed mail and worked fine

lizdance40

ACE - Sage

 • 

70.3K Messages

There is no reason to keep enabling and disabling cellular or Wi-Fi connection. Modern cell phones are very capable of doing this without wasting battery or data. Please leave both Wi-Fi and cellular on

The only reason to make such switches is if your phone is in a marginal coverage area and your phone doesn't connect to wifi calling well with a cell connection interfering.

🐾 (The following is included after all posts to save typing) I don’t work for AT&T. My replies are based on experience and reading content available on the website. Our answers are honest, but not always appreciated. If you posted personal information, please edit and remove.

Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

New Member

 • 

4 Messages

@lizdance40 thank you. I normally do leave both WiFi and cellular on. In trying to resolve my issue is why I shut them on/off and was able to find a combination that worked for me and hopefully for someone else having the same issue.

Thank you again

mobilemax

Employee

 • 

796 Messages

a month ago

Hello,

If you ever encounter a service or data issue like described, an easy trick on iPhone is “Settings > General > Reset (bottom) > Reset Network Settings (enter passcode and then red button).” This will restart phone quickly and get you 5e best local connection (great for travel, too).

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.

New Member

 • 

4 Messages

@mobilemax thank you mobilemax. That was the first option that I tried and it did not work. Appreciate the feedback. I should have noted that earlier.