Skip to main content
AT&T Community Forums
Announcements
Don’t miss your chance to add AT&T Protect Advantage. Peace of mind, starting at $15 per month. Open enrollment ends 8/31. See all protection plans.
D

New Member

 • 

2 Messages

Thu, Jul 2, 2020 10:20 PM

New iPhone purchased from Apple shows "No Service"

I purchased a new iPhone directly from Apple. The purchase process included my phone number and AT&T as the provider. When the phone arrived I went through the setup process correctly - transferred all Contacts, photos, etc. just fine. But when I restart the phone it displays "Searching..." for a few seconds then "No Service". My wife's iPhone is working fine. When I log into myATT and look at my devices it shows my phone number is still tied to my old Samsung phone. What do I need to do to get that changed? Thanks!

Responses

sandblaster

ACE - Expert

 • 

40.1K Messages

a month ago

Did the new iPhone come with a SIM card? If so, sounds like it hasn’t been activated. Does the old phone still have service? Either activate the new SIM card or move the SIM card from your old phone.

(edited)

Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

New Member

 • 

2 Messages

Moving the SIM card from the old phone worked!

 

Thanks sandy!

Get started...

Ask a new question