Skip to main content
AT&T Community Forums
Announcements
Learn how to Get the iPhone 12 Now!
N

New Member

 • 

1 Message

Wed, Sep 30, 2020 2:18 AM

iPhone can send but not receive sms messages

Yesterday at 3:18pm I could receive sms text messages, but since then I have been unable to receive sms text messages on my iphone xr. I can text my friends with android and they will receive it but when they text back I do not receive it. I can make calls and they can receive it and vice versa. 

 

 

 

I have restarted my network settings via att online as well as my iphone, checked send and receive that it is going to my phone number and not my apple id, and restarted my iphone multiple times. I have also checked my storage (I have 23.47 GB available out of 128 gb). I have checked for software and carrier updates and this morning installed the new ios update. Nothing has helped and I still see this issue (I can ask my sister to text me, from where she is sitting right next to me, and I do not get it.) I do get imessages. 

 

 

Please help!! Thank you

Responses

Brand User
ATTHelp

Community Support

 • 

136.7K Messages

21 days ago

Hey there @Nicole3200!

 

There are a couple of steps you can take which may help resolve your inability to receive text messages. Allow us to assist.

  • Make sure SMS is enabled by navigating to Settings > Messages and check that SMS, MMS, iMessage, and Group messaging are all enabled. At times, these settings can change without notice. Modifying your message's app can help resolve your experience.
  • There could be a rogue app in the background and on standby, thus, resulting in your inability to receive text messages. Force close all opened apps by:
    1. On an iPhone X or later and from the Home screen, swipe up from the bottom of the screen and pause slightly in the middle of the screen.
    2. Swipe right or left to find the app that you want to close.  
    3. Swipe up on the app's preview to close the app.
  • If you're using cellular data try resolving your experience by using Wi-Fi Calling exclusively. Using one or the other (cellular or Wi-Fi) usually helps resolve interferences from having both features active:
    1. From your Home screen, navigate to Settings Cellular.
      If an app isn't available on your Home screen, swipe left to access the App Library.
    2. Tap the Cellular Data switch to turn off (if on).

Let us know how this worked for you.

 

Lar, AT&T Community Specialist

Still need help? Ask a question! Our 1.4 million members typically respond within 1 hour.

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.

Get started...

Ask a new question