Skip to main content
AT&T Community Forums
Announcements
Protect your device against loss, theft, damage and get expert technical support. Open Enrollment Ends 3/31/21.
W

New Member

 • 

1 Message

Thu, Jan 21, 2021 8:43 PM

I appear as "Unknown" when I call all of my contacts

I appear as "Unknown" when I call all of my contacts.  "Show Caller ID" is turned on.  I am the only phone on my family plan with this issue.  I have had the problem since first getting the phone/line and it continue after recent upgrade to iPhone11.

Responses

Brand User
ATTHelp

Community Support

 • 

147.7K Messages

a month ago

Let's look into that for you, @Williamgg55!

 

Try resolving your experience by updating the name and mobile number of your wireless account that displays on Caller IDs.

  1. Go to Profile > Account users.
  2. If you have more than one account, select the wireless account from the drop-down at the top.
  3. If you have more than one device, select the number to update.
  4. Select Edit.
  5. Enter the info and select Continue.

Also, you will want to confirm Show My Caller ID is enabled on your iPhone 11:

  1. From the home screen, select the Settings app then scroll to and select Phone.
  2. Select Show My Caller ID then select Show My Caller ID switch to turn caller ID On.
    • Note: To block Caller ID on a per-call basis, dial *67 or #31# before the 10-digit phone number. (Examples: *679995554444 or #31#9995554444). To unblock Caller ID on a per-call basis, dial *82 before the 10-digit number. (Example: *829995554444).

Hopefully, this will resolve your experience. Let us know how this worked for you.

 

Lar, AT&T Community Specialist

Still need help? Ask a question! Our 1.4 million members typically respond within 1 hour.

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.

Get started...

Ask a new question