Skip to main content
AT&T Community Forums

Contributor

 • 

2 Messages

Tue, Oct 10, 2017 12:48 PM

How to Disable ATT Passpoint IPhone 8+ iOS 11.0.2

Hi,

 

Yesterday I was at a HomeDepot and nothing was loading on my phone.  It turned out I was on ATT-Passpoint WiFi. Not LTE. The phone won’t let me “forget” that ssid and when I toggle AutoJoin off it just switches back on. 

 

I don’t care what security ATT passpoint uses I just don’t want to auto join any public WiFi system. Anyone know how to disable this?

 

Thanks

Responses

lizdance40

ACE - Sage

 • 

76.3K Messages

3 years ago

Turn off “Ask to join networks” in settings

 

🐾 I don’t work for AT&T or any carrier. Never have, never will. My replies are based on experience and reading content available on the website. If you posted personal information, please edit and remove.

Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Contributor

 • 

2 Messages

3 years ago

Thanks for the response. I already have “Ask to join” off. 

 

Thanks again. 

lizdance40

ACE - Sage

 • 

76.3K Messages

3 years ago

Hmm.  Android has the ATT smart Wifi app included, which I disable for the same reason.  But your iPhone shouldn’t have that.   

Call ATT and ask for advanced tech support and if they don’t know, call Apple.  There must be a way to disable other than turning off wifi 

 

🐾 I don’t work for AT&T or any carrier. Never have, never will. My replies are based on experience and reading content available on the website. If you posted personal information, please edit and remove.

Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Contributor

 • 

2 Messages

3 years ago

I had the same issue. What finally worked is while at Home Depot I went into settings and turned off Wi-Fi (for anyone reading this who does not know, iOS 11 does not really turn off Wi-Fi or Bluetooth from the quick menu screen; you must go into settings to fully turn either off). When I turned Wi-Fi back on a minute later the option “do not auto connect” (or words to that effect) was magically available. That was for att pass point. There was another att Wi-Fi I was able to select “forget this network.”

 

To AT&T TROLLS. Screw you and your unsecured Wi-Fi. I don’t want it nor do I want it auto connecting. With all cyber security issues nowadays, why would you force me to auto connect to an unsecured network. YOU INVALIDS

lizdance40

ACE - Sage

 • 

76.3K Messages

3 years ago


huttler wrote:

To AT&T TROLLS. Screw you and your unsecured Wi-Fi. I don’t want it nor do I want it auto connecting. With all cyber security issues nowadays, why would you force me to auto connect to an unsecured network. YOU INVALIDS


@huttler   Seriously?   First of all, there are no ATT employees on this particular thread and Trolls defines a specific activity of flaming other posters or posting made up stuff.  

    This seems to be a defect in iPhones because my ATT android phones DO NOT auto connect to any Wifi.   

 

🐾 I don’t work for AT&T or any carrier. Never have, never will. My replies are based on experience and reading content available on the website. If you posted personal information, please edit and remove.

Award for Community Excellence 2019 Achiever*
*I am not an AT&T employee, and the views and opinions expressed on this forum are purely my own. Any product claim, statistic, quote, or other representation about a product or service should be verified with the manufacturer, provider, or party.

Contributor

 • 

2 Messages

3 years ago

Uh yeah ok. Maybe reread what I wrote. My displeasure is directed at ATT. I provided a solution to the OP that worked for me. Maybe the issue does solely lie in Apple iOS. Either way ATT is still exposing millions of its users to cyber criminals (not to mention terrible Wi-Fi that is so useless that cellular data is needed anyway). 

 

ATT is wrecking themselves. Checkout their latest quarterly earnings and stock price. They can’t get out of their own way

Contributor

 • 

1 Message

3 years ago

Good its very easy to do it from here thanks for the give me full guide to do it.

Contributor

 • 

1 Message

2 years ago

I am having the same issue in Canada with one of our local carriers.  They are also using IOS carrier updates to jam this down people's throats.

 

Funny enough though the symptom of "Auto Join" turning back on by itself doesn't happen to all users.  If you factory reset (and not restore your phone settings), and then try to turn off "Auto-Join", for me it sticks..

 

So something on Apple's side is broken and causing this Auto-Join to revert back to "On" unintentionally.

Get started...

Ask a new question