Military Appreciation: Exclusive savings for military, veterans, and their families!
Troubleshoot your device issues
GreggMack54's profile

Tutor

 • 

6 Messages

Tue, Oct 13, 2015 4:19 PM

Checking for Mail... on iPhone with iOS 9

Ever since I updated my AT&T iPhone 6 to Apple's iOS 9 (and now on 9.0.2), my email app is nowhere near as "snappy" as it used to be in getting my Email, which is also with AT&T Yahoo!.

When I open the Mail app, it might say that it was updated an hour ago, so when I manually force it to check (by pulling the screen down), it may or may not try to update the inbox (or All Sent, or Trash), and when it does actually try, it can take several seconds to do it.

 

This all used to be rather instantaneous before. I have reset the phone (hold down the Sleep and Home buttons until I saw the Apple logo), and even deleted all 4 of my email accounts and then re-entered them.  Thay all seem to work, but much slower than my previous experience with AT&T Wireless and AT&T Internet email. 

 

Does anyone have any other suggestions for things I should try?

Contributor

 • 

1 Message

7年前

I'm having the same problem!! Hoping someone has some suggestions.
cousintim

Professor

 • 

1.7K Messages

7年前

Is your Mail set to Fetch instead of Push?

 

If yes, the default setting is to fetch emails hourly.  To change: 

 

Settings>Mail, Contacts, Calendars>Fetch New Data.  Set Fetch to “Every 15 Minutes.”

 

Tutor

 • 

6 Messages

7年前

cousintim,

 

Settings>Mail, Contacts, Calendars>Fetch New Data has Push turned on, and each of the individual accounts below that are also showing that they are set for Push (and not Fetch).

 

Tutor

 • 

6 Messages

7年前

I have been trying a few things out, and I am getting a little better picture of the situation.

It appears that my two email accounts at @swbell.net are the real culprits. My email account at @att.net and my email account at @Anonymous.com check for new emails almost immediately.

 

I have been searching through the Internet -> Emails forums, but haven't found anything being reported over there.  I have posted this over on the Apple Support Forums as well, but nothing has been suggested yet.

 

Right now it appears that it's probably not an iPhone or iOS 9 issue, but an AT&T old email domain issue.  I have no idea what to do to fix this. I have already deleted these two email accounts from my iPhone (and then re-added them) several times, and that's simply not going to get it done.  On the iPhone, when I "Add Account", I select the Yahoo! option.

Tutor

 • 

6 Messages

7年前

This problem was resolved by my going to the AT&T U-verse support and getting into a chat session with an agent there. I explained that I was able to get my various email accounts just fine by using Outlook on my desktop computer, and by using the web browser method of accessing my email accounts. I told her that my problem only existed when I was attempting to get email from my two email accounts at @swbell.net WHEN USING MY iPHONE. When using my iPhone, I was not having any problems with my accounts at @att.net and @Anonymous.com (I know that this one isn't controlled by AT&T).

 

The chat agent said that she would have a "mobile device" technical expert call me back in the next 5 - 15 minutes. I never got that call - but maybe I gave them enough information to point them in the right direction. 4 hours later all of my email problems magically went away, and I had not changed anything during that time....

Need help?
The new iPhone 13
Fix, replace or check device delivery
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.