Troubleshoot your device issues
E

New Member

 • 

2 Messages

Sun, Jul 26, 2020 2:33 AM

Can't text from iPhone 7 to Android/Samsung/etc

I can text other iPhones via iMessage, but non-iPhones it won't work.  I have to toggle between 4G/LTE, and the resend, for a text to go through.  I have to "reset" like this every time I want to send a text. Apple support couldn't fix it and said it's a carrier issues.  (I've tried all their fixes [factory reset, network settings reset, MMS/SMS are on, logged out of and back in to iMessage, etc, etc], and still the only thing that works is toggling between 4G/LTE. I shouldn't have to do that every time I want to text a noniPhone though, right?)

 

Anyone know what's going on?  At this point, I'm not sure what else to try.  I'm running Catalina on my Mac, my iPhone is up to date.  Seriously, what's going on??

Fl_retire

ACE - Professor

 • 

2.5K Messages

2 y ago

Check your settings and see if Messages> Send as SMS is turned on. Also if any of your friends changed from iPhone to Android thy may need to follow instructions listed below. 

https://support.google.com/android/answer/6156081?hl=en

 

 

(edited)

ATTHelp

Community Support

 • 

192.1K Messages

2 y ago

Hello, @emmohat,

 

Thank you for reaching out. We'd love to help with this. When did this begin? Were you able to text Android devices before or has it behaved like this since you began using this device? Which iOS is it running? Please let us know.

 

James, AT&T Community Specialist

New Member

 • 

2 Messages

2 y ago

This has been going on for a little while now, a few months.  (But I'm a teacher, so I didn't have the freetime to spend all day on the phone with tech support until summer break.)  I used to be able to text Androids/Samsung, but can't anymore.  This coincided with an iOS update and a move to a new part of town.  I've gone through all of Apple's support steps to ensure it's not an iOS issue, and they say it's a network issue; I'm running the most current iOS.  I was on the phone with ATT a few days ago and we didn't change any of my settings, but they ran some kind of test and I got a report that nothing unusual was found. Since my call to ATT I've been able to text more consistently, but now photos continue to be an issue.  I've tried reducing the file size to send but the issue persists.

Need help?
The new iPhone 13
Fix, replace or check device delivery
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.