Available Now: Buy the new iPhone 14, iPhone 14 Pro and iPhone 14 Pro Max from AT&T!
The new iPhone 14
Infoboy2u's profile

Tutor

 • 

3 Messages

Tue, Oct 8, 2019 4:02 PM

CANNOT SEND GROUP TEXTS CONTAINING ANDROID USERS!

Hello! 

 

I made a trip abroad using Google Fi a few months ago using an iphone xs max. I got back and popped my ATT sim back in. Since then I have been unable to respond to any group text with an android user in it. All "iphone only" group threads work. individual texts with android users works. I can receive the group thread texts, it just wont let me respond to them. I've done every reset imaginable including deleting the thread and starting a new one to no avail. I have since upgraded to an iphone 11 and the problem persists. I've been through two levels of ATT support and pushed to a third that I was told would get back to me in three days. Here we are almost two weeks later with no response. Getting frustrated. Has anyone else had this issue? I did have to change APN settings to use Fi but since putting in ATT sim those settings are no longer accessible to me.

Accepted Solution

New Member

 • 

1 Message

2 y مضت

Like everyone said, using the Google Fi SIM card trick will work. However, if you don’t have the SIM anymore, you can also just reset all settings.

 

General > Reset > Reset all settings

 

Resetting just the network setting will not work.

 

After doing that, your group texts and picture texts should work, however you will need to put your setting back the way they were before manually (including your wallpaper and dark mode if you have it enabled).

Official Solution

ATTHelp

Community Support

 • 

200.4K Messages

3 y مضت

Hello, @Infoboy2u,

 

Updating this response with the latest information:

We have received feedback that some customers were experiencing SMS or MMS related issues after switching to AT&T from using GoogleFi. The issue has been resolved.  Please follow the below steps to update your device.

  1. Power off the device having difficulties
  2. Remove the SIM card from the device
  3. Power on the device without the SIM included
  4. Go to Settings > General > Reset > Reset all settings locally on the device
  5. Power the device back off
  6. Insert the SIM card back in the device
  7. Power up device

These steps will remove the GoogleFi profile from the device and resolve the issue.

Thanks!

 

James, AT&T Community Specialist

(edited)

New Member

 • 

3 Messages

Reposting under the original rather than the last thread....

Found a fix for those of you still having issues. Don't know which steps are relevant but here was my troubleshooting journey. It worked in the end.

1. Reset network settings.

2. Reinserted googlefi sim back into phone, cleared carrier settings. (Intent was just to undo what googlefi had us set up in the beginning. Obviously, this needs to be set up again if you want to use google fi again)

3. Reinserted ATT sim back into phone.

4. Turned off cell data.

5. Turned off imessage.

6. Turned off sms/mms.

7. Restarted phone.

Im assuming that reinserting the googlefi sim and resetting the carrier settings did the trick but I have no clue.

New Member

 • 

5 Messages

@ATTHelp Please tell us you're joking. Every commenter on this thread has tried that horribly useless suggestion and it does nothing.

Tutor

 • 

3 Messages

3 y مضت

It didn’t work. iOS 13.1.3. Hasn’t worked since well before this build. ATT Level 3 tech supportstill hasnt gotten back to me. This is getting silly that they can’t fix this

Contributor

 • 

2 Messages

3 y مضت

I have the same issue. iPhone XR on iOS 13.1.3. Prepaid account 

Contributor

 • 

1 Message

3 y مضت

I created an account here just to say I have the exact same problem! Used Google Fi in Oct. and once I got back group messages with Android users just don’t work. Tried all the same troubleshooting techniques.

Contributor

 • 

2 Messages

3 y مضت

I found my issue resolved when I did a full reset of all settings. General > Reset > Reset All Settings. A pain but it fixed my issue. 

Tutor

 • 

3 Messages

3 y مضت

YES! Exactly! To use it you have to change the MMS settings manually, but once put the ATT sim back in the ability to change those settings disappears. Its like they are forever changed on the back end. Mine issue still isnt fixed and this travel was back months ago. Im starting to worry the whole issue is attached to my phone number now since i have a new iphone and the issue persists. ATT STILL HASN'T GOTTEN BACK TO ME WITH A FIX.

New Member

 • 

3 Messages

3 y مضت

I have the same issue. Is this seriously still a problem they haven't figured out how to fix? I did the exact same thing, by the way. I went overseas with Google Fi, came back, switched back to AT&T, and now I can't respond to group texts that include android users. I can receive them just fine.

(edited)

New Member

 • 

2 Messages

My husband and I are having the exact same issues. We used Google Fi and recently switched to AT&T. We can receive group messages containing android users but we can't respond. My husband was on support with AT&T and they said they would get back to him but they haven't. This is maddening...

New Member

 • 

2 Messages

Still no response from AT&T but found this Reddit that recommends to find your Google Fi SIM card and change the settings and then re-insert your AT&T SIM. It worked like a charm.

https://www.reddit.com/r/ProjectFi/comments/bsxorx/left_googlefi_and_now_text_messaging_doesnt_work/?utm_source=share&utm_medium=ios_app

New Member

 • 

3 Messages

Found a fix for those of you still having issues. Don't know which steps are relevant but here was my troubleshooting journey. It worked in the end.

1. Reset network settings.

2. Reinserted googlefi sim back into phone, cleared carrier settings. (Intent was just to undo what googlefi had us set up in the beginning. Obviously, this needs to be set up again if you want to use google fi again)

3. Reinserted ATT sim back into phone.

4. Turned off cell data.

5. Turned off imessage.

6. Turned off sms/mms.

7. Restarted phone.

Im assuming that reinserting the googlefi sim and resetting the carrier settings did the trick but I have no clue.

New Member

 • 

3 Messages

3 y مضت

Reposting under the original rather than the last thread....

Found a fix for those of you still having issues. Don't know which steps are relevant but here was my troubleshooting journey. It worked in the end.

1. Reset network settings.

2. Reinserted googlefi sim back into phone, cleared carrier settings. (Intent was just to undo what googlefi had us set up in the beginning. Obviously, this needs to be set up again if you want to use google fi again)

3. Reinserted ATT sim back into phone.

4. Turned off cell data.

5. Turned off imessage.

6. Turned off sms/mms.

7. Restarted phone.

Im assuming that reinserting the googlefi sim and resetting the carrier settings did the trick but I have no clue.

New Member

 • 

6 Messages

I am having the same issue. Switched from straight talk in Nov 2019 to ATT. Got a new iPhone XR, since day 1 I can’t respond to group chats with android users in them also I cannot send MMS messages to android users. I fought with ATT for a month and they said it was an Apple issue. I have been back and forth with Apple for 4 months now and I just now got a new IPhone under warrantee from Apple. Switched all my stuff over and I’m still having the same issue. I no longer have my straight talk SIM card to do the carrier settings, but even then, my other sim never went in to this phone so could that be the issue still?

New Member

 • 

5 Messages

3 y مضت

This is absurd. I was on Google fi (traveling abroad, as others here have mentioned). Then when I came back to the states, I was briefly on T-mobile, and now I've switched to AT&T. And just like the rest of you, can't send messages in group conversations with an android. And my Fiancee has an android lol. I have absolutely no idea where my Google Fi sim card is, so I guess I'm screwed?

New Member

 • 

6 Messages

@thespitzmeister I just fixed mine. 5 months later and I Finally did it. So, I did a factory reset on the iPhone. When it asked if I wanted to restore the iPhone I selected the prompt that said do not restore apps and data (something along those lines), it’s the last option of the 5. So basically I booted the phone up as a new iPhone without restoring anything. I put my Apple ID in a the phone came up without any of my data in it. I tried the messaging and it worked, group chat with android users and sent a picture to an android phone and it all worked. After this I was unable to get my apps to show up. So I did a restore on the phone from my last back up. All my stuff was back on the phone and the issue with the messaging came back. So I went to settings and reset all settings, the first choice. Once this was completed all of my stuff was on my phone and my messaging is working. Give it a shot guys, hope it works for you. Now, since I got a replacement phone from apple im not sure if the new phone was the fix and I just had to remove the messed up settings that my backup was pulling over, or if the old phone was fine and I just needed to do these step. Unsure, but my phone works now.

New Member

 • 

3 Messages

@thespitzmeister call Google Fi. They sent me a free SIM card when I explained the situation, and it worked like a charm. Just insert it, go to the settings they had you change, and change them back, like the other posts in this thread suggested.

New Member

 • 

3 Messages

in a way, it is apple’s fault, because they don’t let you access the menu required until you have the right SIM card installed. And the settings don’t get reset when you try to reset them.

New Member

 • 

5 Messages

@sndrsn Thank you!!! Will try this.

New Member

 • 

5 Messages

@Helicrewchief Wow, that sounds like an epic journey. Congrats on getting it fixed! I'll try this fix, if the Google Fi sim card fix doesn't work.

New Member

 • 

1 Message

2 y مضت

I had this same issue and was about to go to ATT and switch until I checked this article. Didn’t have to reset network settings, but I did insert a google fi sim, clear the network settings under ‘cellular’ and was able to text again. I loved GoogleFi and would have stayed, but ATT has better reception in the house we are moving to. Hope this helps someone going through the hours of visiting the att store / being escalated to tier 2 tech support. 

New Member

 • 

1 Message

2 y مضت

Popping the Google Fi Sim back in and clearing the Settings definitely fixed the issue.  I've been stuck with this issue for the whole year and I forgot I had inputed a proxy in the SMS settings to make it work for the country I went too.  I couldn't see the settings with the ATT SIM card in, but I could definitely see them with the Google Fi SIM card once I put it back in.   Once I cleared the settings and turned off the phone and swapped the ATT SIM card back in everything worked as expected again.

New Member

 • 

1 Message

2 y مضت

I'll give my update on this since I just figured it out with the help of many others who posted solutions here. (I actually joined this forum just to do a write up because it is confusing and can save others hours of effort). I spent several hours over many months dealing with this; many hours with AT&T corporate technical support & in their retail stores trying out all combinations.

The big 'ah-ha' moment for me was realizing that the Google Fi (and maybe other mvno options) Cellular Data Network settings (i.e. APN & MMSC) used for their plans are stuck to that type of SIM (physical or eSIM) on the iPhone. When you switch to using an AT&T SIM, the ability to change these settings is 'hidden' by AT&T but the actual values set for Google FI (or MVNOs) still remains set/active on your iPhone. THIS IS WHAT BREAKS MMS/SMS.

Second 'ah-ha', it actually is possible to operate in Dual-SIM mode on iPhone with AT&T and Google Fi and have 100% functioning MMS/SMS.... but holy moses the steps are very specific.

Here's my final setup because the type of SIM for the specific carrier (and their settings) matter in my example below.

  • AT&T on Physical SIM
  • Google Fi on eSIM (but I have the Physical SIM and SIM code still - this is a MUST)
  • iPhone 12 Pro (iOS 14.4)

So adding Google Fi always starts with the physical SIM activation. In doing so, their instructions say to configure the settings in Settings > Cellular > Cellular Data Network. (This is 'hidden' when using an AT&T SIM (either physical or eSIM). These are the settings that cause issues with AT&T SMS/MMS.

  1. My phone starts out life with only one Cellular plan, AT&T on a physical SIM... no problems so far. 
  2. I add Google Fi service, requiring me to swap my AT&T SIM card out, and put in my Google Fi SIM. (iOS will still have the AT&T cellular plan but it will show with "No SIM" under Settings > Cellular when you pull the AT&T SIM card out)
  3. I download and launch the Google Fi iOS app to start activation
  4. The instructions say to update my APN + MMSC settings in Settings > Cellular > Cellular Data
  5. Everything activates, I reboot my phone.
  6. *In that same menu you change settings in Step 4 above, you also have "Reset Settings" <-- make note of this for later

I want to run in Dual SIM and the most efficient, self-service, method I have available at home is to make Google Fi eSIM. (AT&T's process is more complicated and requires them to help you)

To get Google Fi to eSIM, follow their published online instructions. They're basically as follows:

  1. Make sure your physical SIM is inserted. (It would be if you continued from above)
  2. Delete and reinstall the Google Fi iOS app.
  3. Sign in to the app with your Fi account.
  4. When prompted, tap Download your SIM.
  5. Then add the cellular plan with QR code as instructed. (I recommend you label this plan with something you will easily identify this is the eSIM version. It will help later when you need to distinguish which Google Fi plan was for the physical SIM once you've changed to eSIM)
  6. Return to the Google Fi iOS app, finish the steps, and power off your phone when they say you need to reboot.

So you reboot your phone - but your instinct may be to remove the now unneeded physical Google Fi SIM and put your AT&T SIM back in the tray. If you do this, those Cellular Data Network settings you first entered will still be set AGAINST your physical SIM slot. Using the AT&T SIM card will hide your ability to get back to this Cellular Data Network menu and reset these settings on that SIM slot - thus your SMS/MMS issue will persist when the AT&T physical SIM is used.

Turn on your phone WITH the Google FI physical SIM still inserted. You can check the Google Fi app under 'PLAN' > Manage plan > Devices > iPhone##,# , and it should show you 'Google Fi eSIM' to confirm. You should also have working service from Google Fi.

  • Go back to Settings > Cellular > Under 'Cellular Plans': Choose the plan for the physical Google Fi SIM (NOT THE eSIM) > Cellular Data Network > Reset Settings.
  • Now you can back out to Carrier (You can choose to Remove Cellular Plan, or not)
  • Eject the Google Fi SIM.
  • Replace the AT&T SIM
  • SMS/MMS on AT&T should work as normal (I didn't need to reboot or toggle cellular radios) 
  • Both AT&T and Google Fi service should be working together normally

If you find a left over cellular plan in Settings > Cellular that says "No SIM", you can ignore it or remove it... 

These steps, especially for Google Fi stuff, could change later but they are accurate currently.

Just as JamWils posted earlier: You can perform this settings reset at anytime if you first swap your active AT&T physical SIM out, and put your Google Fi SIM back in (even if you're using Google Fi as eSIM). 

I hope this helps - it seems nobody at AT&T really understands the underlying issue here. I promise you do not need to reset any other network settings, or iPhone factory resets to get this to work.

(edited)

Need help?
The new iPhone 14
Fix, replace or check device delivery
New to AT&T Community?
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.