Skip to main content
AT&T Community Forums



1 Message

Mon, Mar 26, 2018 6:23 AM

Cannot connect to the internet on mobile device

Hello when I try and connect to the internet using LTE  I get the following message “AT&T Free Message: Your attempt to connect to data service was unsuccessful. Please try again later.”. I can connect via WiFi but not when using data. I have unlimited data but this just started happening. If you could please help resolve asap that’d be much appreciated. Thanks.


Brand User

Community Support


136.4K Messages

3 years ago

Hello @nickbrell,

Welcome to the Community Forums! This is a very interesting issue, but I would be more than willing to look into it.

Have you heard of our Troubleshoot & Resolve Tool? It’s like having your own personal technical support assistant! Once here, choose your device and select Messaging under Service/network issues. Answer all the questions as accurately as possible to receive the best resolution.

Resetting network settings is a great way to troubleshoot network related issues. You can do this by going to Settings > General > Reset > Reset Network Settings; ensure you restart the device after doing this. You might need to re-enter your Wi-Fi password to reconnect to your wireless network.

Removing and reinserting your SIM card is another great way of troubleshooting network related issues. For instructions on how to do this, use our Device Support Tool. Just like before, choose your phone then go to Learn how to use > About your device > Insert SIM/Phone Assembly. Ensure your device is completely powered off before removing the SIM.

If you run into any more trouble, please don’t hesitate to let us know! I hope you have a wonderful rest of your day!

Jax, AT&T Community Specialist

Still need help? Ask a question! Our 1.4 million members typically respond within 1 hour.

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.

New Member


1 Message

3 months ago

I'm getting the same error message and I try both of your procedures and it still doesn't work

New Member


2 Messages

22 days ago

I'm having the exact same problem, were you able to get it fixed?

Get started...

Ask a new question