Troubleshoot your device issues
M

New Member

 • 

14 Messages

Wed, Dec 9, 2020 9:40 PM

AT&T e-mail requiring a new password continuous loop

I am having a login problem that is causing a looping issue.  I have seen this same issue posted in this forum and I have added my comments to this other thread, however the AT&T help specialist has not responded to any of my comments in that thread (only the original member that started the thread.  So, I am re-posting most of what I had said on a new thread in hopes in getting a solution to my problem.  

First my primary account and one sub-account stopped working.  I received a message that I had an Account Error.  I would click on the details and received a message that said:

Cannot Get Mail
No Password provided for [Email address] 

Please go to Mail Account Settings and enter a password.

These accounts had been working for many years and the passwords were indeed entered in the mail settings.  I had the problem in all of my devices: iPhone (12 Pro Max), my iPad Pro (3rd Generation) and my MacBook Pro.  In order to try to solve this issue, I started a chat with support, and I was told to delete the accounts in my mail apps and reinstall the accounts (I was told to use the yahoo! set up to re-establish my accounts. I did this, and it seem to solve the problem for these two email addresses. 

Then my wife’s sub-account stopped working. Just like when my account stopped working, it failed on all of her devices. So, I tried deleting the account in her mail app and reinstalling it. However, this time after I entered the Account e-mail address on the Yahoo page, I was taken to the AT&T sign in page.  I entered the e-mail address and password and then I was taken to a page that asked me to set my personal password.  No matter what I entered on this page I was taken back to the Sign In page, and then after I signed in again, I was again directed to the Set Personal Password.  I have tried to enter the current password at this final page and I am thrown back into the loop.  I have tried to change the password here and I still get thrown back into the loop (and then I get a letter in the regular mail from AT&T telling me that the password was changed for my sub-account).

Then a few days later another one of my sub-accounts stopped working, again trying to reinstall the account it went into this same loop. And just a couple of days later (the day I started commenting in the other thread) another one of my sub-accounts stop working. It seems that all of my sub-accounts are failing one at a time every few of days. 

I have tried to reinstall the sub-account on all three of my devices all with the same results, getting stuck in that loop. I even tried to download a different mail client to see if it was a problem with the Apple Apps. I had the same problem getting stuck in the loop.

We can only access these sub-accounts now through a browser. This is a problem because we can only review one account at a time and now we do not get notified when we have new mail. So we have to constantly be checking each account separately to see if we have received any new mail.  This is time consuming and not very convenient.

I am aware of that yahoo!/AT&T have initiated new security protocols, however as this looping problem has occurred on six different devices that all worked correctly prior to these mail changes, I can only surmise that there is a bug and this new mail protocol that needs to be fixed.

Now ATTHelp on the other thread had posted a few items to try to solve the issue and all of us on this other thread tried these to fix the issue unfortunately none of them solved the problem.  What I have tried is:

Uninstall the account and then reinstall it.  This is where the loop issue started.

ATTHelp provided a link to help trouble shoot the issue, unfortunately when I clicked on the link it took me to a page that said:

Alert! Unfortunately, we are unable to access Troubleshoot & Resolve at this time. For further assistance, please visit att.com/esupport. 

However, I have added e-mail accounts to my devices many times.  The last time was when I was in a chat with AT&T support.  As I stated earlier, he had told me to use the yahoo! setup for these accounts.  To show you that I understand how to add an account to my mail App, I will list the steps involved (along with screen shots of each step) to show you that we are following the steps outlined and still get caught into this loop.

1. I navigate to my settings, then click on Mail, then click on Add Account.
2. This takes me to the add account page (see 1-Add_account.PNG)
3. I click on the yahoo! link to add the account
4. This takes me to a yahoo! Sign In page (see 2-SignIn_Yahoo.PNG)
5. Here I enter the e-mail address of the recently deleted sub-account.
6. After I click Next, I am taken to a Sign In page for AT&T (see 3-SignIn_ATT.PNG)
7. I enter my credentials here (I even check the box to show the password to make sure it is correct).
8. When I click Sign In I am taken to the Set Personal Password page (see 4-Set_Personal_Password.PNG). And this is where the loop starts.

Next ATTHelp suggested that we log into our account on our browser on our phone instead of the Mail App.  He said that sometimes this clears the logjam.  This was no help for me.  I tried his suggestion of logging into my sub-accounts on my iPhone browser (Safari). I tried this with two different accounts. Even though I could get to my e-mail through the Browser, still no luck in the Mail App and I am still getting stuck in the loop. 


ATTHelp had asked in the other thread if the email was a yahoo! account or one of the AT&T related email accounts.  My response was I am using the standard Apple mail client (the one that comes with iOS on my phone & iPad).  I have had this account since 2004 when I first got U-verse (and had my original e-mail address since the 90’s when I was on DSL). Up until AT&T/yahoo! pushed this security patch I have not had any issues with retrieving my e-mail on any of my devices. 


In the last post by ATTHelp he provided two suggestions: 


Sounds like you may need to Verify your Email Settings to make sure they're set to work with your email through mail applications.  I have done this step.  The Yahoo set up accounts (my primary e-mail address and one sub-account e-mail) work using the Yahoo imap.mail.yahoo.com for inbound & smtp.mail.yahoo.com for outbound.  I have verified that the other sub-accounts are using the correct settings (from the AT&T support) imap.mail.att.net Server Port 993 for inbound and smtp.mail.att.net Server Port 587 for outbound mail.


You may also need to resync your account, which you can do by Resetting your Password.  I have also reset my password for multiple sub-accounts that are not working.  I waited 24 hours to see it the system will resync and this has not solved this issue either.


Sorry for the long post, but I wanted to let you know that I have tried all of these solutions and am still having issues getting into these sub-accounts.

New Member

 • 

12 Messages

1年前

Thanks MRSinks,

Did you create your accounts again using the YAHOO, or OTHER selection in the Mail/Accounts area?

Copy that - you've used the standard account pw, and not the secure mail key (smk)

I was also told that Apple OS Mail was OAuth compliant, but no explanation why it refuses to work on certain accounts.

So far, everyone is just in a wait and see mode?

New Member

 • 

14 Messages

1年前

sdpcmedics, originally (before they stopped working) I was using the OTHER link to create my sub-accounts, however after my original discussion with AT&T service where he advised me to use YAHOO!, as the sub-accounts started working again I used YAHOO! 

I agree with you there seems to be no rhyme or reason why the accounts just stop working and in my case just start working again. I find very frustrating is that when you contact AT&T they try to tell you the problem is on your end as opposed to trying to solve it on their end. 

Need help?
The new iPhone 13
Fix, replace or check device delivery
New to the AT&T Community? Start by visiting the Community How-To.
New to the AT&T Community?
Visit the Community How-To.