Skip to main content
AT&T Community Forums

Tutor

 • 

2 Messages

Wed, Jun 7, 2017 1:21 PM

why are my text messages and responses out of order

Why do my text messages display out of order?

Responses

Accepted Solution

Official Solution

Brand User
ATTHelp

Community Support

 • 

124.1K Messages

3 years ago

Hello @marc13!

 

I am so sorry to hear you have been having issues with your text messages being out of order. I completely understand how this can become an annoyance; since it happened to me a few times as well. I would be more than happy to assist you!

 

A lot of times when this happens, it is usually because of an error with the phone’s internal time. Don’t worry though; this is a very easy fix! I would be glad to walk you through how to change this. Depending on your phones, these steps may vary:

 

  1. Go to Settings.
  2. Select Date and time.
  3. Select Automatic date and time switch, to enable feature.
  4. Adjust settings as needed.

 

It is very important your phone’s internal clock is set to automatic. If you choose to manually set your watch, you are more than welcome to. However please keep in mind; this will affect certain areas of your device such as your messages. If your clock is fast, they may, at times, come in out of order.

 

For exact steps on how to change your phone’s internal clock, I would recommend visiting out Device Support page. Once you arrive on the page, please be sure to select your phone’s make and model. Then please click on Tutorials > Settings > Date & Time.

 

I hope you find this information beneficial. Please let me know if you have any other questions. Have a fantastic rest of your day!

 

Austin, AT&T Community Specialist

Still need help? Ask a question! Our 1.4 million members typically respond within 1 hour.

*I am an AT&T employee, and the postings on this site are my own and don't necessarily represent AT&T's position, strategies or opinions.

Tutor

 • 

2 Messages

3 years ago

Thank you. This seems to have taken care of my issue.

Contributor

 • 

1 Message

3 years ago

This did not fix the issue I am having with my SMS and iMessages coming in late and out of order.

Melkirby

Tutor

 • 

3 Messages

3 years ago

AT&T this did not fix my text messages either. I did what you suggested going to settings.... my date/time were already set to automatic, but I turned it off and then back on..... it’s still happening. It seems many others are having this same issue. 

Contributor

 • 

1 Message

3 years ago

Exact same problem here

Contributor

 • 

1 Message

3 years ago

Same problem here and I did what they suggested. Didn’t change anything. 

Tutor

 • 

2 Messages

2 years ago

I tried following the steps that were suggested to fix this issue.  My setting was already set to automatic and I am having the same issue.  When I send a text message, the recipients response appears on my screen in the left column above (earlier than) my comment.

Tutor

 • 

2 Messages

2 years ago

I am having this same issue so I followed the instructions outlined above but my setting was on automatic already.  

When I text someone and they respond, the recipient's response is listed above mine (shown as earlier in time) than my text.

Melkirby

Tutor

 • 

3 Messages

2 years ago

After not hearing back from AT&T...... I did a hard reset and it seemed to have fixed the problem (for now😩). 

Contributor

 • 

1 Message

2 years ago

Hi,

 

i am having thie problem as well.  My phone does have the clock set to auto... so that’s not the issue.

 

basically I send a text it goes through and the person responds. However their response is showing up before the text I sent.  It’s very weird. How do I fix this?

Contributor

 • 

1 Message

2 years ago

Same problem!  Just started today and the clock is set to automatically 

Contributor

 • 

1 Message

2 years ago

I'm having the same issue, but my date & time is already set to automatic. Any other suggestions? I have an iPhone 6S.

 

Contributor

 • 

1 Message

2 years ago

SOLVED - PART 2

 

If you followed these steps and found your Automatic Date is already enabled,

 

1.) Turn it off.  

2.) Send a few messages to anybody.  Including yourself.  

3.) Then go back into settings and re-enable the Automatic Date.

4.) Lastly do a hard reset (on iPad or iPhone (prior to iPhone X) hold home button and power button simultaneously until you see the white Apple logo).  And viola they should start sorting correctly once your device has finished resetting.  

 

Worked for me anyway.  

 

ORIGINAL INSTRUCTIONS

Go to Settings.
Select Date and time.
Select Automatic date and time switch, to enable feature.
Adjust settings as needed.

Contributor

 • 

1 Message

2 years ago

I turned the time I turned the time and date off and on again since mine was already enabled. Turned my iPhone off and back on again and now it works fine!

Contributor

 • 

1 Message

2 years ago

this did not take care of my issue.  I called AT&T.  Here is what we did:

Go to settings>>general>>reset>>reset network settings

Also, AT&T will re-


@mnaks424 wrote:

I turned the time I turned the time and date off and on again since mine was already enabled. Turned my iPhone off and back on again and now it works fine!



provision SMS network settings for your number/Phone.

Issue resolved within 3 minutes.

Get started...

Ask a new question